Tilt was working but now gone?

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links, files or images until they have at least 4 posts.
Post Reply
tecnition
New User
Posts: 4
Joined: Tue Apr 30, 2024 9:54 pm

Tilt was working but now gone?

Post by tecnition »

Please fill in this template when posting!
XMBC Version: v2.20.5
Installed or Portable version: Installed
Windows Version: Windows 10 22H2 19045.4291
Mouse Information (brand/model): HyperX Pulsefire Haste
Relevant Computer Information (CPU, RAM etc): 5950x 16core w/ 128MB of RAM
Did the problem occur after an upgrade of XMBC? (If so, from what version?): No
Did the problem occur after a Windows update/upgrade? (If so, from what version?): No
How long have you used XMBC?: New User
What language and keyboard layout do you use in Windows?: English

Been using XMBC, really enjoying it.

Was using it with my HyperX Pulsefire Haste

Wanted to upgrade for work, got the Steelseries Aerox 9 MMO Mouse

Plugged it in, loaded up XMBC, software sees the left and right mouse tilt perfectly

Do a firmware update on the new mouse, restart, XMBC no longer sees the mouse tilt.

Does XMBC think I'm still using the HyperX because that mouse does not have tilt wheel capabilities or did Steelseries mess up my day?

Thanks for your time.
jhonGL
Member
Posts: 15
Joined: Fri May 12, 2023 1:10 pm

Re: Tilt was working but now gone?

Post by jhonGL »

Check the SteelSeries software and see if the tilt buttons are actually set to tilt left an right. Maybe they defaulted to something else after the fw upgrade.
User avatar
phil
Site Admin
Posts: 7705
Joined: Sun Apr 06, 2003 11:12 pm

Re: Tilt was working but now gone?

Post by phil »

tecnition wrote: Fri Jun 07, 2024 3:56 am Does XMBC think I'm still using the HyperX because that mouse does not have tilt wheel capabilities or did Steelseries mess up my day?
XMBC has no idea of the physical device, it is not a device driver, it simply hooks into the Windows mouse message queue. So it makes no different what sends the messages. What appears to have happened is that the firmware update has changed the messages that the mouse sends (so they are not sent as the usual tilt messages through the Windows mouse message system).

As JhonGL suggests, this may be configurable in the original mouse software (Logitech are well know for this). The question will be, if the settings are available to change, does that change apply "for good" without having the original (Steelseries) mouse software running once you have made the change (not that that would be a problem, other than taking more system resources than perhaps necessary).

I've never used a Steelseries mouse so I cant answer that, but in the case of Logitech, it very much depends on the mouse itself - so there is no clear answer in that case either! Something you will have to experiment with I'm afraid.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9/G604/M720/MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 1Tb NVME, 2x2TB WD Black (RAID1)
Post Reply