Specific Windows Not Working

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links, files or images until they have at least 4 posts.
Post Reply
Hujakuja
New User
Posts: 2
Joined: Wed Aug 30, 2023 4:20 pm

Specific Windows Not Working

Post by Hujakuja »

Hello.

I have Youtube PWA web app installed thru the Edge browser.

I want to disable middle click and right click for the YouTube webb app only. When I select the specific window (Yt-app window) it also disables right click and middle click for the entire browser; which is not what I want.

What wrong am I doing? Or is this not possible?

(FYI: Pwa app is basically a website that has its own window and is dependent on the browser)
User avatar
phil
Site Admin
Posts: 7602
Joined: Sun Apr 06, 2003 11:12 pm

Re: Specific Windows Not Working

Post by phil »

I suspect XMBC sees the PWA app simply as Edge as the window classes etc will be based on Edge.
However, you may be able to use the "title" or caption setting - you need to tick the box to enable it, then XMBC will also consider the window title in its profile detection. You may also need to use a regular expression search if the title changes...

This applies to any website in the browser, PWA or not. You can have different profiles for different websites based on the window (website/page) title.

There may be a problem thought - I just tried this by adding a PWA for these forums.. and the Window Title (page title) is not added to the PWA web app. Its just "chrome legacy window" or blank. That's a bit of a problem, because there is no way to distinguish the PWA app from another, or any edge chrome based window :(.

So it may be a non-starter. The strange thing is Window Detective (that can examine window properties) can see the title text, but XMBC is not for some reason. That will need to be investigated, but for now, it looks like you are out of luck :(
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9/G604/M720/MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 1Tb NVME, 2x2TB WD Black (RAID1)
Hujakuja
New User
Posts: 2
Joined: Wed Aug 30, 2023 4:20 pm

Re: Specific Windows Not Working

Post by Hujakuja »

Thanks for your answer.

Maybe it will work in a future update? :)
User avatar
phil
Site Admin
Posts: 7602
Joined: Sun Apr 06, 2003 11:12 pm

Re: Specific Windows Not Working

Post by phil »

Maybe if I can figure out why XMBC cant see the title where other windows finders can!
Hopefully its something "silly" :)
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9/G604/M720/MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 1Tb NVME, 2x2TB WD Black (RAID1)
3tenfh6d
New User
Posts: 4
Joined: Sun Nov 05, 2023 11:02 am

Re: Specific Windows Not Working

Post by 3tenfh6d »

phil wrote: Thu Aug 31, 2023 12:45 am The strange thing is Window Detective (that can examine window properties) can see the title text, but XMBC is not for some reason.
I don't know if anything has changed since this post but I am running into this problem too but for some reason, XMBC can detect the title of the window, the problem is, it puts it in the Description field which as far as I know does not affect the matching whatsoever.

So it DOES see the window title, it just puts it in a different place.
User avatar
phil
Site Admin
Posts: 7602
Joined: Sun Apr 06, 2003 11:12 pm

Re: Specific Windows Not Working

Post by phil »

3tenfh6d wrote: Sun Nov 05, 2023 11:07 am
phil wrote: Thu Aug 31, 2023 12:45 am The strange thing is Window Detective (that can examine window properties) can see the title text, but XMBC is not for some reason.
I don't know if anything has changed since this post but I am running into this problem too but for some reason, XMBC can detect the title of the window, the problem is, it puts it in the Description field which as far as I know does not affect the matching whatsoever.

So it DOES see the window title, it just puts it in a different place.
Nothing had changed (but it has now see below)...
I'd like to see a screenshot of that, because that's not what is happening here. It sees a caption (which can be used for matching), but that caption is still generic "Chrome Legacy Window" (even for Edge PWA'a).

The description field is a user defined description only, XMBC should not be putting anything in there unless maybe you leave it blank it might put some default in?!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9/G604/M720/MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 1Tb NVME, 2x2TB WD Black (RAID1)
User avatar
phil
Site Admin
Posts: 7602
Joined: Sun Apr 06, 2003 11:12 pm

Re: Specific Windows Not Working

Post by phil »

Update: 2.21 Beta 21 now should fix this (of sorts). The problem with PWA's is that you have to match on the parent window, but XMBC never allowed you to "Find" the parent window so you had to guess/use Spy++ or some other tool to find the details.

Anyway, I changed that, so now if you set the match type to "Parent Window" before using the finder tool to select the Edge PWA, it now populates te class/caption etc. fields from the parent window automatically. And it picks up the window title/caption - and it detects properly and activates the profile.

So with 2.21 Beta 21, in the window finder, set the match type to Parent Window, then use the finder icon to select the Edge PWA window, notice the caption is correctly picked up. Ensure you tick the box to include the caption in the match and it should then work!

Let me know!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9/G604/M720/MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 1Tb NVME, 2x2TB WD Black (RAID1)
3tenfh6d
New User
Posts: 4
Joined: Sun Nov 05, 2023 11:02 am

Re: Specific Windows Not Working

Post by 3tenfh6d »

phil wrote: Sun Nov 05, 2023 11:27 am Nothing had changed (but it has now see below)...
I'd like to see a screenshot of that, because that's not what is happening here. It sees a caption (which can be used for matching), but that caption is still generic "Chrome Legacy Window" (even for Edge PWA'a).

The description field is a user defined description only, XMBC should not be putting anything in there unless maybe you leave it blank it might put some default in?!
Okay, I feel like I'm taking crazy pills. It was definitely working prior but now that I'm trying it again, the Description field remains empty. I'm kicking myself for not taking a screenshot of it but it definitely populated it with the PWA's title string (Discord in my case)
3tenfh6d
New User
Posts: 4
Joined: Sun Nov 05, 2023 11:02 am

Re: Specific Windows Not Working

Post by 3tenfh6d »

phil wrote: Sun Nov 05, 2023 12:45 pm Update: 2.21 Beta 21 now should fix this (of sorts). The problem with PWA's is that you have to match on the parent window, but XMBC never allowed you to "Find" the parent window so you had to guess/use Spy++ or some other tool to find the details.

Anyway, I changed that, so now if you set the match type to "Parent Window" before using the finder tool to select the Edge PWA, it now populates te class/caption etc. fields from the parent window automatically. And it picks up the window title/caption - and it detects properly and activates the profile.

So with 2.21 Beta 21, in the window finder, set the match type to Parent Window, then use the finder icon to select the Edge PWA window, notice the caption is correctly picked up. Ensure you tick the box to include the caption in the match and it should then work!

Let me know!
I read your update post and unfortunately I can't test it myself since:

A. I use the portable version of XMBC and...
B. I use Brave, not MS Edge

So it's a double whammy 😅
User avatar
phil
Site Admin
Posts: 7602
Joined: Sun Apr 06, 2003 11:12 pm

Re: Specific Windows Not Working

Post by phil »

Well my fix was only tested with Edge - does Brave even behave in a similar way with PWA's? I guess it probably does as its also chromium based - but I don't know. But in any case, my comment above was more aimed at the OP as I did test and work on this using his use case - i.e. Edge!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9/G604/M720/MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 1Tb NVME, 2x2TB WD Black (RAID1)
3tenfh6d
New User
Posts: 4
Joined: Sun Nov 05, 2023 11:02 am

Re: Specific Windows Not Working

Post by 3tenfh6d »

phil wrote: Mon Nov 06, 2023 2:35 pm Well my fix was only tested with Edge - does Brave even behave in a similar way with PWA's? I guess it probably does as its also chromium based - but I don't know.
I have no clue if it behave the same way. As far as I know, Brave tries to stick close to what Chrome does with just the addition of the blocking of trackers and fingerprinting.
phil wrote: Mon Nov 06, 2023 2:35 pm But in any case, my comment above was more aimed at the OP as I did test and work on this using his use case - i.e. Edge!
Understandable, cheers!
User avatar
phil
Site Admin
Posts: 7602
Joined: Sun Apr 06, 2003 11:12 pm

Re: Specific Windows Not Working

Post by phil »

Just tested it here with Brave on my laptop - it does seems to work similar, you have to "create shortcut" from the "more tools" -> Create Shortcut, then select open in window. Not quite as slick as Edge but identical to chrome.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9/G604/M720/MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 1Tb NVME, 2x2TB WD Black (RAID1)
Post Reply