Simulated Sticky keys don't release properly since upgrade

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links, files or images until they have at least 4 posts.
Post Reply
New User
Posts: 1
Joined: Wed Aug 23, 2023 9:40 pm

Simulated Sticky keys don't release properly since upgrade

Post by Drakkus »

XMBC Version: 2.20.5
Installed or Portable version:Installed
Windows Version: Windows 10 Pro 22H2 Build 19045.3324
Mouse Information (brand/model): Logitech ERGO M575
Relevant Computer Information (CPU, RAM etc): Intel Core i5-7600 64-Bit, 3.5GHz, 16GB Ram
Did the problem occur after an upgrade of XMBC? (If so, from what version?): Yes. Unsure of previous version, upgrade was automatic. Uninstaller showed 2.19.2
Did the problem occur after a Windows update/upgrade? (If so, from what version?): No
How long have you used XMBC?: 2 Years
What language and keyboard layout do you use in Windows?: English(US)

I have a profile for for my CAD program which sets Mouse5 to a Simulated Keystroke of Sticky Shift-MMB and have my settings set to Reset sticky buttons when any other key or button is pressed (both options are checked). This lets me Orbit without having to hold any buttons and I can use LMB or whatever to exit. Up until now this worked great except for rarely locking my mouse input to the CAD program.

Ever since the auto-update to 2.20.5 2 days ago it won't release properly unless I click Mouse5 again. My usual habit is hitting Mouse5 to orbit and then LMB to exit but any time I do that only the mouse button releases but keyboard and mouse input are both mostly locked out: mouse is limited to cursor movement and keyboard only has function and modifier keys. I found I can press shift to release the input locks, but mouse input is still limited to only my CAD window, even the scroll wheel. Pressing Mouse5 twice again in CAD is the only way to completely reset the inputs and give me full access to my system.

I tried restarting the PC, recreating the Profile, uninstalling XMBC and reinstalling with a "reset" of the settings, nothing has worked.

Hopefully the problem's just a setting I've overlooked that got switched during the update because learning new habits is time-consuming and frustrating. Thanks in advance for any help.

Edited to Add: Simulated Keystroke is set to mode "8 Sticky"
User avatar
Site Admin
Posts: 7670
Joined: Sun Apr 06, 2003 11:12 pm

Re: Simulated Sticky keys don't release properly since upgrade

Post by phil »

There was a bug in a prior 2.20 version (may have been 2.20.4) that I though was properly fixed in 2.20.5 (which has been out for quite a while now so I'm unsure why the autoupdate only happened 2 days ago :)).

It would be really useful if you could turn on debug logging immediately after this happens because that will flush the last 200 verbose messages to the log file which you can then send me. You can setup a global hotkey to toggle debug logging on/off and then just hit that hotkey when the lockup happens.

Alternatively, turn on debug logging (settings -> updates & logging tab, don't forget to OK and APPLY the settings on the main GUI) then make it go wrong, then send me the log file (which you can also get to from the same tab in settings). NOTE: Make a note of the time it happens and let me know that too - so I can narrow down the messages in the log - as with debug enabled, it is very verbose!.

PM me a copy of the log here (I will make sure you are removed from the new users group which is unable to attach files to posts).

I'm really short on free time at the moment (this summer seems to have been busier than ever both at work and at home!) but I will try and grab a moment to check the logs you send and see if there is anything obviously wrong which can be fixed quickly. If its less obvious, it might take a while longer.

I can provide links to 2.19.2 download also if I am unable to find a quick solution.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9/G604/M720/MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 1Tb NVME, 2x2TB WD Black (RAID1)
Post Reply