[SOLVED]Something is wrong, not quite sure what

My x64 port of InpOut32
Post Reply
New User
Posts: 1
Joined: Sat Apr 05, 2014 12:09 pm

[SOLVED]Something is wrong, not quite sure what

Post by BreaKer »

Hello! I am working on quite a big project that requires me to output data through the parallel port. I have downloaded your dlls, installed the driver, ran the program, but something seems to be wrong.
The program compiles and runs just fine, however, when I send 0 to the port, I still pick up the normal voltage (~3.4 volts). If I close and reopen the program and press read, I get the 0, so from what I understand, it does write it in the data registry of the port. I do not have a speaker on my MB, however, I connected the multimeter to the speaker pins, pressed the Beeper button and the voltage keeps being 0;
I am running Windows 7 x64, I have little to no knowledge about the parallel ports, I do know I have one on my MB, and according to the specifications in the manual, I am trying on the right pins (Pin 2 and pin 25 -Data 0 and GND)
If it is of any use, my MB is a N68C-GS FX I couldn't find any settings for the parallel port in BIOS though.
Any help is greatly appreciated!

Edit: While the VB code at least seems to write the registry, the c++ one does not. It always reads the same value (0x078) regardless of what I put into the out command, or if I run the VB first.
I made sure the port address is set correctly (it is the default one)

Later Edit: Downloaded a port monitor, based on impout32 as well, whenever I change a value in the vb net program, it changes it in the port monitor, however the output of the pins (aka current) seems to be the same..

Solved: I can't believe this...I can't believe what I just did. I was reading the strobe pin instead of the D0 (The cables I have connected to the pins were the same colour)
I feel so dumb!

Thank you for your time!
Best regards,

Post Reply