Prepar3d V5 from Lockheed Martin

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
funkyhut
New User
Posts: 2
Joined: Fri Jun 26, 2020 7:40 am

Prepar3d V5 from Lockheed Martin

Post by funkyhut »

This is not a serious issue but I'm posting simply as a heads up.
Prepar3d V5 from Lockheed Martin.
With XMouse Button Control active it is not possible to use the mouse wheel to "turn" knobs.
When I disable XMouse Button Control, even after P3D has launched, the "turn" of knobs works.

Also, many thanks for a really useful program!

Thank You.

Chris Stanley

User avatar
phil
Site Admin
Posts: 6697
Joined: Sun Apr 06, 2003 11:12 pm

Re: Prepar3d V5 from Lockheed Martin

Post by phil »

Actually that's not surprising. XMBC redirects the wheel messages to the window under the cursor by default and I'm not surprised this happens.
I don't have prepar3d (just X-Plane 11 and MS FS 2020 Alpha 4 - but I'm not allowed to talk bout that :lol:) I'll check in there but of course it will be different.

However, you should be able to "fix" this by setting up a profile for Prepare3D (the exe) and in that profile, turn ON the option setting "Disable scroll window under cursor"
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

funkyhut
New User
Posts: 2
Joined: Fri Jun 26, 2020 7:40 am

Re: Prepar3d V5 from Lockheed Martin

Post by funkyhut »

Thanks for that advice.
X-Plane 11 and MSFS Alpha 4 don't have that problem!
Take Care!

User avatar
phil
Site Admin
Posts: 6697
Joined: Sun Apr 06, 2003 11:12 pm

Re: Prepar3d V5 from Lockheed Martin

Post by phil »

On another note, how does Prepar3D compare in your opinion? Ive never really got into that one - I know it originated from the old MSFS but how it is graphically and physically (flight modelwise) these days?

I use X-Plane mostly for work (developing plugins for it for visualising real recorded flight data in the sim) so for that purpose, the graphics are more important than the model (which I'm overriding anyway!). Loving flyig around in X-Plane in VR mode right now but cant wait for MSFS2020 to support VR mode as its visually another level in comparison - although I hope with 11.50 its opening that up for future graphic improvements.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

lzamm
New User
Posts: 2
Joined: Wed Jan 27, 2021 4:06 pm

Re: Prepar3d V5 from Lockheed Martin

Post by lzamm »

I know it's 7 months down the line, but you may find this info useful. First off XMBC works fine with P3D v4, it's only with v5 that the scroll wheel isn't recognised. And in v5, you can regain the functionality by unticking "make scroll wheel scroll window under cursor" in the settings page. I don't know what effect this may have on the other programs I run, but so far I haven't seen any.

Thanks for a very useful little program and for making it free :)

User avatar
phil
Site Admin
Posts: 6697
Joined: Sun Apr 06, 2003 11:12 pm

Re: Prepar3d V5 from Lockheed Martin

Post by phil »

Ive not looked any further.

I suggested the fix was to turn off XMBC from scrolling the window under the cursor.
However, you should be able to "fix" this by setting up a profile for Prepare3D (the exe) and in that profile, turn ON the option setting "Disable scroll window under cursor"
That's a per-application way of disabling the general setting "Make scroll wheel scroll window under cursor" which you have confirmed works.
As I don't have Prepare3D (as I said before) I can't even attempt to reproduce the problem here but my previous suggestions was based on the fact that with those "scroll window under cursor" options on, XMBC can redirect the scroll messages which may well be causing the problem because Prepare3D wont be seeing the message (in the right place).

Edit: If you're on Windows 10 then you probably don't even need the scroll window under cursor because Windows 10 does that by default anyway (it isnt quite as comprehensive as XMBC's option but its less invasive and wont interfere in cases such as this!)
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

lzamm
New User
Posts: 2
Joined: Wed Jan 27, 2021 4:06 pm

Re: Prepar3d V5 from Lockheed Martin

Post by lzamm »

Sorry I missed that. And there I was thinking I discovered something. Anyway, I can confirm that your suggestion works too :)

Post Reply