Layer hotkeys for switching layers do not work.

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links, files or images until they have at least 4 posts.
Post Reply
New User
Posts: 1
Joined: Fri Dec 03, 2021 12:59 am

Layer hotkeys for switching layers do not work.

Post by kruszkush »

XMBC Version: 2.19.2
Windows Version: Windows 10 64 Bit
Mouse Information (brand/model): Zowie FK1
Relevant Computer Information (CPU, RAM etc):
How long have you used XMBC?: 1 hour
What language and keyboard layout do you use in Windows?: Polish

Clear description of the problem - try and include as much information as possible, including what button and mappings you are having problems with (if applicable).: Layer hotkeys for switching layers do not work.

Enable global hotkeys is ticked (enabled).

I'm trying to use it while being in Diablo 2. Simply does nothing. Profile is set just for Diablo.

Also CAPS-LOCK doesn't do anything. Ticked "Bypass ALL actions when SCROLL LOCK i ON". Well it's ON and all things in layers 1 are still active.

I want to click one button that will disable everything, or at least will change to other layer which is set to Not intercept.

The only thing that works is "Modifier Keys", but I want to switch layers/disable XMBC with one button click, not while held down.

Tried to run is as administrator, but doesn't help.

Also tried "Enable/Disable XMBC" binding it to any key, but nothing happens, doesn't disable anything.

User avatar
Site Admin
Posts: 6911
Joined: Sun Apr 06, 2003 11:12 pm

Re: Layer hotkeys for switching layers do not work.

Post by phil »

Make sure the XMBC setup screen is closed - global hotkeys are disabled while the screen is open... No idea why the scroll lock isn't disabling XMBC though if thats turned on - works perfectly here.. May be worth capturing some debug logging and sending it to me (PM or post it here)

Enable debug logging in the settings->Updates and Logging tab. OK / Apply that, then turn scroll lock on / off a few times - and load diablo and try switching layers/disabling via scroll lock/hotkeys.

When XMBC is disabled via scroll lock or hotkeys, the icon should change in the status bar (to the normal icon with a red X on it).
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 1Tb NVME, 2x2TB WD Black (RAID1)

Post Reply