Page 1 of 1

Simulated SHIFT During behaves odd

Posted: Tue Nov 23, 2021 11:43 pm
by em27
XMBC Version: 2.19.2

I used to have a multi bt mouse, but it died, and now I got this backup mouse, has only two side buttons. On the older one had its own cp app where to set this setting, but the current one doesn't and that cp app disabled itself. What it used to do is to use the 3rd button beside the back and forward buttons as SHIFT. Now on this two side button mouse I was trying this with XMBC,on button 5 and it behaves odd. Layer 1, button 5 (default forward), Simulated keys (during / 3) {SHIFT}. On left click it works alright, holding it when one file is selected and then clicking on a lower placed file will select all files in between. But if I hold it and then use the right click, it does not open the extended context menu as I'm expecting it to. It does it I use the keyboard, but not the simulated shift. What did I not configure right?

Re: Simulated SHIFT During behaves odd

Posted: Thu Nov 25, 2021 1:54 am
by phil
Have you setup the simulated keystroke to "During" to it stays held while the button is held?
I Wonder if the second button press (right click) is aborting the simkey sequence - before the right button is registered - I'm not 100% sure why it would work with the left click drag in this case, other that perhaps timing - the context menu appears after releasing the right button - well after the right button being pressed aborts the simkey sequence...

I will need to try and reproduce this here (but its 1am here right now and I'm away with work for the next few days so I wont be able to do that immediately).

Re: Simulated SHIFT During behaves odd

Posted: Thu Nov 25, 2021 9:34 pm
by em27
Yes, it's set to during.
I can see the colors on the XMBC Layer panel, mb 5 + left click both get and stay colored yellow, mb 5 + right click alternates activation: mb 5 is yellow, I click the rmb this then turns yellow and mb 5 goes off, when I release rmb mb 5 turns back yellow. I've also tried with any other button together with mb 5, even the scroll wheel, and all stay together, only the rmb behaves differently.

Re: Simulated SHIFT During behaves odd

Posted: Sun Nov 28, 2021 4:32 pm
by phil
OK so during is defo the right thing to do. But I cant figure out why it would be OK on ALL buttons except RMB.
I will have to have a look at the code to make sure there isn't some "special case" going on there - but I cant think of any reason there would be.

Re: Simulated SHIFT During behaves odd

Posted: Sun Nov 28, 2021 4:38 pm
by phil
Just checked and its working perfectly here with {SHIFT} on button 5 and RMB to show the extended context menu... And the 5th button stays highlighted in orange(/yellow) too while pressing RMB... So there seems to be something wrong at your end.

Can you send (PM) me a copy of your profile (firstly), and then enable debug logging (settings/logging & updates tab) then once OK and APPLIED, perform the button 5 + rmb in explorer... Ideally make a note of the time you do this so I can locate it in the log, then send me a copy of the log file too.

NOTE: Debug logging will turn itself off after you exit/restart XMBC or you can turn it back off in settings.

Thanks,
Phil

Re: Simulated SHIFT During behaves odd

Posted: Tue Nov 30, 2021 12:08 am
by em27
Ok, post 4...

Re: Simulated SHIFT During behaves odd

Posted: Tue Nov 30, 2021 3:43 am
by em27
Here's a copy of the log: pastebin com/1cBQv2xV

Re: Simulated SHIFT During behaves odd

Posted: Tue Nov 30, 2021 9:31 pm
by phil
For some reason I am having to approve every post you make - I don't know why (and I hope it will fix itself on your next post as you should be out of "newly registered users". I will try and have a look at the log soon (but I cant do that tonight). I'll let you know what I find (if anything!)