Using Xmouse with Elecom mouse setting tool in tandem

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links, files or images until they have at least 4 posts.
Post Reply
Scathappens
New User
Posts: 1
Joined: Fri Sep 10, 2021 10:12 am

Using Xmouse with Elecom mouse setting tool in tandem

Post by Scathappens »

XMBC Version: v2.19.2
Windows Version: windows 10 pro (latest updates)
Mouse Information (brand/model): 3 mice (main elecom EX-6 - sub mince microsoft intellipoint, elecom relacom)
Relevant Computer Information (CPU, RAM etc): ryzen 9, 64gb ram, nvidia 3080, SSD's
Did the problem occur after an upgrade of XMBC? (If so, from what version?): No
Did the problem occur after a Windows update/upgrade? (If so, from what version?): No
How long have you used XMBC?: Just started configuration
What language and keyboard layout do you use in Windows?: english UK

Clear description of the problem - try and include as much information as possible, including what button and mappings you are having problems with (if applicable).:

Firstly would like to say that this bit of software seems like the perfect solution to my problem but a small issue to overcome.

So I have 3 mice attached to my computer for different reasons. the lecom EX-6 Is my primary mouse that i have converted to be wearable, the other two mice are positioned in convenient places for me to use when i dont want to slip the elecom on my hand and back off again for short tasks.

I have got Xmouse installed and it works fine to accept the buttons 1-5 input from all three mice however the problem comes from the fact that it seems to intercept the elecom EX-6 inputs before the elecom software is activated

xmouse does not recognise the extended buttons on the EX-6 so i have the elecom software to drive that in different profiles but i can't get it and xmouse to operate at the same time.

With the intellipoint software if i allocate buttons 4-5 to something else it overrides xmouse but if i set it to forward back (default) then xmouse picks it up as button 4-5 in elecom software setting the button to forward/back does not send that button click to x mouse.


Is there a way i can get the input from a specific mouse to pass through and the input from the other two mice to be driven by the xmouse software.

Or

Is there a way for the elecom software to be above xmouse in the priority list.

It seems that having xmouse running disables elecom mouse setting tool entirely.


I have tried googling for an answer and i have tried to use many other bits of software to make this happen.

If i haven't explained myself clearly then please do ask for clarifications


Regards
Neil

User avatar
phil
Site Admin
Posts: 6824
Joined: Sun Apr 06, 2003 11:12 pm

Re: Using Xmouse with Elecom mouse setting tool in tandem

Post by phil »

Hi Neil,

Firstly, its not possible to determine/limit which devices XMBC controls. XMBC uses Windows low level hooks to intercept and remap the mouse buttons - and they are device independent (as in, the hook messages provide no information regarding the physical device that generated the message, and therefore XMBC does not know).

What surprises me is that XMBC is stopping the elecom software working. I have no knowledge of that device or how the software works but usually the manufacturer software works at a lower level (like driver level) so it should always see the messages first. However if it uses hooks (like XMBC), then its tricky as there is no way to prioritize the hooks in Windows, other than that the most recently installed hook will generally take precedence. So if you run the elecom software AFTER XMBC has setup its hook, then the elecom software should get the messages first.

Having said that, if you leave the buttons mapped as "No change (Don't Intercept)" in XMBC then XMBC should not do anything, not block, not remap that message as it sees it, so the elecom software should still see the message as it is not touched by XMBC! Can you confirm you have left the buttons as "No change (Don't Intercept)"?
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 1Tb NVME, 2x2TB WD Black (RAID1)

Post Reply