Double click glitchy in AutoCAD

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links, files or images until they have at least 4 posts.
Post Reply
Wimads
New User
Posts: 11
Joined: Mon May 03, 2021 4:23 pm

Double click glitchy in AutoCAD

Post by Wimads »

XMBC Version: v2.19.2
Windows Version: Windows 10 64 bit
Mouse Information (brand/model): Kensington Orbit Fusion (trackball)
Relevant Computer Information (CPU, RAM etc): Intel i7 9750H; nVidia GTX 1660 Ti; 16GB RAM
Did the problem occur after an upgrade of XMBC? (If so, from what version?): no
Did the problem occur after a Windows update/upgrade? (If so, from what version?): no
How long have you used XMBC?: 1 week
What language and keyboard layout do you use in Windows?: US layout; Dutch and US-English languages

Clear description of the problem - try and include as much information as possible, including what button and mappings you are having problems with (if applicable).:

I have set button 5 to execute double click, and noticed that in AutoCAD it is behaving a bit glitchy. It sometimes behaves as if its clicking 3 times, and sometimes as if its clicking only once, and sometimes it cancels my selection or command as if I had pressed ESC.

I have found that I can work around the problem with a simulated keystroke: {LMB}{WAITMS:10}{LMB} with method 1.
If I use {LMB} with method 9, or {LMB}{LMB} with method 1, I get the same glitchy behaviour as the standard double click method. {LMB}{LMB} works if I set delay between keystrokes to 10ms in settings. So it seems that the regular double click is too fast for AutoCAD to interpret, and a slight delay of 10ms solves the issue.

Just thought I would put this out there for anyone who's using AutoCAD (or potentially any other software that behaves funky with double click).

User avatar
phil
Site Admin
Posts: 6762
Joined: Sun Apr 06, 2003 11:12 pm

Re: Double click glitchy in AutoCAD

Post by phil »

Rather than add the WAITMS in each command, you could just adjust the global "delay between simulated keystrokes" in the advanced settings tab. This should apply to the "double click" action too (although I'm not 100% sure about that without checking the code).

EDIT: Oh I see you have tried that and it worked. I guess the default is just a little too slow for Autocad on YOUR computer (it will depend on the speed of your processor, how the target application behaves and anything else going on at the time, so the defaults are a bit of a guess - although I'm a bit surprised on a recent I7!).
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Wimads
New User
Posts: 11
Joined: Mon May 03, 2021 4:23 pm

Re: Double click glitchy in AutoCAD

Post by Wimads »

Yeah, I did try setting the global delay to 10ms. That works for simulated keystroke {LMB}{LMB}, but it has no effect on the normal double click (or at least not as experienced in AutoCAD).

EDIT: I might add that I'm on AutoCAD 2014, so that might have something to do with it.

User avatar
phil
Site Admin
Posts: 6762
Joined: Sun Apr 06, 2003 11:12 pm

Re: Double click glitchy in AutoCAD

Post by phil »

OK, its possible that the globaly setting isn't being used in the "double click" option - I'll have to look into that - it must have a hard coded delay (or none at all) but it does effectively do the same thing as simkeys {LMB}{LMB} internally so I'm a bit surprised!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply