X-Mouse remap not working in Total War: Warhammer II

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links, files or images until they have at least 4 posts.
Post Reply
New User
Posts: 2
Joined: Thu Mar 18, 2021 10:33 am

X-Mouse remap not working in Total War: Warhammer II

Post by Eldvait »

XMBC Version: 2.19.2
Windows Version: 10 Home
Did the problem occur after an upgrade of XMBC? (If so, from what version?): No
Did the problem occur after a Windows update/upgrade? (If so, from what version?): No
How long have you used XMBC?: several months
What language and keyboard layout do you use in Windows?: LT/EN US

Clear description of the problem - try and include as much information as possible, including what button and mappings you are having problems with (if applicable).: My left mouse button is broken and not functioning. I use X-mouse to get around it by binding MB4 to act as LMB. Everywhere so far this works just fine, but when I tried booting up Total War: Warhammer II, the binding doesn't work. I tried creating a profile assigned to the games exe, but no luck. Is there a solution for this that anyone knows?

User avatar
Site Admin
Posts: 6762
Joined: Sun Apr 06, 2003 11:12 pm

Re: X-Mouse remap not working in Total War: Warhammer II

Post by phil »

My bet is that this game is blocking injected keystrokes (many do to prevent cheating; in fact many games now ban people using tools like XMBC, especially the online competitive ones!).

I don't have personal experience with this game so I can't be 100% sure but it is usually the case in these things.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply