I can't switch layers via global hotkeys

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
noxcovenant
New User
Posts: 4
Joined: Mon Mar 08, 2021 12:38 am

I can't switch layers via global hotkeys

Post by noxcovenant »

XMBC Version: v2.19.2
Windows Version: Windows 10 Version 2004
Mouse Information (brand/model): Logitech G PRO Wireless Gaming Mouse
Relevant Computer Information (CPU, RAM etc): Beefy
Did the problem occur after an upgrade of XMBC? (If so, from what version?): Nope.
Did the problem occur after a Windows update/upgrade? (If so, from what version?): Nope.
How long have you used XMBC?: 1 month.
What language and keyboard layout do you use in Windows?: English (United States)

Clear description of the problem - try and include as much information as possible, including what button and mappings you are having problems with (if applicable).:

My Settings:
Global Settings > Hotkeys tab > checked "Enable global hotkeys" > "Switch to Layer 3" > "1"

With the above setting, pressing "1" should switch me to Layer 3, but I still remain on Layer 1. I tried substituting other letters, numbers and combination but the layer never switches. (I don't know if this is relevant, but the "Modifier Keys" tab works, but that hotkey types require holding a button which I prefer not to)

Appreciate any suggestions. Everything else on this program works perfectly though! I was able to map all my actions for Battlefront 2 on my mouse and it's made the game so much more fun. I just donated and even I don't get this solved, it was fully worth it. :)

User avatar
phil
Site Admin
Posts: 6724
Joined: Sun Apr 06, 2003 11:12 pm

Re: I can't switch layers via global hotkeys

Post by phil »

Did you close the setup window? Global hotkeys don't work when the setup window is open (as it says in the manual, and on the screen but that can be easily missed I guess).

I'd also highly recommend that you don't select a single key that's commonly used like 1, 2, 3 etc... Global hotkeys are intended to be key-combos (eg. CTRL+3) as they DISABLE said key from normal use in any application which would be a bit of a problem for commonly used keys like normal letters and numbers! In fact, I'm a bit surprised it even lets you do that (but it does I just checked - and it did actually work once the setup window was closed).
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply