Prevent sending repeated keystokes?

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
xpclient
Member
Posts: 21
Joined: Sun Oct 20, 2013 8:22 am

Prevent sending repeated keystokes?

Post by xpclient »

I am running the latest XMBC 2.19.2 on Windows 10 Enterprise 1803.

My mouse has a tilt wheel which works with XMBC.

For tilt left, I wanna assign: Send keys {CTRL}{LMB}
For tilt right, I wanna assign: {CTRL}W

However it is so sensitive that when I press actually do tilt left, it opens the same link multiple times. Similarly if I tilt right, it closes multiple tabs that are open.

How do I make it send the keystokes only once and then not repeat them so fast again?

I tried {WAIT:2} but that just delays it but still sends the keystrokes after the waiting period. How do I send the keystroke just once and then completely block it for few seconds until I press tilt left/right again?

User avatar
phil
Site Admin
Posts: 6697
Joined: Sun Apr 06, 2003 11:12 pm

Re: Prevent sending repeated keystokes?

Post by phil »

Try Ignore repeated remapped horizontal scroll on the profile options tab (you may have to play with the time (milliseconds) too to find the optimal solution.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

xpclient
Member
Posts: 21
Joined: Sun Oct 20, 2013 8:22 am

Re: Prevent sending repeated keystokes?

Post by xpclient »

Missed that setting! Thank you very much!!!

Happy new year and stay safe.

noxcovenant
New User
Posts: 4
Joined: Mon Mar 08, 2021 12:38 am

Re: Prevent sending repeated keystokes?

Post by noxcovenant »

My solution was switching to Layer 2 after the button press.

Code: Select all

Simulated Keys: (pressed)[{UP}{LAYER:2}]
And then on the Layer 2 settings, I checked Switch to Layer 1 after 1 seconds.

But maybe I should try phil's suggestion. Thanks for the idea.

noxcovenant
New User
Posts: 4
Joined: Mon Mar 08, 2021 12:38 am

Re: Prevent sending repeated keystokes?

Post by noxcovenant »

Actually ignore my crude solution. After doing additional testing, phil's suggestion was more elegant. Thanks again.

Post Reply