Page 1 of 1

Scrolling issue

Posted: Mon Apr 27, 2020 9:01 am
by kvarkk
XMBC Version: 2.19.1
Windows Version: Win10 1909
Mouse Information (brand/model): HP x5500
Relevant Computer Information (CPU, RAM etc): Core i5-7300, 16 Gb RAM
Did the problem occur after an upgrade of XMBC? (If so, from what version?): possibly
Did the problem occur after a Windows update/upgrade? (If so, from what version?): not sure
How long have you used XMBC?: 3 years
What language and keyboard layout do you use in Windows?: Russian and English

Clear description of the problem - try and include as much information as possible, including what button and mappings you are having problems with (if applicable).: Intermittent issue - scrolling stops working on some web pages when XMBC is active. Once I close XMBC scrolling will start working again. Then, if I launch XMBC again the issue is back.
When the issue occurs I can still scroll the page with cursor buttons.
Browser used: Yandex Browser (Chrome-based).
Pages affected: mainly some corporate web pages. Of course I cannot share the links here.

Re: Scrolling issue

Posted: Mon Apr 27, 2020 12:10 pm
by phil
Is it just that one browser or any chrome based browser?
Are there ANY public links you can share?
There are some workarounds in XMBC already for many issues with chrome (and new versions of chrome come out and introduce more/other issues quite a lot :().

However, without any information or examples, there is little I can do. If I cant reproduce the problem here, I can only guess what it could be, and thats not appropriate! I don't really know what you expect out of me is that is all you can offer!

Have you tried turning on debug logging - maybe there is something indicated in the logs with the windows that fail to scroll - its worth a look if you haven't already tried it. Ideally send me a copy of the debug log and the time that scrolling failed -if you cant do that we could have a problem!

A few other things to try...
1. Disable XMBC (rather than exit) that should have the same effect.
2. Add a profile for the browser, and disable "scroll window under cursor" for that profile - see if that helps...

Let me know how you get on either way.


Re: Scrolling issue

Posted: Wed Apr 29, 2020 5:22 am
by toms56

I may have experienced the same problem.
I tried to switch the layer with SHIFT or ALT, then while holding shift or alt I tried scrolling but nothing happened on Chrome or Firefox (shift + alt did work with Firefox). But it worked well on the explorer for example.

It seems that Chrome doesn't accept those keys as it should be reserved to another action, Firefox does better but not perfect. An alternative that worked for me on both browsers was Windows+Alt to switch the layer, then scrolling worked perfectly even with those keys holded.


Re: Scrolling issue

Posted: Wed Apr 29, 2020 7:50 am
by phil
Hi Toms56,

As the OP didn't mention using layers OR hotkeys at all, I don't think this is the same issue - willing to be corrected though!
Layer modifier keys are notorious for this - especially common keys like CTRL/ALT. CTRL+Scroll wheel usually makes the software zoom.

In My firefox, SHIFT+SCROLL actually goes back/forward - not sure about chrome. When you use layer modifier keys, those keys are not blocked from the application - so you need to find a key that does not cause side effects in the target application - this is actually a big problem with layer modifier keys and there is no solution, other than to fins a key combination that does not impact operation (as you suggest) or simply not using layer modifier keys for this - consider button chording or global hotkeys with timers to "switch to" the original layer - neither great alternatives but a workaround to some extent.

Another reason I would hope this is not OP's problem, is its covered in the FAQ and everyone should be looking there before posting :)
"Why do layer modifier keys not work/interfere with operations"


Re: Scrolling issue

Posted: Thu Apr 30, 2020 7:45 am
by kvarkk
Hi all,

I faced the issue yesterday on Gmail and Mail_ru web pages. Once I disabled the "scroll window under cursor" option, the issue was gone. So it seems to be a good workaround for my issue. Thanks Phil.