Page 1 of 1

Bug? Maybe? I am not sure.

Posted: Tue Mar 31, 2020 11:21 pm
by dvertz
XMBC Version: v2.19.1 (x64) Installed
Windows Version: Microsoft Windows 10 Professional Edition, 64-bit
Mouse Information (brand/model): Redragonlite Perdition Lazer Gaming 18 Button Mouse Model M-901,
(yes, I realize that XMBC will only work with 3 of those buttons)
Relevant Computer Information (CPU, RAM etc): Intel Core i7-8700 @ 3.2GHz, 32GB RAM
Did the problem occur after an upgrade of XMBC? (If so, from what version?): No
Did the problem occur after a Windows update/upgrade? (If so, from what version?): No
How long have you used XMBC?: about 8 months
What language and keyboard layout do you use in Windows?: English 110 Corsair K55 RGB keyboard

Clear description of the problem - try and include as much information as possible, including what button and mappings you are having problems with (if applicable).:

At our office we use a program called Ajera for time tracking. I know that it is a Click and Run software that is web based. In the timesheet section it is a grid based where we can select three dots to bring up a list of projects. The resulting window is also a grid based view. When I click to select a project and then click the button to accept that list item, the dialog goes away but the cell is not filled with the selected project. OK that was long winded!

While this had been an issue on/off for a while. I tracked it to XMBC today. Exit XMBC and there was no issues in Ajera. Then start XMBC the issues came back to Ajera.

After about an hour turning options off/on to see which might affect it, I finally found it.

Default Profile > Scrolling Tab > "Force Scroll Pages/Lines (If application does not respond to setting)" equals enabled.

I am curious how the scrolling would effect selection in a cell of a table? Or not let it transfer from one window to another?

I wish I could keep it on as many windows don't scroll correctly otherwise. If I could only make a profile that would be for all programs EXCEPT Ajera. Then I could turn it on there.

Re: Bug? Maybe? I am not sure.

Posted: Tue Mar 31, 2020 11:37 pm
by phil
What that setting does, is force windows to respond to the windows setting telling them the number of lines/pages to scroll with the wheel. It does that using standard Windows API calls - the only API calls available are to change the Windows setting (the lines per scroll notch in this case) AND notify ALL top level windows (by broadcasting a global message) that the Windows settings have changed, OR to change the setting but don't bother notifying all (any) top level windows - which means other windows programs wont see the change until they explicitly check or are restarted.

Maybe your application responds badly, causing this behaviour when it receives a settings changed message from Windows (there are plenty of other things that send a settings changed message, not least the mouse control panel where you can change the number of lines per scroll wheel notch) - I don't know about that (pure speculation which is quite useless!). But the simple fact of the matter is I very much doubt there is anything I can do about it other than have the option which is already there (and available on a per profile basis).

The hopefully simple answer is.... Create a profile for the application in question (Ajera) of the specific window which suffers this problem and turn that option OFF in this profile, maybe that will work... Certainly worth a try?!


Re: Bug? Maybe? I am not sure.

Posted: Wed Apr 01, 2020 1:22 pm
by dvertz
Thank You Phil. That Worked!

That the great thing about Forums. My mind tends to think about the most difficult way to do a task. If I post the problem, some will tell me the simple way.

Re: Bug? Maybe? I am not sure.

Posted: Wed Apr 01, 2020 5:16 pm
by phil
Glad it worked - thats a relief!
I know what you mean about difficult vs simple - it happens to us all :).