Lenovo Wireless Mouse - Buttons 4 & 5 not recognized

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
shadow7
New User
Posts: 1
Joined: Wed Sep 18, 2019 12:52 pm

Lenovo Wireless Mouse - Buttons 4 & 5 not recognized

Post by shadow7 » Wed Sep 18, 2019 1:00 pm

XMBC Version: 2.18.8
Windows Version: Win10 1803
Mouse Information (brand/model): Lenovo ThinkBook Wireless Media Mouse (MA211W)
Relevant Computer Information (CPU, RAM etc): Dell Latitude 5490
Did the problem occur after an upgrade of XMBC? (If so, from what version?): Yes, tried diff versions
Did the problem occur after a Windows update/upgrade? (If so, from what version?): No, didn't get any updates
How long have you used XMBC?: couple of days
What language and keyboard layout do you use in Windows?: English

Clear description of the problem - try and include as much information as possible, including what button and mappings you are having problems with (if applicable).:

Hi, I received new mouse which is Lenovo ThinkBook Wireless Media Mouse (MA211W). I thought that if it has 5 standard buttons (+1 button to change scroll speed and +1 button to change the resolution) then 4th and 5th button would work in standard way (back and forward). Unfortunately Buttons 4 and 5 are changing the volume up and down. I would like to change it back to back and forward as volume change through mouse is completely useless for me. Unfortunately X-Mouse doesn't recognize those buttons as button 4 or 5 and actually doesn't recognize them at all (the 'actions' are not highlighting in the application when I am clicking them). So even if I change what those buttons should do - it's not changing anything and I can still only increase or decrease volume. By any chance there is a way to make those buttons be recognized by the application so then I can change them back to the standard back and forward actions? Thank you in advance!

User avatar
phil
Site Admin
Posts: 6115
Joined: Sun Apr 06, 2003 11:12 pm

Re: Lenovo Wireless Mouse - Buttons 4 & 5 not recognized

Post by phil » Wed Sep 18, 2019 10:52 pm

Urm, first thing to check - what driver is the mouse using? Is it the generic HID-Compliant device (made by Microsoft) or a specific Lenovo driver? If the latter, remove it and try to use the standard/generic HID driver.

Second - is there any other software running that may be intercepting the buttons before XMBC sees them - thats perhaps more difficult to find. Have you tried the mouse in another computer? Does the mouse come with any software itself to configure the buttons (like Logitech mice do) - maybe you need to use that to set the buttons back to "default".

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply