Weird {Home} button behaviour when bound to Tilt Wheel Right

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
HomieButton
New User
Posts: 4
Joined: Mon Feb 25, 2019 7:26 pm

Weird {Home} button behaviour when bound to Tilt Wheel Right

Post by HomieButton » Mon Feb 25, 2019 8:25 pm

XMBC Version: 2.18.3
Windows Version: Windows 7 Professional x64
Mouse Information (brand/model): Logitech G900
Computer Information: Intel i5-4570 CPU @ 3.20GHz, 3201 Mhz, 4 Cores, 4 Logical Processors
Did the problem occur after an upgrade of XMBC?: No
Did the problem occur after a Windows update/upgrade?: No
How long have you used XMBC?: 1,5 years
What language and keyboard layout do you use in Windows?: English; German keyboard layout

Clear description of the problem: I want to bind the simulated {Home} function to the Tilt Wheel Right event on my mouse but encounter heavy resistance. The intended effect would be to scroll all they way to the top of a webpage (in Chrome) after having read a long article. The actual effect is weird, indecisive jumping of the page; sometimes to the top, sometimes to a seemingly random height of the page, sometimes just wiggling up and down a bit.
I recorded a short video of this bug in action: https://youtu.be/rAexc0g1LRA

Additional information: I am also using Logitech's own Gaming Software 9.02.65, with the default binding of "Scroll Right" on Tilt Wheel Right.
Binding the function to a different key (MB4 in my case) worked perfectly as intended, always arriving at the top of the page.
I have to add that the Tilt Wheel events don't seem to work well for me more often than not (at least in a browser), since binding the middle click to Tilt Wheel Left and trying to enter fast-scroll-mode that way has very irregular outcomes as well; I don't know if that could be related, though.


And yes, I know I could just bind it to MB4 and be done with it... maybe I will... but I was in the mood for some good ol' bugreportin' and this bugged me for some reason. Mouse buttons feels like heavily contested real estate, and being able to bind everything exactly the way you want it is dope. So thanks anyway that I was able to come that far @ Phil, I love this tool :)
Last edited by HomieButton on Mon Feb 25, 2019 9:44 pm, edited 1 time in total.

User avatar
phil
Site Admin
Posts: 5998
Joined: Sun Apr 06, 2003 11:12 pm

Re: Weird {Home} button behaviour when bound to Tilt Wheel Right

Post by phil » Mon Feb 25, 2019 9:17 pm

Tilt is a pain in the rear. It is not like a button with discrete down and up, it is a messages that repeats on a timer (hardware dependent) and this makes remapping it awkward.

Did you try enabling the option "Ignore repeated horizontal scroll when remapped" on the options tab. This in effect attempts to convert the repeated messages into a simulated PRESSED and RELEASED message more lie a real button would send. I suspect the weird issues relate to this repeat so its certainly worth a try!

Regards,
Phil

PS. Attachments and URLs are disabled for new users until you have 4 (I think) posts or I manually remove you from the new users group (which I will do). This is because otherwise I get a plague of spam bots posting all sorts of rubbish (and it really frustrates me when that happens on forums, not least my own!).
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

HomieButton
New User
Posts: 4
Joined: Mon Feb 25, 2019 7:26 pm

Re: Weird {Home} button behaviour when bound to Tilt Wheel Right

Post by HomieButton » Mon Feb 25, 2019 9:42 pm

Hi Phil,

Just tried the "Ignore repeated horizontal scroll when remapped" and combinations with the vertical one as well, same behaviour. I previously tried just ignoring vertical with 400ms and it kinda felt like he registered the events better, but the events themselves are still acting up. Could've been placebo though.

I kind of suspected that it's some shenanigans with the tilt events, since the middle button simulation bound to Tilt Wheel Left cancels the scroll very soon after I move the cursor.
EDIT: Changing "Ignore repeated remapped horizontal scroll" to 800ms it becomes apparent that this is the same length of time that the cursor will act according to the scroll command, afterwards it reverts to a simple cursor. This indeed seems to make sure that the button press activates, but the {Home} function still likes to go on ferris rides.

I'll edit the OP with the aforementioned video. But I can imagine the nightmare of having to deal with such finicky stuff just for the sake one person's convenience, so don't sweat it :)

Cheers

EDIT 2: This gets weirder and weirder. Trying {Home} in my youtube subscription feed works as intended! Facebook, reddit, and other endlessly scrollable sites misbehave.

HomieButton
New User
Posts: 4
Joined: Mon Feb 25, 2019 7:26 pm

Re: Weird {Home} button behaviour when bound to Tilt Wheel Right

Post by HomieButton » Wed Apr 24, 2019 4:45 pm

You absolute beast! It's working now, after updating to 2.18.6 . Thanks a bunch!

User avatar
phil
Site Admin
Posts: 5998
Joined: Sun Apr 06, 2003 11:12 pm

Re: Weird {Home} button behaviour when bound to Tilt Wheel Right

Post by phil » Wed Apr 24, 2019 4:55 pm

Glad its working, although right now, I'm not entirely sure what change made the difference between 2.18.3 and 2.18.6 - there were a few chrome related issues so maybe those fixes helped... I can't remember specifically looking in any more detail at this particular occurrence (that may just be my memory, or it may just be a coincidence/fluke that this got fixed (which may be bad if its just a coincidence it now works)).
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

HomieButton
New User
Posts: 4
Joined: Mon Feb 25, 2019 7:26 pm

Re: Weird {Home} button behaviour when bound to Tilt Wheel Right

Post by HomieButton » Wed Apr 24, 2019 5:17 pm

Could be the case. I didn't try it before updating XMBC, so I couldn't say for sure what fixed it. FTR: Chrome version 74.0.3729.108.
I'll ping the thread if it acts up again :)

Post Reply