XMBC frequently resets to default settings randomly.

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Foghorn
New User
Posts: 13
Joined: Thu May 17, 2018 12:57 pm

Re: XMBC frequently resets to default settings randomly.

Post by Foghorn » Sun Jun 10, 2018 4:17 am

Tried 5000 and still had an issue Bumped it up to 7000 and waiting.
Set up CTRL+SHFT+X I might be able to remember that.

Foghorn
New User
Posts: 13
Joined: Thu May 17, 2018 12:57 pm

Re: XMBC frequently resets to default settings randomly.

Post by Foghorn » Sun Jun 10, 2018 3:11 pm

Did it at 7000 as well, after a restart.

User avatar
phil
Site Admin
Posts: 6103
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC frequently resets to default settings randomly.

Post by phil » Sun Jun 10, 2018 3:19 pm

to be fair, if it did it at 2000, 5000 then its not going to be timing out thats causing the problem.
Something else must be getting in there and either putting its own hook in place before XMBC or removing the hook).
Unfortunately there is no way (that I know of) to see what hooks are actually installed or what programs are installing hooks - so that makes it more difficult to figure out.

I was considering adding the ability for XMBC to automatically reinstall its hook, on a timer, which might help but still, depending on when it happens, could still leave it not working. It would be better to try and find out if there is some other software conflicting/installing its own hooks - do you have any other utilities that make the mouse or keyboard behave differently (for example, I have a volume2 which uses mouse hooks to control the volume - I only really have it because someone else found a conflict between that and XMBC lol).

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Foghorn
New User
Posts: 13
Joined: Thu May 17, 2018 12:57 pm

Re: XMBC frequently resets to default settings randomly.

Post by Foghorn » Wed Jun 13, 2018 2:44 pm

I do not have anything that I'm aware of besides XMBC that changes my keyboard or mouse settings.

Foghorn
New User
Posts: 13
Joined: Thu May 17, 2018 12:57 pm

Update-Re: XMBC frequently resets to default settings randomly.

Post by Foghorn » Sat Sep 28, 2019 5:02 pm

Hey Phil,
I never resolved this problem but the shortcut on/off worked fine to reset.

I now have a bigger problem . XMBC has completely locked up and will not work and also will not let me update, or uninstall it to re-install new. I tried a computer restart but XMBC is still unresponsive.

Thanks for your time and help.
XMBC Version:
Windows Version:
Mouse Information (brand/model):
Computer Information:
Did the problem occur after an upgrade of XMBC or Windows?:
How long have you used XMBC?:
What language and keyboard layout do you use in Windows?:



2.18.7or8
Windows 10 v.1903 os build 16299.431
Cyber Power "Gaming optical mouse"
64 bit operating system, x64-based processor
Unknown, but don't believe so.
2 years
English, qwerty

User avatar
phil
Site Admin
Posts: 6103
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC frequently resets to default settings randomly.

Post by phil » Sat Sep 28, 2019 5:40 pm

OK, what do you mean completely locked up - any more detail? This is not something I have ever experienced so I cant give any educated insights, just guesses!

For example, does it still "run" on startup? Does the mouse work or is it blocking the mouse functionality?
I presume you cant get to the setting window - does the context menu (in the system tray) respond at all?
Can you not close (exit) it or kill it in task manager?

I don't understand why you would not be able to "update" it other than if your on the latest version (2.18.8) - still you should be able to download any version and run the installer to replace the current version - you don't *need* to update within XMBC itself (although its odd that you cant). Unless of course it is because XMBC is running and wont exit (that could be why?)

If you can't open XMBC then turning on debug logging may be tricky - but you may be able to do so when starting XMBC manually... That is if you open a command prompt and navigate to the directory where XMBC is installed (usually c:\Program Files\Highresolution Enterprises\X-Mouse Button Control) and then run XMBC as follows:

X-Mousebuttoncontrol.exe /debug

That should start XMBC with debugging turned on - then go find the log file and send that to me (the FAQ tells you where to find this file if your struggling). The debug log may give some insight as to what is going on (or not going on!).

Another useful command line option: /Exit (to close and exit the currently running XMBC)
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Foghorn
New User
Posts: 13
Joined: Thu May 17, 2018 12:57 pm

Re: XMBC frequently resets to default settings randomly.

Post by Foghorn » Sat Sep 28, 2019 7:35 pm

OK, what do you mean completely locked up - any more detail? This is not something I have ever experienced so I cant give any educated insights, just guesses!
It reverted back to the stock key config and the global hotkey shortcut would not work. Left or right-clicking on the icon also did nothing. When I tried to remove and re-install it got hung up repeatedly on removing the program.
After another computer re-start, XMBC had been removed (I guess it force finished the process of removal), so I reloaded it with v2.18.8. I have regained functionality but the global hotkey to enable/disable still does not work. It is still configured properly in the settings (ctrl-shift-x) and box to enable hotkeys is checked.
I think it may have been caused by a windows update, big surprise huh?

User avatar
phil
Site Admin
Posts: 6103
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC frequently resets to default settings randomly.

Post by phil » Sat Sep 28, 2019 11:12 pm

The really strange thing is that is is happening to no one else (at least as far as I know, and I'm sure others would comment if they had the same problems :lol: ).

When you install/update xmbc, it tries to force exit it (by re-running XMBC with the /EXIT commandline - if that fails, then I'm sure it will get stuck - not sure if it *should* remove it on reboot - maybe (but nothing I have expressly told it to do - and as it uses the nullsoft installer and not windows MSI installation, I'm a little surprised that "worked"). Anyhow, at least your back up and running to some extent.

As for the global hotkey not working (ctrl+shift+x) then Im not sure - it is worth turning on debug logging, ok/apply etc.) then pressing the hotkey combo. XMBC should log if there is any problem registering the hotkey (maybe another program has it registered, or Windows said "No!" - that should get logged. So thats worth a shot!

Regards,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
Kukurykus
Fanatic
Posts: 281
Joined: Sat Jul 02, 2016 1:15 pm

Re: XMBC frequently resets to default settings randomly.

Post by Kukurykus » Sun Sep 29, 2019 10:09 am

The right commandline is: XMouseButtonControl.exe /exit, so without '-', as it doesn't exist in file name.

btw could you Phil please tell me how XMBC does it, that it exits XMBC (I guess by command line) without visible (for a short while) black command line window - what you did the process happens in background?
HAMA Roma, Rapoo 3920P
Windows 10 x64, Intel i5-4670K @ 3.40GHz, 8GB,
Intel(R) HD Graphics 4600, Intel SSD 179 GB HDD

User avatar
phil
Site Admin
Posts: 6103
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC frequently resets to default settings randomly.

Post by phil » Sun Sep 29, 2019 11:36 am

XMBC is a windows app not a console app so there is no console window.... But that does not stop the windows app from having commandline arguments :) - it just means it does not show a console window!

XMBC is set to single instance (only one runs at once) but when you start a second one (with /exit for example) that second one communicates with the first one using IPC to pass that command line to the already running instance and tell it to do something.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
Kukurykus
Fanatic
Posts: 281
Joined: Sat Jul 02, 2016 1:15 pm

Re: XMBC frequently resets to default settings randomly.

Post by Kukurykus » Sun Sep 29, 2019 12:09 pm

Okey, I understand. I hoped maybe there is some easy way, as the only workaround to silently exectute system commands via Windows I found, was to trigger them by integrated .vb scripts.
HAMA Roma, Rapoo 3920P
Windows 10 x64, Intel i5-4670K @ 3.40GHz, 8GB,
Intel(R) HD Graphics 4600, Intel SSD 179 GB HDD

Post Reply