Simulated SHIFT During behaves odd

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links, files or images until they have at least 4 posts.
Post Reply
em27
New User
Posts: 5
Joined: Mon Aug 15, 2011 5:57 am

Simulated SHIFT During behaves odd

Post by em27 »

XMBC Version: 2.19.2

I used to have a multi bt mouse, but it died, and now I got this backup mouse, has only two side buttons. On the older one had its own cp app where to set this setting, but the current one doesn't and that cp app disabled itself. What it used to do is to use the 3rd button beside the back and forward buttons as SHIFT. Now on this two side button mouse I was trying this with XMBC,on button 5 and it behaves odd. Layer 1, button 5 (default forward), Simulated keys (during / 3) {SHIFT}. On left click it works alright, holding it when one file is selected and then clicking on a lower placed file will select all files in between. But if I hold it and then use the right click, it does not open the extended context menu as I'm expecting it to. It does it I use the keyboard, but not the simulated shift. What did I not configure right?

User avatar
phil
Site Admin
Posts: 6867
Joined: Sun Apr 06, 2003 11:12 pm

Re: Simulated SHIFT During behaves odd

Post by phil »

Have you setup the simulated keystroke to "During" to it stays held while the button is held?
I Wonder if the second button press (right click) is aborting the simkey sequence - before the right button is registered - I'm not 100% sure why it would work with the left click drag in this case, other that perhaps timing - the context menu appears after releasing the right button - well after the right button being pressed aborts the simkey sequence...

I will need to try and reproduce this here (but its 1am here right now and I'm away with work for the next few days so I wont be able to do that immediately).
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 1Tb NVME, 2x2TB WD Black (RAID1)

em27
New User
Posts: 5
Joined: Mon Aug 15, 2011 5:57 am

Re: Simulated SHIFT During behaves odd

Post by em27 »

Yes, it's set to during.
I can see the colors on the XMBC Layer panel, mb 5 + left click both get and stay colored yellow, mb 5 + right click alternates activation: mb 5 is yellow, I click the rmb this then turns yellow and mb 5 goes off, when I release rmb mb 5 turns back yellow. I've also tried with any other button together with mb 5, even the scroll wheel, and all stay together, only the rmb behaves differently.

User avatar
phil
Site Admin
Posts: 6867
Joined: Sun Apr 06, 2003 11:12 pm

Re: Simulated SHIFT During behaves odd

Post by phil »

OK so during is defo the right thing to do. But I cant figure out why it would be OK on ALL buttons except RMB.
I will have to have a look at the code to make sure there isn't some "special case" going on there - but I cant think of any reason there would be.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 1Tb NVME, 2x2TB WD Black (RAID1)

User avatar
phil
Site Admin
Posts: 6867
Joined: Sun Apr 06, 2003 11:12 pm

Re: Simulated SHIFT During behaves odd

Post by phil »

Just checked and its working perfectly here with {SHIFT} on button 5 and RMB to show the extended context menu... And the 5th button stays highlighted in orange(/yellow) too while pressing RMB... So there seems to be something wrong at your end.

Can you send (PM) me a copy of your profile (firstly), and then enable debug logging (settings/logging & updates tab) then once OK and APPLIED, perform the button 5 + rmb in explorer... Ideally make a note of the time you do this so I can locate it in the log, then send me a copy of the log file too.

NOTE: Debug logging will turn itself off after you exit/restart XMBC or you can turn it back off in settings.

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 1Tb NVME, 2x2TB WD Black (RAID1)

em27
New User
Posts: 5
Joined: Mon Aug 15, 2011 5:57 am

Re: Simulated SHIFT During behaves odd

Post by em27 »

Ok, post 4...

em27
New User
Posts: 5
Joined: Mon Aug 15, 2011 5:57 am

Re: Simulated SHIFT During behaves odd

Post by em27 »

Here's a copy of the log: pastebin com/1cBQv2xV

User avatar
phil
Site Admin
Posts: 6867
Joined: Sun Apr 06, 2003 11:12 pm

Re: Simulated SHIFT During behaves odd

Post by phil »

For some reason I am having to approve every post you make - I don't know why (and I hope it will fix itself on your next post as you should be out of "newly registered users". I will try and have a look at the log soon (but I cant do that tonight). I'll let you know what I find (if anything!)
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 1Tb NVME, 2x2TB WD Black (RAID1)

Post Reply