Explorer Settings ignored

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links, files or images until they have at least 4 posts.
Post Reply
dispalo
New User
Posts: 13
Joined: Thu Mar 21, 2019 11:24 am

Explorer Settings ignored

Post by dispalo »

XMBC Version: 2.19.2
Windows Version: 10
Mouse Information (brand/model): Drakonia

Good day to you.

Got an interesting problem. Part of the usual Windows10-Explorer is its file directory tree on the left side. You can turn that off by opening the ribbon on top, display (? using the german version) and deactivating the "navigation panel". When you open the explorer afterwards, you get your explorer windows without that directory tree on their left side.

Now we try to do that using xmbc. Choose a button on your mouse for opening the explorer and voila, it works. The explorer window opens and no navigation panel on its left side. "Open explorer at My documents", also working.

"Open explorer at specified directory" let's you choose a specified directory, let's take here the same directory we did before, "My documents". And voila... it doesn't work. When I use the specified directory I always get the navigation panel, whatever that location might be.

It's like this specific command ignores my explorer settings when it comes to the navigational panel. I assume you can reproduce it. It appears to me that only xmbc has that problem.

I can open that specific directory by choosing "Run Appilcation" and using a short cut here. Actually I like this even more, I think, because reasons. So no need to help me to circumvent this. But that looks like a couple of faulty lines in code there and I thought you might want to know that.

But by all means. When this can be helped by using the xmbc settings, please tell me. I'm curios :)

User avatar
phil
Site Admin
Posts: 6760
Joined: Sun Apr 06, 2003 11:12 pm

Re: Explorer Settings ignored

Post by phil »

I don't know whats different but it works fine for me :)
Just did the exact steps you described...

1. Turn off the navigation pane in explorer.
2. close explorer
3. Open explorer (confirm still no navigation pane)
4. Close explorer
5. Set middle button to "Open explorer at My Documents" (apply)
6. Press middle button -> explorer opens, no navigation pane - great, same as you.
7. Close explorer
8. Set middle button to "Open explorer at specific folder" choose <my documents> (apply)
9. Press middle button -> explorer opens at <my documents>, no navigation pane - as it should, not the same as you... Odd

Bit of a pain that it worked for me as you described it so well - I was strangely hoping I could say that I can reproduce it easily - but it appears not!
I have Win10 20H2 (UK English), and I do have "Launch folder windows in a separate process" enabled in my windows explorer settings (explorer view ribbon -> options -> view tab). Maybe that makes a difference, but I doubt it?!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

dispalo
New User
Posts: 13
Joined: Thu Mar 21, 2019 11:24 am

Re: Explorer Settings ignored

Post by dispalo »

I can still reproduce it. Interesting this is, but for different reasons now. I am an optimizer and I customized a lot, including the registry. I'm usually reasonably careful, but I am no expert at all. Who knows what's interfering with what now, or what I customized into disrepair. My Explorer is behaving in a weird way recently anyway. Not worried about it. In a month or so I wanted to playback an image anyway.

So, it's more pain for me, because I distracted you from more important things in your life. Thanks for the answer :)

User avatar
phil
Site Admin
Posts: 6760
Joined: Sun Apr 06, 2003 11:12 pm

Re: Explorer Settings ignored

Post by phil »

No problem - sometimes little distractions are nice! :D
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply