Autostart?

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
CrazySupporter
New User
Posts: 3
Joined: Sun Nov 10, 2019 3:33 am

Autostart?

Post by CrazySupporter » Sun Nov 10, 2019 3:39 am

XMBC Version: v2.18.8
Windows Version: Win 10Pro

Hey, my English is not so good.
So I use a Translator.
English :
I have the following problem.
With a very early version that went wonderfully with the startup.
But since some versions I have to start the program always extra, since even with the autostart the program does not run or works correctly.
The key functions do not work. What can this be?
I never changed anything.

Deutsch:
Ich habe folgendes Problem.
Mit einer sehr frühen Version ging das mit dem Autostart wunderbar.
Aber seit einigen Versionen muss ich das Programm immer extra starten, da selbst beim Autostart das Programm nicht läuft bzw. richtig arbeitet.
Die Tasten-Funktionen klappen nicht. Woran kann das liegen?
Ich habe nie was verändert.

User avatar
phil
Site Admin
Posts: 6106
Joined: Sun Apr 06, 2003 11:12 pm

Re: Autostart?

Post by phil » Sun Nov 10, 2019 5:23 pm

Do you know what the working version was? How long ago was it?
XMBC starts using the registry RUN key - you should see it in Windows Task Manager on the startup tab (assuming Windows 8 or later) or in MSConfig on Windows 7 or earlier in the startup tab. Check it is there and not disabled.

Did you install XMBC as a different user (I think auto-start may only work for the user that installed XMBC)?

----[Google translate -> German]-------

Wissen Sie, was die Arbeitsversion war? Wie lange ist es her?
XMBC beginnt mit der Verwendung des Registrierungsschlüssels RUN. Dieser sollte im Windows Task-Manager auf der Startregisterkarte (vorausgesetzt, Windows 8 oder höher) oder in MSConfig unter Windows 7 oder früher auf der Startregisterkarte angezeigt werden. Überprüfen Sie, ob es vorhanden und nicht deaktiviert ist.

Haben Sie XMBC als anderen Benutzer installiert (Ich denke, der automatische Start funktioniert möglicherweise nur für den Benutzer, der XMBC installiert hat)?
----------------------------------------------

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

CrazySupporter
New User
Posts: 3
Joined: Sun Nov 10, 2019 3:33 am

Re: Autostart?

Post by CrazySupporter » Wed Nov 13, 2019 2:23 am

Also ich habe jetzt mal mehrere Versionen probiert, aber immer das gleiche Problem.
Im Autostart habe ich das auch mal geändert, brachte aber nichts. Das Programm startet zwar beim Neustart und auch ist als Icon unten in der Taskleiste drin, aber die Tasten funktionieren nicht.
Erst wenn ich das Programm extra nochmal starte, reagieren die Tasten.
Bei Neustart ist das Programm offen, aber man sieht auch nicht das aufblinken der Tasten in dem Fenster, was bei einem neuen Start des Programms dann aber funktioniert.

English:
So now I have tried several versions, but always the same problem.
I also changed that during the startup, but did not bring anything. The program starts on reboot and is also there as an icon at the bottom of the taskbar, but the buttons do not work.
Only when I start the program again, the buttons react.
When restarting, the program is open, but you also do not see the flashing of the buttons in the window, which then works with a new start of the program.

User avatar
phil
Site Admin
Posts: 6106
Joined: Sun Apr 06, 2003 11:12 pm

Re: Autostart?

Post by phil » Wed Nov 13, 2019 9:05 am

Sorry I didn't realize that XMBC was running and not working. Do you have any other software that may be hooking the mouse on startup - that could be conflicting with XMBC. XMBC uses hooks to capture the mouse input. Another program could be using hooks also and not letting the XMBC hook do its stuff. Instead of closing and restarting XMBC, try disabling it and then enabling it (that should also work and will prove if the hook has been removed). Is there anything in the log file?

Try increasing the hook timeout value in settings - make it 5000ms then reboot and see if it makes any difference.
-------------------------------------------------------------------------------------------------
Entschuldigung, ich habe nicht bemerkt, dass XMBC läuft und nicht funktioniert. Haben Sie eine andere Software, die möglicherweise die Maus beim Start einhakt - dies könnte zu einem Konflikt mit XMBC führen. XMBC verwendet Hooks, um die Mauseingabe zu erfassen. Ein anderes Programm könnte auch Hooks verwenden und nicht zulassen, dass der XMBC-Hook seine Aufgaben erledigt. Anstatt XMBC zu schließen und neu zu starten, deaktivieren Sie es und aktivieren Sie es dann (das sollte auch funktionieren und wird prüfen, ob der Hook entfernt wurde). Befindet sich etwas in der Protokolldatei?

Erhöhen Sie den Wert für das Hook-Timeout in den Einstellungen. Stellen Sie ihn auf 5000 ms ein, starten Sie ihn neu und prüfen Sie, ob er einen Unterschied macht.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

CrazySupporter
New User
Posts: 3
Joined: Sun Nov 10, 2019 3:33 am

Re: Autostart?

Post by CrazySupporter » Thu Nov 14, 2019 6:01 pm

Also ich hatte nur ein Programm für meine Tastatur, aber das habe ich eben mal deaktiviert, brachte aber leider auch nichts. Wäre auch verwunderlich gewesen, weil beides schon mal ging, aber hab es dennoch versucht.
Wo kann man das Hook-Timeout einstellen/umstellen?
Und wo würde ich ein Protokoll finden? Im Installationsordner ist leider keine.


So I only had one program for my keyboard, but I just deactivated that, but unfortunately it did not work either. Would have been surprising, because both have ever gone, but have still tried.
And where would I find a log? In the installation folder is unfortunately no.

User avatar
phil
Site Admin
Posts: 6106
Joined: Sun Apr 06, 2003 11:12 pm

Re: Autostart?

Post by phil » Fri Nov 15, 2019 1:46 am

Did you try changing the hook timeout setting as requested?
The FAQ tells you how to find the log file - I'm not going to repeat myself here!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply