Initial Problems

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
TheArtfulDodger
New User
Posts: 4
Joined: Sat Oct 27, 2018 2:21 pm

Initial Problems

Post by TheArtfulDodger » Sat Oct 27, 2018 2:40 pm

XMBC Version: 2.17
Windows Version: 10 PRO, x64, Version 1803, OS Build 17134.320
Mouse Information (brand/model): Easterntimes Tech / 2.4G Wireless Optical Mouse Model D-09
Computer Information: Microsoft Surface Book
Did the problem occur after an upgrade of XMBC or Windows?: Initial Mouse Purchase
How long have you used XMBC?: 1 day
What language and keyboard layout do you use in Windows?: English

Clear description of the problem: I cannot get the wheel switch to produce a double click! The wheel does not scroll a web page.

I have tried changing the switch to up and down and both but nothing works. I have also tried these settings in the application but nothing happens!

Thank you in advance - I really don't want to send it back!

Sparky

User avatar
phil
Site Admin
Posts: 5550
Joined: Sun Apr 06, 2003 11:12 pm

Re: Initial Problems

Post by phil » Sat Oct 27, 2018 2:45 pm

HI,

When you press the wheel button, does the middle button dropdown in XMBC highlight in orange?
If it does, then XMBC should be able to remap it (and without XMBC running it should trigger autoscroll in applications that support it, like the browser0.

If not then XMBC is simply not seeing the button - there are several reasons or that...

1. The button is not working
2. The mouse driver is not sending the correct message for the button
3. Something else in Windows is swallowing the button message and not passing it through to other applications.

If you have another mouse, check that it works as expected- if it does then I'd focus on 1 and 2 above. If the button does nothing anywhere then the chances are its simply broken (can you try the mouse in another PC to test it there?). Check what driver you are using, and if its not the Microsoft generic HID device, try using that instead?

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

TheArtfulDodger
New User
Posts: 4
Joined: Sat Oct 27, 2018 2:21 pm

Re: Initial Problems

Post by TheArtfulDodger » Sat Oct 27, 2018 3:38 pm

Hi, Phil:
I guess I'm a bit confused. You asked about the middle button - but there's no middle button. There is a right and left button, a scrolling mouse button, and a switch on the mouse wheel. Having said that, I hadn't noticed the orange popping up on the main XMBC Screen. Having noticed it, however, why does XMBC interpret the wheel switch as a middle button and not the wheel switch.

However, even though the XMBC shows the middle button closing and opening, it does not operate as a double click.

WorkAround: I did get the following to work: For Left Button, I assigned "Left Click". For Right Button, I assigned "Right Click". For the Wheel Switch. to the Middle Button, I assigned "{LMB}{LMB}". That combination seems to work. I cannot explain it!

Sparky

User avatar
phil
Site Admin
Posts: 5550
Joined: Sun Apr 06, 2003 11:12 pm

Re: Initial Problems

Post by phil » Sat Oct 27, 2018 6:20 pm

Hi,

On most mice, the wheel is between the left and right buttons, hence it is in the middle and referred to generally as the middle button (when pressed) and scroll wheel when scrolled up and down. Windows internally refers to it as the middle button and/or button 3 (where button 1 is left and button 2 right click). Back in the day (before the wheel was added to mice) we had some 3 button mice, left, right and middle (between the two), so I guess its a historic thing!

Now some mice have another button just below the wheel... Most of the time this is hard wired in the mouse to adjust DPI (i.e. the mouse gets faster or slower when clicking this button). It sends nothing to Windows and cant be remapped by XMBC(is this what you were referring to, or did you mean the wheel button all along?)

You mentioned that the wheel was not scrolling - did you fix that? Usually you can leave the scroll up/down as "nothing, don't intercept" and it will scroll by default. NOTE: XMBC by default turns on universal scrolling so you should be able to scroll windows under the cursor without activating them - this doesn't work for all applications and can be turned off in the general settings tab using the "make scroll wheel scroll window under cursor" option.

Anyway... It seems you have made some progress.. I would recommend leaving LEFT and RIGHT set to "nothing (don't intercept)" rather than left/right click respectively (as the default is left and right click anyway so you don't need XMBC getting involved (and potentially slowing things down a little) for those buttons).

So now it seems that the "double click" selection is not working - and that is a known issue and related to timing so sometimes it works and sometimes not. I have already fixed this in 2.18 Beta series but behind the scenes it effectively does {LMB}{LMB} as you have done with simulated keystrokes, so no need to rush to the beta for the fix as you have it working now anyway!

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

TheArtfulDodger
New User
Posts: 4
Joined: Sat Oct 27, 2018 2:21 pm

Re: Initial Problems

Post by TheArtfulDodger » Sun Oct 28, 2018 1:33 pm

Hi, Phil:

I can't seem to find how to insert a screen shot - is there a way?

Sparky

User avatar
phil
Site Admin
Posts: 5550
Joined: Sun Apr 06, 2003 11:12 pm

Re: Initial Problems

Post by phil » Sun Oct 28, 2018 5:18 pm

You can upload the image file as an attachment and place it inline or you can use the IMG option to link to an image off site.
But I think you need to have made 4 posts before this is allowed... Your on 3. I'll manually move you out of the new user group and it should work then.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

TheArtfulDodger
New User
Posts: 4
Joined: Sat Oct 27, 2018 2:21 pm

Re: Initial Problems

Post by TheArtfulDodger » Sun Oct 28, 2018 5:45 pm

Hi, Phil:

Thanks - I looked everywhere for a link but couldn't find one!

Anyway, here's a screen shot of exactly why I misunderstood the Wheel Button.
Wheel Button from Microsoft.jpg
But, now it seems to be working well.

Yes, the scrolling seems to be working OK too.

I will go back and change the right & left button and let you know how I make out!

Thanks again for the understanding!

Sparky
You do not have the required permissions to view the files attached to this post.

Post Reply