Mousewheel scrolling in Game Maker Studio 2 not functioning when XMBC enabled

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
OtherChris
New User
Posts: 2
Joined: Mon Sep 10, 2018 6:19 pm

Mousewheel scrolling in Game Maker Studio 2 not functioning when XMBC enabled

Post by OtherChris » Mon Sep 10, 2018 7:58 pm

XMBC Version: 2.17
Windows Version: Windows 10
Mouse Information (brand/model): Logitech M500 (Corded)
Computer Information: It's not a gaming rig
Did the problem occur after an upgrade of XMBC or Windows?: No
How long have you used XMBC?: Five or so years
What language and keyboard layout do you use in Windows?: English, regular

Clear description of the problem:

Game Maker Studio 2 prides itself on its new workspace environment, wherein you can arrange objects and elements to organize a project to your liking. It comes at the price that, instead of having a separate window or tab for things like the script editor, these windows are embedded within the workspace. If I click within an opened script editor, I would normally expect to be able to scroll up or down through lines of code using the mousewheel. What I've found was that when X-Mouse is enabled, mousewheel scrolling does not work in any of the application. (I originally thought it was exclusive to workspace elements, but it doesn't work for the resource tree or console log either!) If I disable X-mouse, mousewheel scrolling immediately works as intended, across the board.

I find that strange, since the only buttons I change in my "For Work" profile are 4 and 5, which I use for Magnifier Zoom In and Zoom Out. Secondly, none of the other buttons are impeded within GMS2 (Left, right middle). And finally, I've been using X-Mouse for five or so years, and I've never seen this problem occur for any other software I've used while running X-Mouse.
---------------------------------------------------------
I consider this to be a problem with GMS2, not X-Mouse. But since this is a matter of two programs not getting along, of course I have to bring it up with both parties. I do have to give props for just how well X-Mouse works for me overall. The fact that I can enable/disable it for an easy stress test alone puts it above the built-in Windows mouse rebinding stuff that did not exist when I first got this. I may try testing Windows' take on rebinding to see if that works in GMS2, but I have a feeling my allegiance is going to remain unchanged.

User avatar
phil
Site Admin
Posts: 5499
Joined: Sun Apr 06, 2003 11:12 pm

Re: Mousewheel scrolling in Game Maker Studio 2 not functioning when XMBC enabled

Post by phil » Mon Sep 10, 2018 11:19 pm

OK I think there is a simple fix...

By default, XMBC sends scroll messages to the window under the cursor to enable "universal" scroll where the window does not have to be activated to scroll. This does not work in all cases though, especially windows which have unusual behaviors such as embedded editors as you have found.

The first thing to try is to disable this option, in general settings, turn off "make scroll wheel scroll window under the cursor" and see if that fixes it.

If it does, but you don't want to globally turn off this option you can create a profile for GMS2 and disable scroll window under cursor just for that process/window using the setting on the profile's options tab.

Let me know if that works out.

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

OtherChris
New User
Posts: 2
Joined: Mon Sep 10, 2018 6:19 pm

Re: Mousewheel scrolling in Game Maker Studio 2 not functioning when XMBC enabled

Post by OtherChris » Tue Sep 11, 2018 12:06 am

That did it!

Somehow I overlooked that settings button, and was only looking at the options available in the "Scrolling" and "Options" tabs next to the layers. I'm glad it was a simple fix. Thanks for getting back to me so quickly.

Post Reply