XMBC frequently resets to default settings randomly.

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
Foghorn
New User
Posts: 4
Joined: Thu May 17, 2018 12:57 pm

XMBC frequently resets to default settings randomly.

Post by Foghorn » Thu May 17, 2018 2:01 pm

XMBC Version:
Windows Version:
Mouse Information (brand/model):
Computer Information:
Did the problem occur after an upgrade of XMBC or Windows?:
How long have you used XMBC?:
What language and keyboard layout do you use in Windows?:

Clear description of the problem:

2.16.1
Windows 10 v.1709 os build 16299.431
Cyber Power "Gaming optical mouse"
64 bit operating system, x64-based processor
Unknown, but don't believe so.
2 years
English, qwerty

XMBC frequently resets to default settings randomly. Re-install of XMBC restores my settings. Worked fine for months before the problem started.

User avatar
phil
Site Admin
Posts: 5415
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC frequently resets to default settings randomly.

Post by phil » Fri May 18, 2018 8:17 am

That's certainly odd and not something I have seen... XMBC stores its settings in an xml settings file (somewhere under your user profile by default). You can load and save other profiles, which get saved as XMBCS files - which if you double click, will open in XMBC (thus changing your settings) but I guess you are not doing that!

When the settings are reset, do you loose all application profiles? or is it specific settings?

Are there anything (errors/warnings) in the log file - there probably wont be much as by default logging is minimal. You might like to turn on debug logging and when it randomly resets the settings again send me a copy of the log, ideally highlighting the time at which the reset occurred (roughly). Note that debug logging will turn itself off once XMBC restarts!

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Foghorn
New User
Posts: 4
Joined: Thu May 17, 2018 12:57 pm

Re: XMBC frequently resets to default settings randomly.

Post by Foghorn » Fri May 18, 2018 2:22 pm

When the settings are reset, do you loose all application profiles? or is it specific settings?
It resets to the mouse's original button functions, but as soon as I reload XMBC, hit finish, it changes to my chosen setting with no setting adjustment needed, so it appears to save my profile. It just turns itself off.
I'm not computer literate enough to know how to turn on debug logging.

User avatar
phil
Site Admin
Posts: 5415
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC frequently resets to default settings randomly.

Post by phil » Sat May 19, 2018 1:03 am

Ah OK, so its like XMBC is exiting/crashing or simply being disabled - causing the mouse buttons to not be re-mapped.
If its crashing or exiting, then the XMBC icon (in the system tray, to the right of the taskbar by the clock) will go away until you re-load it?
If its being disabled, the icon will change from a white mouse icon to a grey mouse icon with a little red X in it.

NOTE: the icon may be hidden in the extended system tray - in which case, the little up ^ arrow to the left of the icons in the system tray should show it.

To turn on debug logging, in XMBC, hit the settings button and then on the "Updates and logging" tab, you can turn it on there. Debug logging only stays on until next time XMBC is run (or you turn it off manually). You can also open the log file from that tab. Turn it on, hit OK and APPLY, wait for it to go wrong, then <run XMBC again> open up the log file and copy and paste it here, or PM/email the whole log file to me as an attachment.

I am rather busy at the moment - most of my weekends are all booked up, but I will try and find some time to look into the log if you can get it to me!

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Foghorn
New User
Posts: 4
Joined: Thu May 17, 2018 12:57 pm

Re: XMBC frequently resets to default settings randomly.

Post by Foghorn » Mon May 21, 2018 2:09 am

Excellent. Thanks. I'll do the above as soon as I can. I appreciate the help.

Foghorn
New User
Posts: 4
Joined: Thu May 17, 2018 12:57 pm

Re: XMBC frequently resets to default settings randomly.

Post by Foghorn » Mon May 21, 2018 3:40 am

It had "crashed" while I was out of town between 5/18 and 5/20 if that helps you identify anything in this log.

18-05-2018 09:00:49.0765> X-Mouse Button Control v2.16.1 (x64) Startup. Commandline '/installed /notportable'
18-05-2018 09:00:49.0859> Running in high integrity mode (0x00003000)
18-05-2018 09:00:49.0859> Loaded 0 application specific profiles (0 normal and 0 custom window).
18-05-2018 09:00:49.0859> Running on Microsoft Windows 10 Home Edition (build 16299), 64-bit, Hook Timeout: 1000 ms
18-05-2018 09:00:49.0859> Startup folder: 'C:\Program Files\Highresolution Enterprises\X-Mouse Button Control\'
18-05-2018 09:00:49.0859> Settings (and log) folder: 'C:\Users\Foggy\AppData\Roaming\Highresolution Enterprises\XMouseButtonControl\'
18-05-2018 09:00:49.0875> Using keyboard language 0x04090409
18-05-2018 16:14:28.0343> Power State: System is suspending operation.
18-05-2018 16:14:28.0359> Reinstall mouse hook on resume is enabled. Remove hook before suspending...
18-05-2018 16:14:28.0359> Removing any active XMBCHook Timers...
18-05-2018 16:14:28.0406> CSendInput: Exiting SendInput thread.
18-05-2018 16:14:28.0406> Hook thread exited with error code 0.
18-05-2018 16:14:28.0406> Timer thread exited with error code 0.
18-05-2018 16:14:28.0406> RemoveMouseHook took 47ms
20-05-2018 20:42:56.0390> Power State: Operation resuming automatically after event.
20-05-2018 20:42:56.0390> Reinstall mouse hook on resume is enabled. Re-hooking mouse...
20-05-2018 20:42:56.0656> Loaded 0 application specific profiles (0 normal and 0 custom window).
20-05-2018 20:42:57.0390> Using keyboard language 0x04090409
20-05-2018 20:44:56.0421> There is a new version available! (2170000)
20-05-2018 20:59:54.0921> MultInstance: Sending commandline to an existing instance of X-Mouse Button Control
20-05-2018 20:59:54.0921> MultInstance: Successfully finished communicating with the first instance of X-Mouse Button Control.
20-05-2018 20:59:54.0921> Received message with data 0x80000021 from another instance of X-Mouse Button Control.
20-05-2018 20:59:54.0921> Exit requested from the commandline.
20-05-2018 20:59:54.0968> Removing any active XMBCHook Timers...
20-05-2018 20:59:54.0984> CSendInput: Exiting SendInput thread.
20-05-2018 20:59:54.0000> Hook thread exited with error code 0.
20-05-2018 20:59:54.0000> Timer thread exited with error code 0.
20-05-2018 20:59:54.0000> RemoveMouseHook took 32ms
20-05-2018 20:59:54.0000> X-Mouse Button Control Shutdown.



*******************************************************************************************************************************************
20-05-2018 21:00:04.0281> X-Mouse Button Control v2.16.1 (x64) Startup. Commandline '/installed /notportable'
20-05-2018 21:00:04.0515> Running in high integrity mode (0x00003000)
20-05-2018 21:00:04.0531> Loaded 0 application specific profiles (0 normal and 0 custom window).
20-05-2018 21:00:04.0531> Running on Microsoft Windows 10 Home Edition (build 16299), 64-bit, Hook Timeout: 1000 ms
20-05-2018 21:00:04.0531> Startup folder: 'C:\Program Files\Highresolution Enterprises\X-Mouse Button Control\'
20-05-2018 21:00:04.0531> Settings (and log) folder: 'C:\Users\Foggy\AppData\Roaming\Highresolution Enterprises\XMouseButtonControl\'
20-05-2018 21:00:04.0562> Using keyboard language 0x04090409
20-05-2018 21:17:07.0546> MultInstance: Sending commandline to an existing instance of X-Mouse Button Control
20-05-2018 21:17:07.0562> MultInstance: Successfully finished communicating with the first instance of X-Mouse Button Control.
20-05-2018 21:17:07.0562> Received 2048 bytes on the IPC named pipe.
20-05-2018 21:17:07.0562> Received message with data 0x80000021 from another instance of X-Mouse Button Control.
20-05-2018 21:17:07.0562> Exit requested from the commandline.
20-05-2018 21:17:07.0562> Removing any active XMBCHook Timers...
20-05-2018 21:17:07.0609> CSendInput: Exiting SendInput thread.
20-05-2018 21:17:07.0609> Hook thread exited with error code 0.
20-05-2018 21:17:07.0609> Timer thread exited with error code 0.
20-05-2018 21:17:07.0609> RemoveMouseHook took 47ms
20-05-2018 21:17:07.0609> X-Mouse Button Control Shutdown.



*******************************************************************************************************************************************
20-05-3918 21:17:37.594> X-Mouse Button Control v2.17 (x64) Startup. Commandline '/installed /notportable'
20-05-3918 21:17:38.185> Running in high integrity mode (0x00003000)
20-05-3918 21:17:38.259> Loaded 0 application specific profiles (0 normal and 0 custom window).
20-05-3918 21:17:38.259> NewApplicationSettings: SPIThread is not initialised.
20-05-3918 21:17:38.260> Running on Microsoft Windows 10 Home Edition (build 16299), 64-bit, Hook Timeout: 1000 ms
20-05-3918 21:17:38.260> Startup folder: 'C:\Program Files\Highresolution Enterprises\X-Mouse Button Control\'
20-05-3918 21:17:38.260> Settings (and log) folder: 'C:\Users\Foggy\AppData\Roaming\Highresolution Enterprises\XMouseButtonControl\'
20-05-3918 21:17:38.346> Using keyboard language 0x04090409

Post Reply