XMBC 2.18 Beta

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
User avatar
phil
Site Admin
Posts: 5593
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.18 Beta

Post by phil » Sat Dec 08, 2018 6:51 pm

Here is 2.18 Beta 16...

If you have check for beta versions enabled, you should get notified of a new version and prompted to update in the next day or so. This is the most efficient method (bandwidth wise) as the updates are only a fraction of the size of the full install. Otherwise, you can get the full installation beta HERE. Note that this link will always get you the latest beta version!

Changes since v2.18 Beta 15:
  • #591 - When copying an application profile, Button Held and MTS actions are not copied
  • #590 - Add ability to change enhance pointer precision option in application/window profile
  • #589 - Fixed an issue where toggle magnifier or launching an application/explorer window could cause a hook timeout and leak the original button action
  • #588 - Fixed scrollbar on profile list being shown when it shouldn't be!
  • #587 - Fixed (I hope) issue introduced in 2.18 Beta 15 which broken some profile detection
*** Please test profile detection to check I haven't broken anything! ***

There are no new language strings in 2.18 Beta 16 (the last language change was in 2.18 Beta 14).

Any problems, PM me a copy of the debug log file (or post a snippet in a code block here).

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
Kukurykus
Committed
Posts: 198
Joined: Sat Jul 02, 2016 1:15 pm

Re: XMBC 2.18 Beta

Post by Kukurykus » Sat Dec 08, 2018 7:43 pm

#587 - Fixed (I hope) issue introduced in 2.18 Beta 15 which broken some profile detection
Unfortunatelly it's still broken in Beta 16, so like in Beta 15 :( I temporarily moved to Beta 14.
HAMA Roma, Rapoo 3920P
Windows 10 x64, Intel i5-4670K @ 3.40GHz, 8GB,
Intel(R) HD Graphics 4600, Intel SSD 179 GB HDD

User avatar
maxoku
Committed
Posts: 137
Joined: Sun Apr 02, 2017 5:21 pm

Re: XMBC 2.18 Beta

Post by maxoku » Sat Dec 08, 2018 7:55 pm

@Kukurykus
Have you updated it or installed from the downloaded file?

@Phil
XMBC still can't see the update after 1 hour from uploading. O it doesn't want to check it? It immediately shows the dialog that I have the latest version. It always takes some time to check. It did once an hour ago and now is this. :?

User avatar
Kukurykus
Committed
Posts: 198
Joined: Sat Jul 02, 2016 1:15 pm

Re: XMBC 2.18 Beta

Post by Kukurykus » Sat Dec 08, 2018 8:06 pm

Updated. I have sometimes same. Restarting computer always was helping.
HAMA Roma, Rapoo 3920P
Windows 10 x64, Intel i5-4670K @ 3.40GHz, 8GB,
Intel(R) HD Graphics 4600, Intel SSD 179 GB HDD

User avatar
phil
Site Admin
Posts: 5593
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.18 Beta

Post by phil » Sat Dec 08, 2018 8:28 pm

Updates use DNS TXT records to propagate the latest version.
This can take up to 24hrs to propagate around the web (and through your local DNS cache).
So thats quite normal.

@Kukurykus... OK Debug log please (with you moving the cursor between these windows). Because I have pretty much put it back to 2.14 code (but with a different fix for the region issue).
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
Kukurykus
Committed
Posts: 198
Joined: Sat Jul 02, 2016 1:15 pm

Re: XMBC 2.18 Beta

Post by Kukurykus » Sat Dec 08, 2018 8:57 pm

I'm sending you the same action for Beta 14 and Beta 16:

I exited XMBC, deleted 'XMouseButtonControl.txt', launched XMBC, opened settings to enable DEBUG log, applied changes and switched to Photoshop where I already had open document in full screen mode.

Beeing with cursor over document I pressed Middle Button (that used F2 key). Then I opened XMBC settings to disable DEBUG log and apply changes. Finally I exited XMBC and copied 'XMouseButtonControl.txt' to desktop to rename to appropriate Beta version.


For Beta 14 it worked - some bound action was performed. For Beta 15 it didn't.

I tried to compare Beta 14 to Beta 16 logs, but I didn't find differences that would help me and probably you to know what happens. Probably you'll find something I couldn't see ;)
You do not have the required permissions to view the files attached to this post.
HAMA Roma, Rapoo 3920P
Windows 10 x64, Intel i5-4670K @ 3.40GHz, 8GB,
Intel(R) HD Graphics 4600, Intel SSD 179 GB HDD

User avatar
maxoku
Committed
Posts: 137
Joined: Sun Apr 02, 2017 5:21 pm

Re: XMBC 2.18 Beta

Post by maxoku » Sat Dec 08, 2018 11:05 pm

@Kukurykus
Thanks, restarting helped.

@Phil
It seems that I could be right and XMBC just didn't want to check and did it only after restart.

I've checked that point Kukurykus is saying about still works the same like in beta 15.

Copying profiles with held button has been fixed, but that scrollbar not.

What about the 7+tt problem? Do you need all my profiles like an "export all" profiles or my settings as save (user) profile?

User avatar
phil
Site Admin
Posts: 5593
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.18 Beta

Post by phil » Sat Dec 08, 2018 11:22 pm

maxoku wrote:
Sat Dec 08, 2018 11:05 pm
@Phil
It seems that I could be right and XMBC just didn't want to check and did it only after restart.
A restart will flush your DNS cache.. So yeh that might help. As might running ipconfig /flushdns but the point is DNS does not updqate instantly and this is NOT a problem!
maxoku wrote:
Sat Dec 08, 2018 11:05 pm
I've checked that point Kukurykus is saying about still works the same like in beta 15.
And the result of your check is?!???
maxoku wrote:
Sat Dec 08, 2018 11:05 pm
Copying profiles with held button has been fixed, but that scrollbar not.
Good for the copy.
Bad for the scroll bar - it fixed it here for me - although it was only broken on my laptop, the desktop was fine... It appears it may be a DPI related issue (and broken in Microsoft's own component) Your full settings (all profiles list) may be of use here. And what DPI is your screen running at? Surprised my "fix" didn't work for you though.
maxoku wrote:
Sat Dec 08, 2018 11:05 pm
What about the 7+tt problem? Do you need all my profiles like an "export all" profiles or my settings as save (user) profile?
Well it probably does not matter. A full export will be most useful but a save profile will be better than the nothing I have right now. I presume the 7+TT issue is also not fixed in beta 16. I have 7+TT so I would be able to reproduce it if I had your profile(s). A bit late now though as I think Ive already fixed it... PM coming!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
maxoku
Committed
Posts: 137
Joined: Sun Apr 02, 2017 5:21 pm

Re: XMBC 2.18 Beta

Post by maxoku » Sun Dec 09, 2018 1:03 am

phil wrote:
Sat Dec 08, 2018 11:22 pm
And the result of your check is?!???
For me is the 2nd layer scroll left/right as I described before.
Bad for the scroll bar - it fixed it here for me - although it was only broken on my laptop, the desktop was fine... It appears it may be a DPI related issue (and broken in Microsoft's own component) Your full settings (all profiles list) may be of use here. And what DPI is your screen running at? Surprised my "fix" didn't work for you though.
For it was on my old computer (WinXP) and now on notebook (Win8.1). I've sent you everything in PM. As for DPI I don't really know. I didn't change it, so it's the default setting. It's the middle option of three in the Control Panel.
I have 7+TT so I would be able to reproduce it if I had your profile(s). A bit late now though as I think Ive already fixed it... PM coming!
Still not fixed in beta 16.1.

User avatar
Kukurykus
Committed
Posts: 198
Joined: Sat Jul 02, 2016 1:15 pm

Re: XMBC 2.18 Beta

Post by Kukurykus » Sun Dec 09, 2018 1:11 am

I think Phil asked of result of the problem I met, but probably yours is related somehow to that too ;)
HAMA Roma, Rapoo 3920P
Windows 10 x64, Intel i5-4670K @ 3.40GHz, 8GB,
Intel(R) HD Graphics 4600, Intel SSD 179 GB HDD

CollinChaffin
New User
Posts: 3
Joined: Mon Jun 18, 2018 1:44 am

Re: XMBC 2.18 Beta

Post by CollinChaffin » Sun Dec 09, 2018 2:49 am

Of all versions ever released of XMBC I think despite being a beta you need to consider pulling this one back (beta 16). I am trying to download an older beta to roll back as we speak when you added this "mouse precision" what it is doing on my systems after beta16 update just now is CONTINUALLY unchecking the box in mouse control panel upon upgrading my mouse sped up triple speed because beta16 apparently continually will force OFF precision (even if you previously had it ENABLED before beta16), what's worse if even upon re-enabling in mouse control panel (which sets my mouse speed back to normal), literally within a minute or two, XMBC apparently is on a timer and RE-DISABLES it forcibly because if I wait a couple min with XMBC enabled (this does NOT occur if it is closed) and go back into mouse control panel, the enhance precision checkbox is magically now disabled but with XMBC (beta 16 only) CLOSED if I reenable my normal precision setting it will then remain enabled indefinitely (as it should).

Where is the download for Beta15?

EDIT: It appears it may not actually be periodically but because I made the mistake of simply re-opening XMBC at all (to confirm the beta version etc.) which at that point even just clicking "close" and not apply if you do not have "override mouse speed" enabled (which I do not intend to override anything), it at that point has unchecked the box (changed the setting/reg key/etc. reflected in the checkbox) and that is also when mouse speed jumps three times due to prior precision being disabled by XMBC. XMBC should not be doing ANYTHING to the precision setting unless I check the box telling it to so i guess my point is - that instead it is doing so.

EDIT2: Nope - bad, bad, bad. I just also tested and can confirm that now XMBC for the first time actively has changed and continues to change my mouse precision (forcing it off) ON EVERY LAYER APP, not just default. So, I have a layer set up for an exception app with different settings. Even if for 5 min I got my original precision back enabled in control panel, I spoke before I opened that LAYER2 app. Now, as soon as layer2 became effective with that app, BOOM my precision was once again forced off and is unchecked in control panel - I knew as soon as that app launced and the mouse speed was again sped up 3x losing the precision. So, I would greatly appreciate knowing where I can download beta15, and/or how to disable this sudden new behavior.

User avatar
phil
Site Admin
Posts: 5593
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.18 Beta

Post by phil » Sun Dec 09, 2018 3:59 am

Try turning on pointer precision in the XMBC general settings page - that should at least stop XMBC turning it back off (as it will use that as the default)... It wont be changing on a timer, its more likely to be as the profile (default or other) is activated... Not right but I think that would make sense. Similar issues happened when I changed the mouse speed to per-profile - I though this time I had tested it enough to avoid that but clearly not.

Previous betas are still available as it pretty much any version. Just substitute the version number at the end of the link
https://www.highrez.co.uk/scripts/downl ... on=2180015 2180015 = 2.18 beta 15, 2180014 = beta 14 and so on.

I do appreciate the feedback, and I'm sorry but I would like to remind you and everyone else that this is exactly what the beta process is for, introducing new things that people request and can test before they get released (and effect everyone negatively if something is wrong). No one is forcing you to run the beta versions or jump onto it the day it is made available.

Pulling the beta? No much better to try and fix it (OK if I cant do that quickly it might be worth pulling it or undoing the change) but hopefully I can fix it tomorrow!

PS, Any chance of sending the debug log file? It might make things easier to fix.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
Kukurykus
Committed
Posts: 198
Joined: Sat Jul 02, 2016 1:15 pm

Re: XMBC 2.18 Beta

Post by Kukurykus » Sun Dec 09, 2018 4:15 am

I just had to say how to download earlier Beta, but you did that first ;) and I agree, that's good you reminded it's Beta phase, not finished product - it needs tests I appreciate. For example huge companies which enslaved their users with subscription model like Adobe (that makes Photoshop), do not engage testers anymore. The users are unaware Beta testers in official Alpha release! You can't imagine what happens on their forums, while they don't care because thye got monopoly for images / graphics apps.

Few times I mentioned on their forums of just one man (you) and 'free' program he develops for 15 years with a passion, where the priority over new features mostly is making everything bug free. For Adobe it's more important to encourage new users by new (kind of) features while keeping bugs if not enough of them complain on. This is sad, as they have many engineers, but no reliable managament, while you are one and manage everything with 'no problem'.
HAMA Roma, Rapoo 3920P
Windows 10 x64, Intel i5-4670K @ 3.40GHz, 8GB,
Intel(R) HD Graphics 4600, Intel SSD 179 GB HDD

User avatar
phil
Site Admin
Posts: 5593
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.18 Beta

Post by phil » Sun Dec 09, 2018 6:15 pm

Here is 2.18 Beta 17...

I hope this will fix the broken implementation of Enhance Pointer Precision on a per profile basis and respect what has been set in Windows (unless you intentionally override it!).

If you have check for beta versions enabled, you should get notified of a new version and prompted to update in the next day or so. This is the most efficient method (bandwidth wise) as the updates are only a fraction of the size of the full install. Otherwise, you can get the full installation beta HERE. Note that this link will always get you the latest beta version!

Changes since v2.18 Beta 16:
  • #590 - Fixed issue causing Windows enhance pointer precision to be reset (turned off) after introducing new per profile option.
  • #588 - Further fixes for scrollbar on profile list being shown when it shouldn't be!
  • #587 - More changes, mostly debug logging to assist in debugging some issues with profile detection.
*** Please test profile detection to check I haven't broken anything! ***

NOTE To Kukurykus and Maxoku - thanks for your assistance so far diagnosing #587. This build should be no different than the internal build I gave you last night (which apparently is now working for Kukurykus at least). I have added some more useful/relevant debug log around the profile detection through so it may be of help for further diagnosis if required.

There are no new language strings in 2.18 Beta 16 (the last language change was in 2.18 Beta 14).

Any problems, PM me a copy of the debug log file (or post a snippet in a code block here).

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
Kukurykus
Committed
Posts: 198
Joined: Sat Jul 02, 2016 1:15 pm

Re: XMBC 2.18 Beta

Post by Kukurykus » Sun Dec 09, 2018 6:32 pm

I confirm that 16.1 and now 17 solves the problem (they work like Beta 14, while 15 and 16 broke XMBC).

For everyone who wants to use main profile buttons (having also sublcasses of that profile on list of apps.) when the same button is not assigned for subclasses but is for main process, please remember to fill these 2 boxes when you're editing subclass profiles (in Specific Window):

'Only Match If There Is No Parent Class' & 'Enable Regular Expression Matching'.
HAMA Roma, Rapoo 3920P
Windows 10 x64, Intel i5-4670K @ 3.40GHz, 8GB,
Intel(R) HD Graphics 4600, Intel SSD 179 GB HDD

Post Reply