XMBC 2.11 Beta

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
User avatar
phil
Site Admin
Posts: 6101
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.11 Beta

Post by phil » Sun Apr 26, 2015 9:24 pm

OK, here is XMBC v2.11 Beta 3.

If you have check for beta versions enabled, you should get notified of a new version and prompted to update in the next day or so. This is the most efficient method (bandwidth wise) as the updates are only a fraction of the size of the full install. Otherwise, you can get the full installation beta HERE.

Changes since v2.11 Beta 2:
  • #301 - Added on screen volume display indicator (styled like the Windows 8 Volume OSD), shown when using XMBC to change volume (Pre Windows 8 only). It can also optionally be shown when anything changes the volume.
  • - Dropped support for Windows 2000. XMBC now only supports Windows XP and greater
Any problems, PM me a copy of the log file (or post a snippet in a code block here).

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
phil
Site Admin
Posts: 6101
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.11 Beta

Post by phil » Mon May 04, 2015 9:55 pm

OK, here is XMBC v2.11 Beta 4.

If you have check for beta versions enabled, you should get notified of a new version and prompted to update in the next day or so. This is the most efficient method (bandwidth wise) as the updates are only a fraction of the size of the full install. Otherwise, you can get the full installation beta HERE.

Changes since v2.11 Beta 3:
  • #303 - Added OSD for brightness controls.
  • #301 - Modified OSD to ensure that is stays visible when required (inc. after suspend/resume). Fixed flickering redraw and added interactive OSD (ability to draw the OSD bar or use the scroll wheel to manipulate it)
Any problems, PM me a copy of the log file (or post a snippet in a code block here).

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

WayHow47
Member
Posts: 26
Joined: Fri Jan 16, 2015 5:27 pm

Re: XMBC 2.11 Beta

Post by WayHow47 » Thu May 07, 2015 2:08 pm

Hello Phil,

Things are working well for me but when I installed Beta 4 of 2.11 there is a weird artifact when I do an Alt-tab. It still appears after a reboot. I'm running Windows 8.1 Pro.

Please see attachment.

Thanks,

Wayne
You do not have the required permissions to view the files attached to this post.

User avatar
phil
Site Admin
Posts: 6101
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.11 Beta

Post by phil » Thu May 07, 2015 9:58 pm

that would be the volume/brightness OSD... hummm didn't think of that - will have to hide it from the task switcher! Thanks for letting me know!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

gwarser
New User
Posts: 3
Joined: Sat May 09, 2015 12:12 pm

Re: XMBC 2.11 Beta

Post by gwarser » Tue May 12, 2015 11:13 am

Happened just now, after automatic restart issued by Realtek HD audio driver installation.

Code: Select all

---------------------------
Fatal error in X-Mouse Button Control!
---------------------------
A fatal error occurred.
Exception type: EXCEPTION_ACCESS_VIOLATION - C0000005 (-1073741819)

X-Mouse Button Control will now close!

Please inform the developer.
---------------------------
OK
---------------------------

Code: Select all

*******************************************************************************************************************************************
12-05-2015 11:56:00.0987> X-Mouse Button Control v2.11 Beta 4 (x64) Startup. Commandline '/notportable'
12-05-2015 11:56:00.0987> Running on Microsoft Windows 7 Enterprise Edition Service Pack 1 (build 7601), 64-bit, Hook Timeout: 5000 ms
12-05-2015 11:56:00.0987> X-Mouse Button Control is NOT running using an elevated administrative account (UAC elevation)
12-05-2015 11:56:00.0987> Startup folder: 'C:\Program Files\Highresolution Enterprises\X-Mouse Button Control\'
12-05-2015 11:56:00.0987> Settings (and log) folder: 'C:\Users\off\AppData\Roaming\Highresolution Enterprises\XMouseButtonControl\'
12-05-2015 11:56:00.0987> Hooking the mouse...
12-05-2015 11:56:00.0987> Successfully hooked into the mouse messages.
12-05-2015 11:56:00.0987> Current language is 0x04150415
12-05-2015 11:56:00.0987> Checking installed keyboard layout: 0x04150415
12-05-2015 11:56:00.0987> Unable to find suitable English keyboard layout... Loading US English.
12-05-2015 11:56:00.0003> HookThread: Successfully set the mouse hook 0x10179
12-05-2015 11:56:00.0003> HookThread: Successfully set the keyboard hook 0x1017B
12-05-2015 11:56:00.0065> Enabling extra debug logging.
12-05-2015 11:56:00.0065> Hook thread exited successfully.
12-05-2015 11:56:00.0065> Reset Swap Mouse Buttons to default (0)
12-05-2015 11:56:00.0471> Reset Wheel Scroll Lines to default (3)
12-05-2015 11:56:00.0471> RemoveMouseHook took 406ms
12-05-2015 11:56:00.0471> **** A fatal error occured -  X-Mouse Button Control will now close! Please inform the developer. ****
12-05-2015 11:56:00.0471> Exception: EXCEPTION_ACCESS_VIOLATION Address: 0x3F61A83F, Code: 0xC0000005 Flags: 0x00000000

*******************************************************************************************************************************************
12-05-2015 11:56:52.0388> X-Mouse Button Control v2.11 Beta 4 (x64) Startup. Commandline '/notportable'
12-05-2015 11:56:52.0388> Running on Microsoft Windows 7 Enterprise Edition Service Pack 1 (build 7601), 64-bit, Hook Timeout: 5000 ms
12-05-2015 11:56:52.0388> X-Mouse Button Control is NOT running using an elevated administrative account (UAC elevation)
12-05-2015 11:56:52.0388> Startup folder: 'C:\Program Files\Highresolution Enterprises\X-Mouse Button Control\'
12-05-2015 11:56:52.0388> Settings (and log) folder: 'C:\Users\off\AppData\Roaming\Highresolution Enterprises\XMouseButtonControl\'
12-05-2015 11:56:52.0388> Hooking the mouse...
12-05-2015 11:56:52.0388> Successfully hooked into the mouse messages.
12-05-2015 11:56:52.0403> Current language is 0x04150415
12-05-2015 11:56:52.0403> Checking installed keyboard layout: 0x04150415
12-05-2015 11:56:52.0403> Checking installed keyboard layout: 0x04090409
12-05-2015 11:56:52.0403> Using keyboard language 0x04090409
12-05-2015 11:56:52.0403> HookThread: Successfully set the mouse hook 0x1600C7
12-05-2015 11:56:52.0403> HookThread: Successfully set the keyboard hook 0x2036B
12-05-2015 11:56:52.0466> Brightness: Unable to initialise COM
12-05-2015 11:56:52.0466> Brightness: Unable to set COM security
12-05-2015 11:56:52.0466> Successfully created the main message window.
12-05-2015 11:57:01.0030> CMyMessageWnd::OnSetup   -   Clear hotkeys...
12-05-2015 11:57:01.0030> CMyMessageWnd::OnSetup   -   Opening setup dialog.
12-05-2015 11:57:01.0030> Sorting action list took 0ms
12-05-2015 11:57:03.0199> CMyMessageWnd::OnSetup   -   Setup dialog closed.

*******************************************************************************************************************************************
I also sometimes see OSD showing for a moment after resume from suspend/hibernation.

User avatar
phil
Site Admin
Posts: 6101
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.11 Beta

Post by phil » Tue May 12, 2015 5:12 pm

What happened, a "new" crash or was this a followup to a previous message in this thread?
Ive had a very rare crash too but I have never been able to reproduce it, which makes finding these things pretty much impossible. Unfortunately the log gives no idea, other than access violation which could be anywhere in 1,000's of lines of code!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

DirkSteinkamp
New User
Posts: 1
Joined: Wed May 13, 2015 8:43 pm

Re: XMBC 2.11 Beta

Post by DirkSteinkamp » Wed May 13, 2015 8:55 pm

Hi!
I enjoy using XMBC a lot, but have a crash from time to time, with the current beta, but also with the betas before.

Here's my log:

Code: Select all

*******************************************************************************************************************************************
13-05-2015 21:40:53.0629> X-Mouse Button Control v2.11 Beta 4 (x64) Startup. Commandline '/notportable'
13-05-2015 21:40:53.0629> Running on Microsoft Windows 7 Professional Edition Service Pack 1 (build 7601), 64-bit, Hook Timeout: 5000 ms
13-05-2015 21:40:53.0629> X-Mouse Button Control is NOT running using an elevated administrative account (UAC elevation)
13-05-2015 21:40:53.0629> Startup folder: 'C:\Program Files\Highresolution Enterprises\X-Mouse Button Control\'
13-05-2015 21:40:53.0629> Settings (and log) folder: 'C:\Users\Dirk\AppData\Roaming\Highresolution Enterprises\XMouseButtonControl\'
13-05-2015 21:40:53.0629> Hooking the mouse...
13-05-2015 21:40:53.0629> Successfully hooked into the mouse messages.
13-05-2015 21:40:53.0629> Current language is 0x04070407
13-05-2015 21:40:53.0629> Checking installed keyboard layout: 0x04070407
13-05-2015 21:40:53.0629> Checking installed keyboard layout: 0x04090409
13-05-2015 21:40:53.0629> Using keyboard language 0x04090409
13-05-2015 21:40:53.0629> HookThread: Successfully set the mouse hook 0x1D1635
13-05-2015 21:40:53.0629> HookThread: Successfully set the keyboard hook 0x35161B
13-05-2015 21:40:53.0645> Brightness: Unable to initialise COM
13-05-2015 21:40:53.0645> Brightness: Unable to set COM security
13-05-2015 21:40:53.0645> Successfully created the main message window.
13-05-2015 21:41:00.0055> Enabling extra debug logging.
13-05-2015 21:41:00.0055> **** An unexpected exception occured -  X-Mouse Button Control will now close! Please inform the developer. ****
13-05-2015 21:41:00.0055> Exception: EXCEPTION_ACCESS_VIOLATION Address: 0xFAB3BBD2, Code: 0xC0000005 Flags: 0x00000000
Today I played around a little and managed to reproduce it this way:
- choose an application that has its own profile in XMBC (I discovered it with IrfanView first, but I could reproduce it with Excel, too)
- set the scroll method to "Method 5 (WPF Scroll Msg)"
- start the application, open/create a document
- hold ctrl, and move the scroll wheel rapidly forwards and backwards, to "zoom in" and "zoom out"
- it doesn't take long (max. 5-10 seconds, sometimes immediately), and the exception occurs

Hope this helps in finding the bug!

Dirk

User avatar
phil
Site Admin
Posts: 6101
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.11 Beta

Post by phil » Wed May 13, 2015 11:12 pm

Thanks for the info, unfortunately (of course) its not crashing here with that - I also used Excel.
Strangely though, if you are holding CTRL to zoom, the the scroll method is completely ignored anyway so I dont expect that's particularly relevant in the grand scheme of things.

Looks like Im going to have to invest in some more exception logging - to try and unwind the call tree so I can at least see what bit of code the crash is occurring in - that's quite a lot of work though from past experience.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
phil
Site Admin
Posts: 6101
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.11 Beta

Post by phil » Sat May 16, 2015 2:22 pm

OK, here is XMBC v2.11 Beta 5.

If you have check for beta versions enabled, you should get notified of a new version and prompted to update in the next day or so. This is the most efficient method (bandwidth wise) as the updates are only a fraction of the size of the full install. Otherwise, you can get the full installation beta HERE.

Changes since v2.11 Beta 4:
  • #307 - Added crash dump log file to assist debugging crashes. The file will be called XMBCExceptionNNN.log in the XMBC log file folder. If a crash occurs, please send me this file and a description of what you were doing when the crash occurred.
  • #306 - Fixed an issue with {NUM:ENTER} simulated keystroke. It might work now - please test.
  • #304 - Increased the width of the text labels on the modifier key tab (for translations that require more space).
  • #301 - Modified OSD to stop it appearing in the task switcher!
Any problems, PM me a copy of the log file (or post a snippet in a code block here).
Any crashes, please PM me a copy of the XMBCExceptionNNN.log file!

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
phil
Site Admin
Posts: 6101
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.11 Beta

Post by phil » Sun May 17, 2015 4:13 pm

OK, here is XMBC v2.11 Beta 6.

If you have check for beta versions enabled, you should get notified of a new version and prompted to update in the next day or so. This is the most efficient method (bandwidth wise) as the updates are only a fraction of the size of the full install. Otherwise, you can get the full installation beta HERE.

Changes since v2.11 Beta 5:
  • #308 - Fixed occasional crash when scrolling and the tilt wheel is pressed.
  • #307 - Updated crash dump log file code to work for all crashes!.
  • #305 - Added ability to randomise the simulated keystrokes repeat delay by 10%
Any problems, PM me a copy of the log file (or post a snippet in a code block here).
Any crashes, please PM me a copy of the XMBCExceptionNNN.log file!

There are some new translations in this one. I have updated the template (and some of the language packs for one changed entry)

Code: Select all

"Randomise auto repeat delay by 10%" => ""						# -- Added in 2.11 Beta 6 --
Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
AndyK
Committed
Posts: 149
Joined: Mon Jan 06, 2014 4:38 pm

Re: XMBC 2.11 Beta

Post by AndyK » Mon May 18, 2015 5:43 pm

Please have a look on the buttons in "Simulated Keysrokes"
xmbcButton.png
Andy
You do not have the required permissions to view the files attached to this post.

User avatar
phil
Site Admin
Posts: 6101
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.11 Beta

Post by phil » Mon May 18, 2015 11:14 pm

Odd I thought I had fixed that - must have undone it or fixed it after I built it - Doh!
Will be fixed in the next beta!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

WayHow47
Member
Posts: 26
Joined: Fri Jan 16, 2015 5:27 pm

Re: XMBC 2.11 Beta

Post by WayHow47 » Sun Jun 07, 2015 6:36 pm

Hello Phil,

I recently developed an intermittent problem with my Contour Perfit mouse being detected upon boot. Rebooting or unplugging and replugging USB fixes the problem. Not sure it is caused by X Mouse but the problem developed around the time I installed 2.11 beta 4. I uninstalled and went back to the latest release version and so far it's being detected. However, I have only booted a couple of times and it was an intermittent problem. I will let you know if the problem comes back.

Wayne

User avatar
phil
Site Admin
Posts: 6101
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.11 Beta

Post by phil » Mon Jun 08, 2015 9:36 am

Thanks for the info - one to keep an eye on, but I cant see how XMBC can have any impact on this as it does nothing with drivers or USB protocols. It simply redirects windows mouse messages (completely device independent) so something not being detected sounds like a different problem to me.

Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

WayHow47
Member
Posts: 26
Joined: Fri Jan 16, 2015 5:27 pm

Re: XMBC 2.11 Beta

Post by WayHow47 » Sun Jun 14, 2015 5:08 pm

Hello Phil,

That was my understanding from what you've said before. However, I've had a week without the issue returning. I will try the latest bet again to see if the problem comes back. I agree that it's probably coincidental but if I can duplicate the problem then I will recontact you.

Best,

Wayne

Locked