"change movement to scroll" - icon problem

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
New User
Posts: 1
Joined: Fri May 08, 2020 1:27 pm

"change movement to scroll" - icon problem

Post by kmoll »

XMBC Version: 2.19.1
Windows Version: Windows 10 Home 1909
Mouse Information (brand/model): several trackballs (kensington orbit, logitech trackman marble...)
Relevant Computer Information (CPU, RAM etc): Intel Core i5-6200U, 8GB RAM
Did the problem occur after an upgrade of XMBC? (If so, from what version?): no
Did the problem occur after a Windows update/upgrade? (If so, from what version?): no
How long have you used XMBC?: around a year
What language and keyboard layout do you use in Windows?: English (Colemak)

Clear description of the problem - try and include as much information as possible, including what button and mappings you are having problems with (if applicable).:
When using the "change movment to scroll" functionality, whenever I try to set the option to lock to Y or X axis, the icon with the hand and double red arrow which appears in this case starts flickering constantly and continues to do so even after the cursor has stopped moving. It does it independently of the device I am using (several trackballs, but also mice). Granted, it is just a minor annoyance, but I find it quite distracting when reading. Therefore, is there a way to fix this, so that the icon stays stable, without flickering?
Thank you so much for this unbelievably helpful application which has allowed me to continue using trackballs despite the shortcomings of all available models I have tried regarding scrolling.
Keep up the good work!

User avatar
Site Admin
Posts: 6678
Joined: Sun Apr 06, 2003 11:12 pm

Re: "change movement to scroll" - icon problem

Post by phil »

I've not seen this but it may be a problem in 2.19.x (Im using a newer test version and its not flickering for me - I will try with 2.19.1 shortly).
Is this something that has only just started happening (since upgrading to 2.19) or has it always done it?

EDIT: I just tried 2.19.1 again and I didn't see any flicker... Not sure what is going on for you - could you PM me a copy of your settings file so I can run that and make sure there isn't some option somewhere than is causing this?
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply