Scrolling window under cursor

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
raShoe
New User
Posts: 3
Joined: Fri Mar 01, 2019 3:39 pm

Scrolling window under cursor

Post by raShoe » Fri Mar 01, 2019 4:28 pm

XMBC Version: 2.18.4
Windows Version: Windows 10 Pro version 1803 (build 17134.345)
Mouse Information (brand/model): Logitech M500, Tecknet Wired Gaming Mouse GM299
Computer Information: Intel i5-4570, ASRock B85 Pro4, Gigabyte Radeon RX 570
Did the problem occur after an upgrade of XMBC?: No
Did the problem occur after a Windows update/upgrade?: Possibly
How long have you used XMBC?: since before 2010
What language and keyboard layout do you use in Windows?: US/English

Clear description of the problem:The "Make scroll wheel scroll window under cursor" option does not work, unless the Windows 10 Settings app | Devices | Mouse | "Scroll inactive windows when I hover over them" is set to On. This is not a problem in itself, but I found out that for inactive windows, X-Mouse's custom events are not sent, but inactive windows do scroll when using the scroll wheel while hovering over them.

Example: I run Notepad, add notepad.exe to Application / Window Profiles, setup a double click on wheel up or a scroll up on button 4, click Apply. The double click and scroll up events don't work while hovering over Notepad unless Notepad is the active window. The events setup for "Default" do work when Notepad is inactive, however. So it seems the detecting of hovering over inactive windows is broken... :(

raShoe
New User
Posts: 3
Joined: Fri Mar 01, 2019 3:39 pm

Re: Scrolling window under cursor

Post by raShoe » Fri Mar 01, 2019 4:31 pm

Oh, forgot to mention, this started happening when I had XMBC 2.15 installed, and I upgraded to 2.18.3 and 2.18.4, with no change. So I'm thinking it's because Windows changed something. Thank you so much for all your labor on this software!

User avatar
phil
Site Admin
Posts: 5889
Joined: Sun Apr 06, 2003 11:12 pm

Re: Scrolling window under cursor

Post by phil » Fri Mar 01, 2019 4:47 pm

Have you got "Enable profile switching on mouse move" in the advanced setting tab? If not then the profile will not be detected until the window is activated and then I would expect this behavior.

If you have got that option ticked then its odd/wrong/a bug somewhere.
If you leave the XMBC setup window open, does the notepad profile highlight when the mouse cursor moves over it?

Thanks,
Phil

PS: I spent all Wednesday testing issues related to "Make scroll wheel scroll window under cursor" in certain apps - like chrome - so I'm pretty sure it does "work" (on various versions of Windows 10) and it should work better in 2.18.4 (but it was working mostly before that too here).

EDIT: Your notepad example works absolutely fine here (Win 10 1809) - so there must be something else at play (either XMBC configuration or Windows or 3rd party software).
Can you send (PM/Email) me a copy of your XMBC settings (save profile button on main gui) so I can test with your exact XMBC configuration?
Also can you turn on debug logging (update & logging tab/OK/APPLY!) then repeat the notepad test... Then send me the debug log?
Finally, what DPI is your screen running at (as there is a small chance that the DPI may confuse XMBC - thats happened before and maybe crept back in).
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

raShoe
New User
Posts: 3
Joined: Fri Mar 01, 2019 3:39 pm

Re: Scrolling window under cursor

Post by raShoe » Fri Mar 01, 2019 6:21 pm

Wow, thanks for the quick reply! I re-installed 2.18.4, and chose to reset my settings. It works now! Thank you!!

If you want a copy of my old settings that didn't work, I can PM it to you...

Post Reply