Button chording not working in MS Word

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
Adrianrff
Dedicated
Posts: 41
Joined: Sun Mar 12, 2017 4:42 pm

Button chording not working in MS Word

Post by Adrianrff » Mon Jul 09, 2018 3:18 am

XMBC Version: 2.17 (portable)
Windows Version: 10 (64 bit)
Mouse Information (brand/model): Microsoft Sculpt Ergonomic
Computer Information: i7 8550U CPU, 12 GB RAM - HP Pavillion Laptop
Did the problem occur after an upgrade of XMBC or Windows?: No
How long have you used XMBC?: ~4 years
What language and keyboard layout do you use in Windows?: Spanish (VE) - Spanish (qwerty)

Clear description of the problem:

I had created a post earlier today about this and deleted because I thought I had found a solution and it was too silly. Turns out I didn't find a solution.

The problem is that in my MS Word window profile, the button chording feature doesn't work (most of the time, sometimes it randomly works).

I have several combos setup for for this, but MS Word reacts as if I was just pressing the second button alone. For example, Mouse 4 + right click copies to clipboard (Word simple shows the context menu); Mouse 4 + left click is paste (MS Word does a normal click); Mouse 4 + Mouse wheel up/down is redo/undo (MS Word scrolls vertically)... etc.

I have no idea under which conditions it starts working again. I deleted my previous post because I thought that having "unblock when the mouse moves" checked was causing the issue. In fact, when I unchecked it it started working and it worked for a while, but then it stop.

In every other window profile, including the default profile, this combos work consistently as expected, so I have no idea what Word has or does that prevent it from working there.

I'm attaching my profile in case you need it.

Thanks.
You do not have the required permissions to view the files attached to this post.

User avatar
phil
Site Admin
Posts: 5550
Joined: Sun Apr 06, 2003 11:12 pm

Re: Button chording not working in MS Word

Post by phil » Tue Jul 10, 2018 7:51 am

Hi Adrian,

Thanks for the detail and the profile. Ive just tried your profile with XMCB 2.18 beta 11 and all seems to be working fine.
I have however fixed quite a few issues with the chording through the current beta run, so maybe thats why I dont notice a problem.

The first thing to try would be to use 2.18 beta 1, but of course, the portable version is not available in beta. You can "make" a portable version of the beta though by following Suke's instructions (here).

The other thing to do would be to turn on debug logging and capture some log of your actions in MS Word (especially if the problem persists in 2.18 beta 11!).

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
injtsvetkov
Fanatic
Posts: 256
Joined: Mon Jun 06, 2016 8:51 am

Re: Button chording not working in MS Word

Post by injtsvetkov » Wed Jul 11, 2018 1:05 pm

Hi Adrianrff,

I have noticed some problems in MS Word particularly with the "Ctrl+C"/"Ctrl+V" combos but since they work fine in all other apps, I thought that most probably the reason isn't in XMBC. So here are some things to try:

- Try whether the combos work fine when physically pressing the keys.

- Try sending the combos via SymKeys instead of chording.

- Try enabling the "Block / Delay original button action ..." in the chording window and see if MS Word still recognizes the left/right clicks.

- Instead of "Ctrl+C"/"Ctrl+V", try sending some other commands to see if they are executed properly.

This is interesting to me so I'll be waiting for your reply :)
Good luck!
Iliya
HAMA Mirano
Windows 8.1 x64, Intel i5-3230M @ 2.60GHz, 4GB

Adrianrff
Dedicated
Posts: 41
Joined: Sun Mar 12, 2017 4:42 pm

Re: Button chording not working in MS Word

Post by Adrianrff » Thu Jul 19, 2018 6:12 pm

Hi, @Phil.

I have run into this issue again and enabled Debug logging in XMBC (log attached). I noticed some specific conditions:

- It seems that the problem doesn't occur when having a single Word file opened.
- It also seems to happen with some specific words inside the Word Document. I'm attaching an image in which the words with which this problem occurs are highlighted. If I select any other word, the combo works as expected. Right now I have this to document in parallel view and sync scrolling, I don't know if that matters though, but each time this happens, I seem to be working this way.

EDIT: It seems to be random with which words it happen! There are a few others now.

Let me know if this helps.
You do not have the required permissions to view the files attached to this post.

Post Reply