I have upgraded the board - please let me know if you have any problems

Bug with disabling mouse buttons 4+5??

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Post Reply
New User
Posts: 2
Joined: Tue May 09, 2017 10:51 pm

Bug with disabling mouse buttons 4+5??

Post by LOG3 » Tue May 09, 2017 11:11 pm

Hey guys,

I think I have found a strange bug, maybe its already known, maybe its not.
I like this porgram very much as it helped me solve a long lasting problem I had.
Maybe you can help me?

I have push-to-talk (for TS3) on my Mouse4 button and it annoyed me the most that this button is also used as 'backwards' in all browsers. So when Im in the browser and speaking, it would automaticly go back one webpage. I have tried disabling this function in browsers but to no avail, its hardcoded somewhere in the drivers apparently and I can only disable the button completely in the mousedriver, which I don't want.
So I was very happy that I could selectively disable these buttons for specific programs with X-MBC.

Now I think I have found a strange bug. When it happens my PC isn't registering mouseclicks and mouseover actions. I can still move the mouse, I can still use Mouse4 to talk. But when I hover over anything that should register the mousepointer, it doesn't. For example, hovering over another open program in the task bar, the program should get highlighted. Also clicking left or right does nothing. The PC doesn't freeze, everything else works as it should. I can hit CTRL+ALT+DEL but then I still can't highlight/click on any option although the mouse moves without problems or lags.
The problem resolves itself if I wait for around 10-20 seconds.

I think it has to do with this program, never encountered the problem before. I also suspect that it gets triggered when I hold down Mouse4 button for a longer time and I suspect it has something to do with actions or commands getting queued up and blocking others maybe?
My Setup:

Im using X-Mouse Button Control v 2.15
I added firefox.exe and steam.exe as applications and 'disabled' Mouse4 and Mouse5 in both.
In the 'Global Settings' in general tab I unchecked every check box and set default layers to 1.
Everything else is untouched.

Using Win7 Prof.x64
Mouse is Logitech G502
Logitech Gaming Software 8.57.145 installed
No other mouse related software installed

User avatar
Site Admin
Posts: 4802
Joined: Sun Apr 06, 2003 11:12 pm

Re: Bug with disabling mouse buttons 4+5??

Post by phil » Wed May 10, 2017 8:01 am

HI, XMBC does not queue up any actions except simulated keystrokes. For disable, it simply returns from the mouse hook saying the message has been handled without doing anything, so as not to be passed on further.

Can you please enable debug logging (settings/logging tab) and then try to reproduce the problem - once you have, please send me the debug log file via PM or email.

--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

New User
Posts: 2
Joined: Tue May 09, 2017 10:51 pm

Re: Bug with disabling mouse buttons 4+5??

Post by LOG3 » Thu May 18, 2017 10:31 pm

I have since been trying to capture the bug. It was hard, because once the bug activated I couldn't open the settings and start the logging. This bug seems to be rare also, happens around once a day (I'm using the PC for min. 6h daily). But today managed to capture it!

More findings:

1. The bug seems to always trigger while I am either in the firefox or steam window (my only 2 profiles in XBMC). I don't know if push-to-talk on Mouse4 button has anything to do with it, I am always in Teamspeak and I always use this button..

2. Once the bug happens, the current application, namely fireofox or steam, WILL react to all mouseclicks! I only notice the bug because my mouseactions are not getting registered in any other application/windows once I try to switch to them or close the firefox/steam window.

3. Exception is, the other profiled program!! If the bug triggers while I am in firefox, my MOUSEOVER actions are registered in steam! ONLY the mouseovers though, I can highlight buttons and thats it! If the bug triggers while I am in steam, firefox still registers my mouseovers! No other applications manage to register mouseovers.

4. As a workaround I hit CTRL+ALT+DEL and navigate to Task Manager via the keyboard. Once I hit enter and Task Manager opens, the bug is gone!

5. While the bug is active, the push-to-talk button still works and I can talk in teamspeak.
I send you the logfile via EMAIL since it is too big for PM!
I cut out the debugging infos from other days with failed attempts, but only the detailed logging. You have all the normal infos available.
The bug happenned on 18-05-2017 while I was browsing firefox. I can't say when exactly it started or how long it lasted. I suspect it started maximum a few minutes before! So you best start from the end of the log.

Once I noticed the bug I clicked around windows/firefox/desktop a few times and tried to click on other open programs in the taskbar to test mouseover/mouseclics. I also minimized firefox and switched to other programs using alt+tab.
The bug stopped at time 22:47:30.0388 when I opened Task Manager via keyboard.

Hope this helps. From what I can see there are no errors in the logs, but to me it looks like it didn't register all the HWND changes?

Posts: 81
Joined: Tue Sep 06, 2016 9:09 am

Re: Bug with disabling mouse buttons 4+5??

Post by BriHecato » Mon May 22, 2017 1:32 pm

First - Uninstall LGS. I'm a ex-user of G502 Proteus Spectrum mouse (I gladly abandon this device for some reasons) and theres one thing sure - use XMBC or LGS, but not both of them.
In LGS you should be able to write all the macros you needed and link it to aplication exe file profiles. You will benefit from additional keys that XMBC cannot recognize, but you will not be able to rebind some buttons.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests