Page 1 of 1

Data not reading through DB25 parallel cable

Posted: Thu Jul 15, 2010 8:10 am
by Amol
Hi,

I have downloaded a example code for .net. I tested a write and read funcationlity of application on Parallel port at single machine, it works fine.

But, when I connect to PC's with a MALE-MALE DB25 parallel port cable and copy this .net appliccation on both machine. A cable is connected to LPT1 port of both the machines. When I write on LPT1 port of one machine and try to read on another machine on same port. It gives nothing.

I have write 97 ascii value of 'a' on one machine when i click on read button on same machine I get 97 value. But, not same happens on second connected machine.

After my investigation I select 889 inplace of 888 as a port address in program on machine where i am reading data. And maintain 888 as a port address in other machine from where i am wrting data on port. I am getting something, but which is not a meaningful. If i send 97 ascii value of 'a' and read it at other machine i get 710. But on machine from where i am writting, i get proper 97 value.

Please help me to sort out this problem.

Re: Data not reading through DB25 parallel cable

Posted: Thu Jul 15, 2010 12:38 pm
by phil
I'm not sure why you feel the need to email and post on the forums - its a bit overkill!

I've replied by email but for the benefit of others:
I do not know how “modern” parallel ports work and I don’t pretend to know – I’ve never used InpOut32 to interface with a parallel port.

Last time I user parallel ports was back in the days of DOS (before Windows 95 even!) but even then, you had to ensure the LPT port was in the right mode (bi-directional by the sounds of it).
Maybe you should contact the author if InpOut32 (I only ported it to 64bit) who may understand parallel ports.