Can't install in Windows 7 RC 7100 x64

My x64 port of InpOut32
Post Reply
GnatGoSplat
New User
Posts: 2
Joined: Thu Jun 04, 2009 3:52 pm

Can't install in Windows 7 RC 7100 x64

Post by GnatGoSplat » Thu Jun 04, 2009 3:55 pm

Hi, I tried to install InpOutx64 to Windows 7 RC by running the InstallDrivers.exe file. It says it successfully installed InpOutx64.sys, but when I reboot it doesn't appear to be installed and that file is not in c:\Windows\System32\Drivers.
I have tried running InstallDrivers as Administrator and have UAC turned off, but still doesn't seem to work.
What am I missing?

User avatar
phil
Site Admin
Posts: 5875
Joined: Sun Apr 06, 2003 11:12 pm

Re: Can't install in Windows 7 RC 7100 x64

Post by phil » Thu Jun 04, 2009 4:08 pm

I don't know what you are missing.
Maybe it does not work with windows 7 :evil:

I haven't tried it on Windows 7 yet. I will try and remember to try it tonight when I get home.

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

GnatGoSplat
New User
Posts: 2
Joined: Thu Jun 04, 2009 3:52 pm

Re: Can't install in Windows 7 RC 7100 x64

Post by GnatGoSplat » Fri Jun 05, 2009 2:19 am

Turns out it DID work, just not on the first reboot for some reason. I came home from work today to my wife using the computer and to my surprise, the VFD happened to be working, so I guess it did install after all. I don't know why I didn't see the files in the driver's folder yesterday. My mistake, sorry!

User avatar
phil
Site Admin
Posts: 5875
Joined: Sun Apr 06, 2003 11:12 pm

Re: Can't install in Windows 7 RC 7100 x64

Post by phil » Fri Jun 05, 2009 2:45 am

No problem.. and good news - thanks for letting me know :)
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

diggedydog
New User
Posts: 3
Joined: Mon Sep 07, 2009 7:49 pm

Re: Can't install in Windows 7 RC 7100 x64

Post by diggedydog » Mon Sep 07, 2009 8:01 pm

Hi - not sure if I am in the right place talking to the right people..... but I found this thread after googling for my current problem. I have a home made HTPC running Windows 7 on a P6T board with an i7 CPU. I have installed a High IEEE 1284 Parallel Port PCI card. The case that I have built the unit has a VFD display. I know that the VFD display works fine because if I plug it into the parallel port of an old Window XP laptop that I own then LCDsmartie drives it perfectly. However when I plug the VFD into the parallel port of my HTPC and run LDCsmartie - nothing! I am running the release version of Windows 7 and this does seem to have a few more options in the Parallel Port control panel - but whatever I try - it simply doesn't work.
I have read in a few places that installing a special version (from your site downloads) inpout32 into the LCDsmartie folder could help - but I am a bit nervous about installing this as I am not much of a Windows expert .. .and there is a lot of frightening comments on the web about installing the wrong DLL etc.
Can anyone help me here?
Thanks in anticipation to anyone who can!
Cheers!

diggedydog
New User
Posts: 3
Joined: Mon Sep 07, 2009 7:49 pm

Re: Can't install in Windows 7 RC 7100 x64

Post by diggedydog » Mon Sep 07, 2009 8:05 pm

responding to my own post here .. just read your comments on a similar thread..

Sorry to inform you but InpOut (any version) does not work with parallel or USB PCI ports. The reason being they don't use the old fashioned address (ports) and instead use virtual addresses.

Seems that I am out of look - will start googling for a usb/board display!!
Ah well - at least I will not waste any more time on this - maybe I can use the vfd on my Windows Home Server?
Thanks anyway

User avatar
phil
Site Admin
Posts: 5875
Joined: Sun Apr 06, 2003 11:12 pm

Re: Can't install in Windows 7 RC 7100 x64

Post by phil » Mon Sep 07, 2009 8:12 pm

Yeh, I think these days its getting to the point where on-board parallel ports are being phased out, so the USB screen is the way to go in my opinion (I have a Matrix orbital usb based screen that has all sorts of nice extra's (like 1wire bus built in for temp monitoring and the likes) and it supports x64 out of the box.

Windows home server should work fine with InpOut so long as the parallel port is on the motherboard and not a PCI/USB extra.

NOTE: there may be alternatives out there for PCI/USB parallel ports - but probably you need a dedicated driver and that's beyond me.

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

diggedydog
New User
Posts: 3
Joined: Mon Sep 07, 2009 7:49 pm

Re: Can't install in Windows 7 RC 7100 x64

Post by diggedydog » Tue Sep 08, 2009 8:03 am

Thanks so much for taking the time to respond - bearing in mind your comments and the other bits of info that I have been able to find from your site I think that it is time for me to bury my VFD units inside my WHS! And now I have a great excuse for buying a nice new lcd/usb device!! Clearly - unless I am able to fit one of these units to the front of my HTPC, I am never going to be able to get sufficiently irritated and distracted by it for me to have to disconnect it!!! "A mans got to do what a mans got to do!"
Thanks again

Post Reply