Build errors

My x64 port of InpOut32
Post Reply
Mrngg
New User
Posts: 2
Joined: Sun Jul 24, 2016 12:33 pm

Build errors

Post by Mrngg » Sun Jul 24, 2016 12:47 pm

Hello,

I know this is pretty old but any help would be appreciated.
I'm trying to build your project from source, but I get errors, on Windows 7 64 bit, Visual Studio 2015.

Log when trying to build the driver:

Error (active) #error directive: "No target architecture defined" HWInterfaceDrv c:\Program Files (x86)\Windows Kits\10\Include\10.0.10586.0\km\ntddk.h 7927
Error (active) identifier "PDRIVER_EXCPTN_CALLBACK" is undefined HWInterfaceDrv c:\Program Files (x86)\Windows Kits\10\Include\10.0.10586.0\km\ntddk.h 12385
Error (active) identifier "PCMC_EXCEPTION" is undefined HWInterfaceDrv c:\Program Files (x86)\Windows Kits\10\Include\10.0.10586.0\km\ntddk.h 12462
Error (active) identifier "PCPE_EXCEPTION" is undefined HWInterfaceDrv c:\Program Files (x86)\Windows Kits\10\Include\10.0.10586.0\km\ntddk.h 12473
Error (active) identifier "SLIST_HEADER" is undefined HWInterfaceDrv c:\Program Files (x86)\Windows Kits\10\Include\10.0.10586.0\km\wdm.h 15387
Error (active) identifier "SLIST_HEADER" is undefined HWInterfaceDrv c:\Program Files (x86)\Windows Kits\10\Include\10.0.10586.0\km\wdm.h 15407
Error (active) #error directive: "No target architecture defined" HWInterfaceDrv c:\Program Files (x86)\Windows Kits\10\Include\10.0.10586.0\km\wdm.h 19517
Error (active) identifier "PSLIST_HEADER" is undefined HWInterfaceDrv c:\Program Files (x86)\Windows Kits\10\Include\10.0.10586.0\km\wdm.h 22239
Error (active) identifier "PSLIST_HEADER" is undefined HWInterfaceDrv c:\Program Files (x86)\Windows Kits\10\Include\10.0.10586.0\km\wdm.h 22290
Error (active) identifier "PSLIST_HEADER" is undefined HWInterfaceDrv c:\Program Files (x86)\Windows Kits\10\Include\10.0.10586.0\km\wdm.h 22304
Error (active) identifier "PSLIST_HEADER" is undefined HWInterfaceDrv c:\Program Files (x86)\Windows Kits\10\Include\10.0.10586.0\km\wdm.h 22391
Error (active) identifier "PSLIST_HEADER" is undefined HWInterfaceDrv c:\Program Files (x86)\Windows Kits\10\Include\10.0.10586.0\km\wdm.h 22397
Error (active) identifier "PSLIST_HEADER" is undefined HWInterfaceDrv c:\Program Files (x86)\Windows Kits\10\Include\10.0.10586.0\km\wdm.h 22404
Error (active) #error directive: "No Target Architecture" HWInterfaceDrv c:\Program Files (x86)\Windows Kits\8.1\Include\shared\ntdef.h 168
Error MSB3073 The command "ddkbuild -WNETA64 free ." exited with code 9009. HWInterfaceDrv C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets 41

And log when trying to build the 32bit dll:

Error (active) identifier "_outp" is undefined inpout32drv c:\Users\Milan\Desktop\sourceDLLs\inpout32drv.cpp 92
Error (active) identifier "_inp" is undefined inpout32drv c:\Users\Milan\Desktop\sourceDLLs\inpout32drv.cpp 127
Error (active) identifier "_inp" is undefined inpout32drv c:\Users\Milan\Desktop\sourceDLLs\inpout32drv.cpp 461
Error (active) identifier "_outp" is undefined inpout32drv c:\Users\Milan\Desktop\sourceDLLs\inpout32drv.cpp 495
Error C3861 '_outp': identifier not found inpout32drv c:\users\milan\desktop\sourcedlls\inpout32drv.cpp 92
Error C3861 '_inp': identifier not found inpout32drv c:\users\milan\desktop\sourcedlls\inpout32drv.cpp 127
Error C3861 '_inp': identifier not found inpout32drv c:\users\milan\desktop\sourcedlls\inpout32drv.cpp 461
Error C3861 '_outp': identifier not found inpout32drv c:\users\milan\desktop\sourcedlls\inpout32drv.cpp 495
Error LNK1104 cannot open file 'inpout32.lib' InstallDriver C:\Users\Milan\Desktop\sourceDLLs\InstallDriver\LINK 1

The 64bit dll builds just fine.

Thanks for any help.

User avatar
phil
Site Admin
Posts: 5197
Joined: Sun Apr 06, 2003 11:12 pm

Re: Build errors

Post by phil » Mon Jul 25, 2016 12:06 am

Urm, off the top of my head, I cant think what the problem could be. I presume the DDK you are using is quite new (10.x) and the last time I compiled the driver it was a much older DDK - that could be the source of the problems.

I cant sign the built driver so I haven't built it for some time - I will try and have a look in more detail when I get a bit of time (I've been away this weekend). I didn't write the code (just ported to x64) and my knowledge of the DDK is rather limited - but I will d/l the new DDK and see what I can find.

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Mrngg
New User
Posts: 2
Joined: Sun Jul 24, 2016 12:33 pm

Re: Build errors

Post by Mrngg » Mon Jul 25, 2016 1:01 pm

Thank you for your help. If you figure something out, please let me know.

User avatar
phil
Site Admin
Posts: 5197
Joined: Sun Apr 06, 2003 11:12 pm

Re: Build errors

Post by phil » Sun Jul 31, 2016 6:10 pm

I Haven't figured out the Win10 DDK yet - I'm unable to build anything with it. Its been years since I last built InpOut32 (bear in mind that I didn't write it, I just ported it to x64) and the DDK is not something that I am overly familiar with.

I haven't even got as far as the build errors you listed :( I wonder if the Windows 10 DDK supports building the legacy type drivers such as InpOut32.

The driver seems to build OK with the Windows 7 DDK (v7600.16385.1)
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Lammert
New User
Posts: 1
Joined: Fri Jul 21, 2017 10:14 am

Re: Build errors

Post by Lammert » Thu Jul 27, 2017 10:39 am

Mrngg wrote:
Mon Jul 25, 2016 1:01 pm
Thank you for your help. If you figure something out, please let me know.
Hey Mrngg, did you get past these errors on Windows 7?

Darryn
New User
Posts: 1
Joined: Fri Nov 17, 2017 1:11 am

Re: Build errors

Post by Darryn » Fri Nov 17, 2017 1:37 am

Curious to see if anyone could build with the visual studio 2015 + ddk combination and get the driver to run.
Any luck out there?
I get the following:

MSB3073 The command "ddkbuild -WNETA64 free" exited with code 9009

Anybody make heads or tails of this one...

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests