ImpOut32 (x64) working with Win10 x64

My x64 port of InpOut32
Anomaly
New User
Posts: 4
Joined: Tue May 14, 2013 12:31 am

ImpOut32 (x64) working with Win10 x64

Postby Anomaly » Tue Apr 18, 2017 6:30 pm

Hello Phil,

I have been using InpOut32 since XP days and have relied on it to run a single computer controlled device that is very important to my work. With Win 7 and then Win 8, I had some problems getting up and running, but eventually was successful.

Win 10 was problematic, as my PCIe parallel port card was no longer compatible. The solution was relatively simple. I purchased a new card that is compatible with Win 10; Model SI-PEX10011. I suggest testing with a printer first, as the driver had to be installed several times to get it up and running. The port address in my VB application had to be changed to the new address of E010. I installed the latest dll and it installed with out any drama. The system now operates as it did previously and I am greatly relieved.

Many thanks for your efforts and kind permission to use this software at no cost. A donation follows.

Kind regards,
Anomaly

User avatar
phil
Site Admin
Posts: 4726
Joined: Sun Apr 06, 2003 11:12 pm

Re: ImpOut32 (x64) working with Win10 x64

Postby phil » Tue Apr 18, 2017 6:51 pm

That's great to know.

While a donation would be appreciated, remember that I didn't write InpOut32, I only ported it to x64 (which I guess is quite important these days).

The original author is not around/responding any more and I'm not able to make any modifications as I can't, as an individual, purchase a driver signing certificate any more :(

So thankfully, Win 10 didn't require any changes to the code!

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)


Return to “InpOut32 (x64)”

Who is online

Users browsing this forum: No registered users and 1 guest