Page 4 of 5

Re: Beta Testers Wanted

Posted: Fri Mar 25, 2011 7:41 pm
by Luke7
25-03-2011 15:39:09> X-Mouse Button Control v1.53.16 (beta) (x64) Startup. Commandline '/notportable /svclaunch'
25-03-2011 15:39:09> Running on Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit, Hook Timeout: 5000 ms
25-03-2011 15:39:09> Hooking the mouse...
25-03-2011 15:39:20> CMyMessageWnd::OnSetup - Clear hotkeys...
25-03-2011 15:39:20> CMyMessageWnd::OnSetup - Opening setup dialog.

********************************************************************************
25-03-2011 15:41:52> X-Mouse Button Control v1.53.16 (beta) (x64) Startup. Commandline '/notportable /svclaunch'
25-03-2011 15:41:52> Running on Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit, Hook Timeout: 5000 ms
25-03-2011 15:41:52> Hooking the mouse...
25-03-2011 15:41:56> CMyMessageWnd::OnSetup - Clear hotkeys...
25-03-2011 15:41:56> CMyMessageWnd::OnSetup - Opening setup dialog.

********************************************************************************
25-03-2011 15:43:27> X-Mouse Button Control v1.53.16 (beta) (x64) Startup. Commandline '/notportable /svclaunch'
25-03-2011 15:43:27> Running on Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit, Hook Timeout: 5000 ms
25-03-2011 15:43:27> Hooking the mouse...
25-03-2011 15:43:59> Exit requested by the user.


********************************************************************************
25-03-2011 15:44:07> X-Mouse Button Control v1.53.16 (beta) (x64) Startup. Commandline '/exit'
25-03-2011 15:44:07> Running on Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit, Hook Timeout: 5000 ms
25-03-2011 15:44:07> Hooking the mouse...
25-03-2011 15:44:07> Exit requested from the commandline.


********************************************************************************
25-03-2011 15:44:31> X-Mouse Button Control v1.53.15 (beta) (x64) Startup. Commandline '/notportable /svclaunch'
25-03-2011 15:44:31> Running on Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit, Hook Timeout: 5000 ms
25-03-2011 15:44:31> Hooking the mouse...
25-03-2011 15:44:39> CMyMessageWnd::OnSetup - Clear hotkeys...
25-03-2011 15:44:39> CMyMessageWnd::OnSetup - Opening setup dialog.
25-03-2011 15:44:49> Applying changes to X-Mouse Button Control settings...
25-03-2011 15:44:50> CMyMessageWnd::OnSetup - Setup dialog closed.

Beta 15 running perfect. No idea what's going on.

Re: Beta Testers Wanted

Posted: Fri Mar 25, 2011 8:56 pm
by MainTrane
There weren't any major changes between those two betas, just cleaning up of the apply button logic and fixing an issue when running at startup. See the changelog in the program files directory.

Code: Select all

	#ID38: Updated user documentation
	#ID37: Fixed some issues introduced with #34 in previous build. 
	       Also fixed errors in logging from launcher service to aid debugging and prevent confusion.
	#ID21: Fixed several minor issues with new Apply enable logic.
Both myself and the developer are also running Win7, 64-bit SP1 and have never had any crashes when entering setup or otherwise. Is the EXE is crashing, or is the setup dialog simply closing the instant you try to open it. I'm sure the developer, Phil, will respond shortly. Until then here's my 2 cents.

It looks like the program thinks you are closing it whenever the setup dialog is opened. I'm shooting in the dark here, but it's possible a change to your configuration between the two beta builds could be causing the crash; try opening the setup dialog after disabling XMBC from the tray icon's context menu or if you use the Scroll Lock bypass, engage Scroll Lock then try opening.

If any of the above works, please enable debug logging in the advanced settings then try to recreate the crash and post an updated log.

Re: Beta Testers Wanted

Posted: Fri Mar 25, 2011 9:30 pm
by Luke7
Error from Event viewer:
- System
- Provider
[ Name] Application Error

- EventID 1000
[ Qualifiers] 0

Level 2

Task 100

Keywords 0x80000000000000

- TimeCreated
[ SystemTime] 2011-03-25T20:14:26.000000000Z

EventRecordID 1404

Channel Application

Computer Torben-PC

Security

- EventData
XMouseButtonControl.exe
1.53.16.0
4d8be6f6
XMouseButtonHook.dll
1.53.16.0
4d8be6ec
c0000005
0000000000002760
c4
01cbeb293800fe4c
C:\Program Files\Highresolution Enterprises\X-Mouse Button Control\XMouseButtonControl.exe
C:\Program Files\Highresolution Enterprises\X-Mouse Button Control\XMouseButtonHook.dll
7afee8e4-571c-11e0-bc51-0019d130ea05


I can't enable enable debug logging in the advanced settings, since I cannot enter setup on version 16.

Re: Beta Testers Wanted

Posted: Fri Mar 25, 2011 9:45 pm
by MainTrane
Most of the changes between Beta15 and Beta16 had to do with the way the service launches the program at startup.

The more information you provide the better, preferably step-by-step. Please give as much details as possible.

Does XMBC load OK at startup?
Do you have UAC enabled?
Can the program function normally before trying to open Setup?
Can it be disabled from notification area?
Is it crashing or is the setup dialog just not appearing/closing immediately?

Re: Beta Testers Wanted

Posted: Fri Mar 25, 2011 10:01 pm
by Luke7
Does XMBC load OK at startup? YES
Do you have UAC enabled? NO
Can the program function normally before trying to open Setup? YES
Can it be disabled from notification area? YES
Is it crashing or is the setup dialog just not appearing/closing immediately? Crashing when I try to open setup, both from tray notification area and prog folder.

Re: Beta Testers Wanted

Posted: Fri Mar 25, 2011 10:07 pm
by phil
Hi Luke,

How many profiles do you have setup? I wonder if you could send mt a copy of your XMBCSettings.xml file (in the same folder as the log file)? Just in case its a configuration thing that I might be able to reproduce?

Thanks,
Phil

Re: Beta Testers Wanted

Posted: Fri Mar 25, 2011 10:24 pm
by Luke7
Only Default profile.

xml from 15

Re: Beta Testers Wanted

Posted: Fri Mar 25, 2011 10:26 pm
by Luke7
Not sure if the xml file was uploaded

Re: Beta Testers Wanted

Posted: Fri Mar 25, 2011 10:34 pm
by phil
It didn't but probably not essential if you only have the default profile :)

Its probably something silly I did with the apply logic, trying to use something that is not there or similar.
I will take a look, but I'm busy this w/end so I might have to delay things a little :(

Thanks for letting me know about this before I released it with this problem!
Phil

Re: Beta Testers Wanted

Posted: Fri Mar 25, 2011 10:47 pm
by MainTrane
Hi Luke,

It looks like you've changed the XMBC's Icon to the G500, even on the task button. How did you achieve this?
Try restoring the default icon and see if Beta16 continues to crash.

Re: Beta Testers Wanted

Posted: Fri Mar 25, 2011 10:52 pm
by phil
And once you have tried that....
Try this:
<file removed>


Thanks,
Phil

Re: Beta Testers Wanted

Posted: Fri Mar 25, 2011 11:55 pm
by Luke7
Hi again

Beta 16.1 work :)

About the icons:
Here is what I do.
I created my Logitech icon, name Layer1.ico and placed it in X-mouse dir.
And add this reg info you can see on the picture.

Re: Beta Testers Wanted

Posted: Sat Mar 26, 2011 5:36 am
by phil
Thanks for the feedback. Glad I managed to figure out what I had done wrong - I guess thats what betas are for :)

Hopefully this time, it will be the release version lol!

Thanks,
Phil

Re: Beta Testers Wanted

Posted: Sat Mar 26, 2011 11:03 am
by Luke7
Hi again Phil
It is also possible to integrate a 256 pixel icon (109) into your exe file.
If you create a 256 icon you can add/create the smaller size in IconFX 1.64.
IconFX is freeware and there is a portable version too. http://www.icofx.ro/
It works at least as good as Iconworkshop.
I know you do not prefer the user to modify the exe file, so I will not go into to any/more details how to do it.
Again thanks a lot for your great program and also thanks to MainTrane for the great and professional user guide.

Re: Beta Testers Wanted

Posted: Sat Mar 26, 2011 5:08 pm
by phil
Yes I have used IconFX before :)

As you say I'm not so keen of modifying the exe, but then what you do with it on your own PC is up to you as far as I'm concerned :) I'm glad for the help testing and for anyone to report issues - because in this case, you probably stopped a big problem on general release - so again, thanks :)

As for the user guide - I'm glad you like that too. There are a few more updates in that prior to release, mostly to mention the custom icon file support (not editing the exe of course) lol. Maintrane has done quite a nice job with that I think, its certainly a lot better than nothing which I had before!!

Thanks,
Phil