Sendkey bug

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
danila
New User
Posts: 2
Joined: Wed Jan 13, 2021 9:55 pm

Sendkey bug

Post by danila »

XMBC Version: 2.5
Windows Version: 7 x64
Mouse Information (brand/model): simple office mouse
Relevant Computer Information (CPU, RAM etc):
Did the problem occur after an upgrade of XMBC? (If so, from what version?): no
Did the problem occur after a Windows update/upgrade? (If so, from what version?): no
How long have you used XMBC?: many years
What language and keyboard layout do you use in Windows?: eng

Clear description of the problem - try and include as much information as possible, including what button and mappings you are having problems with (if applicable).:
Hi! I have a problem with send hotkey function. After using {LMB} parameter next binds not executes.
For example bind for notepad this sendkey a{LMB}b and you got only "a" typed.
I tryed also last version of XMBC and no changes.
I tryed random wolkarounds I can imagine like a{LMB}{CLEAR}b, a{LMB}{WAITMS100}b, a{LMB}{MB5}b, but no luck.
any help pleaaaseeee!)

User avatar
phil
Site Admin
Posts: 6627
Joined: Sun Apr 06, 2003 11:12 pm

Re: Sendkey bug

Post by phil »

Its working here for me right here in the browser when replying to your message(also latest version).
Are you sure the {LMB} isn't changing keyboard focus to something else - so the b goes elsewhere?
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

danila
New User
Posts: 2
Joined: Wed Jan 13, 2021 9:55 pm

Re: Sendkey bug

Post by danila »

Hi Phill !

I foung walkaround by changing parameter "DURING" to "REPEATLY WHILE MOUSE IS DOWN". Not ideal, "DURING" is better for my task, but it works.

I'm sure problem is LMB. When I try a{RMB}b with "during" is ok

User avatar
phil
Site Admin
Posts: 6627
Joined: Sun Apr 06, 2003 11:12 pm

Re: Sendkey bug

Post by phil »

Well the RMB does not normally change keyboard focus so that could still have an impact. I didn't test during (I just tested on click as you didn't specify the "during" method if your first message!).

In during, A is pressed, then LMB pressed then B pressed, then when releasing the button, B is released, the LMB is released, then A is released - Im not sure combining mouse buttons and keys in during makes much sense?! That could be causing some issues too - not sure.

What are you using this combo with? Program/Game/Other? As I said, it worked with method 1 (on click) in the browser text input field - I didn't try anything else. The more information I have, the better I can try to reproduce the problem here - and if I can reproduce it here, the more chance I can debug and if needed, fix it!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, AMD Ryzen 5900x, MSI x570 Tomahawk, 32GB DDR4,
nVidia RTX 2070s, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply