How do I stop input queuing?

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
Mikk
New User
Posts: 3
Joined: Wed Dec 30, 2020 12:15 am

How do I stop input queuing?

Post by Mikk »

XMBC Version:
2.19.2
:

Windows Version:
8Windows 10 20H2
:

Mouse Information:
Logitech G502 Hero
:

Relevant Computer Information:
Threadripper 3970x,G.Skill 4000MHZ 64GB, TRX40 Aorus Master
:

How long have you used XMBC?
A couple of days.
:

What language and keyboard layout do you use in Windows?
Keyboard Danish - Windows English
:

I am using XMouse Button Control because the Logitech software does not permit me to rebind MouseWheelUP/Down. I am using the mousewheel to send inputs into video games. The problem I am having is that the inputs get queued up so that the inputs continue even after I stopped scrolling. If I scroll for a while and then stop the inputs can continue for more than 30 seconds. Is there a way to stop that form of input queuing?:

Thank you in advance for taking the time to look into this. :)

//Mikk

User avatar
phil
Site Admin
Posts: 6618
Joined: Sun Apr 06, 2003 11:12 pm

Re: How do I stop input queuing?

Post by phil »

Have you tried the "Ignore repeated remapped vertical/horizontal scroll" on the options tab? That's the only thing I can think of that might help here.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Mikk
New User
Posts: 3
Joined: Wed Dec 30, 2020 12:15 am

Re: How do I stop input queuing?

Post by Mikk »

I tried it and it helps a littlebit. The optimal situation would be that the input stops when I stop spinning the wheel. But that might not be possible then.

Mikk
New User
Posts: 3
Joined: Wed Dec 30, 2020 12:15 am

Re: How do I stop input queuing?

Post by Mikk »

Ok I played a little around with it and now it works when I set it to 2 MS. Thank you very much for your help. :)

User avatar
phil
Site Admin
Posts: 6618
Joined: Sun Apr 06, 2003 11:12 pm

Re: How do I stop input queuing?

Post by phil »

I'm glad you found a setting that worked, as that's the only option currently in XMBC.
Because the wheel (and tilt) are not buttons that send discrete down/up messages, its more complicated because you dont actually know that scrolling has stopped (for sure), you can only assume it by the lack of a new scroll message in a given time. What this option does is essentially ignore messages that happen too quickly, so as not to bother adding additional entries to the send input queue which in turn means said queue is processed more quickly and stops closer to you stopping scrolling.

XMBC does not have the ability to kill the single simulated input thread/queue when you stop scrolling - and I'm not sure that would be feasible (a simple change) because there may be other things in that queue that you wouldn't want to remove - and also you still need to know (guess) when the scrolling has really stopped!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply