Simulated key broken from 2.19.1 to 2.19.2

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
User avatar
Shorty
New User
Posts: 2
Joined: Sat Dec 19, 2020 1:17 pm

Simulated key broken from 2.19.1 to 2.19.2

Post by Shorty »

XMBC Version: 2.19.2 Portable (C:\PortableApps\XMouseButtonControl\...)
Windows Version: Microsoft Windows 7 (6.1) Professional 64-bit Service Pack 1 (Build 7601)
Mouse Information (brand/model): Logitech M590 Bluetooth
Relevant Computer Information (CPU, RAM etc): Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz, 16GB DDR4 RAM
Did the problem occur after an upgrade of XMBC? (If so, from what version?): Yes, from 2.19.1 to 2.19.2 (in 2.19.1 the problem does not occur)
Did the problem occur after a Windows update/upgrade? (If so, from what version?): No, nothing was changes except of upgrading XMBC.
How long have you used XMBC?: >2 years (starting with version 2.16)
What language and keyboard layout do you use in Windows?: DE/DE

Clear description of the problem - try and include as much information as possible, including what button and mappings you are having problems with (if applicable).: I wote you already an email with screenshots at Dec/10/2020. Here is the description of the problem:
Among other things, I control the zoom of a chart program (MetaTrader 4 from Metaquotes) by sending + and - keystrokes (plus and minus) when tilting the mouse wheel.

In version 2.19.1 this works fine, but with version 2.19.2. the chart program does not react at all to the tilting of the mouse wheel. So I downgraded to Version 2.19.1 at the moment.

Here is my setting of the related profil: [see screenshot in my email, dont know how to upload images here in the forum].

Regards,
Markus

User avatar
phil
Site Admin
Posts: 6618
Joined: Sun Apr 06, 2003 11:12 pm

Re: Simulated key broken from 2.19.1 to 2.19.2

Post by phil »

Hi, I missed your email, it got caught in my spam box. I have found it now though - I will try and take a look tomorrow - but I dont recall very much changing between 2.19.1 and 2.19.2 although it was quite a while ago so I could be wrong - but I hope that will make it easier to figure out whats broken!.

I'll reply to the email or here if I need more information

Thanks
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
Shorty
New User
Posts: 2
Joined: Sat Dec 19, 2020 1:17 pm

Re: Simulated key broken from 2.19.1 to 2.19.2

Post by Shorty »

Hello Phil,

surprisingly I can give you an all-clear.

I was just about to make you a screen video to show you the problem, when it turned out that the simulated keys now also work with version 2.19.2.
I suspect that the problem was either with myself (maybe I did something wrong) or with the chart program, because the chart program has been updated in the meantime.

Sorry for the trouble I may have caused. There is no error, all is well.

Thank you for your understanding.

Regards,
Markus

Post Reply