Pixelated pointer if the "Change cursor to indicate active layer" option is used

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
User avatar
spitfire_ch
Member
Posts: 16
Joined: Wed Jan 02, 2013 1:27 pm

Pixelated pointer if the "Change cursor to indicate active layer" option is used

Post by spitfire_ch »

XMBC Version: 2.19.2
Windows Version: 10
Mouse Information (brand/model): Logitech Trackball Ergo
Relevant Computer Information (CPU, RAM etc): Intel Core i7-8700, 16 GB RAM
Did the problem occur after an upgrade of XMBC? (If so, from what version?): n/a
Did the problem occur after a Windows update/upgrade? (If so, from what version?): n/a
How long have you used XMBC?: years
What language and keyboard layout do you use in Windows?: Swiss German

Clear description of the problem - try and include as much information as possible, including what button and mappings you are having problems with (if applicable).: When using a larger mouse pointer (windows setting) and activating the XMouse option "Change cursor to indicate active layer", the pointer looks very pixelated, at least the diagonal side of the arrow (strong aliasing). The normal mouse pointer (layer 1 -> no number) has no aliasing. It seems to me windows is scaling the cursor up, but can't do that when it's modified by XMouse.

Certainly, this is not high priority, just cosmetics and somewhat irritating when using other layers and said options.

Thanks for eventually looking into it and I hope you are well!

User avatar
phil
Site Admin
Posts: 6618
Joined: Sun Apr 06, 2003 11:12 pm

Re: Pixelated pointer if the "Change cursor to indicate active layer" option is used

Post by phil »

Hi, yes I know about this - and there are other issues here too - espesically with DPI and when changing DPI - I noticed on my new surface pro 7!
I will look into it at some point, but have other priorities right now... To be fair, I knew about it before releasing 2.19.2 but while its annoying, its not really a show stopper.

As for being well - thats not so good - a bit of a long story but its not been a great year for me (not Covid related) but heart issues related. I had a pace maker fitted in the last week - not something you expect to happen in your early 40's! So thats one of the reasons I've not been getting much done with XMBC!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
spitfire_ch
Member
Posts: 16
Joined: Wed Jan 02, 2013 1:27 pm

Re: Pixelated pointer if the "Change cursor to indicate active layer" option is used

Post by spitfire_ch »

Oh sh**, I am sorry to hear that! :( No, definitely not something you'd expect in the early 40's! I hope everything went well and it doesn't impact your life too much.

Regarding the issue: yes, of course, like I said, it's just cosmetics, no prio.

All the best and take care!

User avatar
phil
Site Admin
Posts: 6618
Joined: Sun Apr 06, 2003 11:12 pm

Re: Pixelated pointer if the "Change cursor to indicate active layer" option is used

Post by phil »

Yeh hopefully thats the issue fixed now - having been in and out of hospital since March... lol.. and Hopefully nothing else goes wrong this year - 2020 has been a bit sh** (understatement!) for the whole world!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
spitfire_ch
Member
Posts: 16
Joined: Wed Jan 02, 2013 1:27 pm

Re: Pixelated pointer if the "Change cursor to indicate active layer" option is used

Post by spitfire_ch »

Indeed! Only 24 days left, thankfully ...

Post Reply