Scrolling in OSM not working

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
SirTwist
New User
Posts: 2
Joined: Sat Jul 25, 2020 11:28 pm

Scrolling in OSM not working

Post by SirTwist »

XMBC Version: 2.19.2
Windows Version: Win10 2004
Mouse Information (brand/model): Logitech 705
Relevant Computer Information (CPU, RAM etc): Intel
Did the problem occur after an upgrade of XMBC? (If so, from what version?): no
Did the problem occur after a Windows update/upgrade? (If so, from what version?): no
How long have you used XMBC?: some days
What language and keyboard layout do you use in Windows?: German

Clear description of the problem - try and include as much information as possible, including what button and mappings you are having problems with (if applicable).:
Hi, I just discovered, that I cannot scroll maps in OpenStreetmap (OSM) web pages in Firefox browser (78.0.2).

What do I mean with map scrolling? Usually, you can left click onto the map and while mouse button is pressed move around with the mouse and the map is following.

In contrast to that, Google Maps is working fine.
And OSM works in MS Edge as well.
But.... when I disable XMBC via scroll key, OSM works fine again even in Firefox.

I tried this on two different computers, both Win10 2004, where I freshly installed XMBC.
I tried to fine some hints in the debugging log file, but hm... that's too much for me.
I also tried to change some settings, which I thought could have an effect on that scrolling. I only have one Layer, and tried also the checkbox "Disable in Next/Previous layer commands"

Okay, after I've written all that, I found something
: Directrly after installation of XMBC I had some issues, thinking XMBC wasn't working, but it was the Logitec Setpoint software interferring. But during that wrangling, I assigned "Left click" to the left button, "Right click" to the right button and so on. When I reset this to "No Change (Don't intercept") for left and right button, OSM works again.

Can you please have a look into that, why "map scrolling" is not working on OSM when mouse buttons are intercepted? Can you or anyone else reconstruct this behaviour?

Kind regards, and thanks in advance,
Michael

User avatar
phil
Site Admin
Posts: 6543
Joined: Sun Apr 06, 2003 11:12 pm

Re: Scrolling in OSM not working

Post by phil »

I can confirm that I see the same problem. No idea why yet.
But its really not a good idea to change the left button to "Left click" because effectively that blocks the button, and sends (injects) a simulated click using MS's SendInput API. Many programs (usually games) block injected input so the button will never be seen.

Ive not seen this problem in a browser window before (and I don't really see how the OSM page could block that when firefox works normally otherwise (I can still click and drag to select text) but clearly that's what is happening somehow. The Why bit is still a mystery to me though.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

SirTwist
New User
Posts: 2
Joined: Sat Jul 25, 2020 11:28 pm

Re: Scrolling in OSM not working

Post by SirTwist »

Thank you for having a look at it so soon.
I fully agrtee, that we can see the assignment of "left button" to left button etc.. as a misconfiguration ;-)
I just moved some days ago from the Logitec own utility SetPoint to XMBC and had some interference between those in the beginning.
So perhaps the best solution would be to add something like a warning "Are you sure you want to reassign left button?" to the configuration GUI.
Kind regards,
Michael

User avatar
phil
Site Admin
Posts: 6543
Joined: Sun Apr 06, 2003 11:12 pm

Re: Scrolling in OSM not working

Post by phil »

Yes Ive been considering adding a warning to the left button for some time - not least because lots of people change it to something else and then get caught out because they can no longer use the mouse as normal and struggle to change this setting again (there are ways to disable XMBC but its only once you get stuck that you think about it :)).
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply