remote desktop connection - buttons do not work!!!

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
New User
Posts: 1
Joined: Wed Jul 22, 2020 11:26 am

remote desktop connection - buttons do not work!!!

Post by CamdenJayce »

XMBC Version: 2.18.7
Windows Version: windows 10
Mouse Information (brand/model): X7
Computer Information: ---
Did the problem occur after an upgrade of XMBC?: +++
Did the problem occur after a Windows update/upgrade?: previously (on older versions) worked well. Now it does not work for more than a month...

How long have you used XMBC?: 5 years.

What language and keyboard layout do you use in Windows?: Russian

Clear description of the problem: When I connect to a remote desktop (server) on the Internet, through Windows, the copy - paste buttons (which I assigned to 2 side keys) - do not work. And this problem only on the new version of the program. On old versions - everything worked perfectly and without failures. I do not understand what the problem is at all, but you have to constantly download an older version, which is very inconvenient. Please help in solving the problem.

User avatar
Site Admin
Posts: 6543
Joined: Sun Apr 06, 2003 11:12 pm

Re: remote desktop connection - buttons do not work!!!

Post by phil »


I use remote desktop and I don't have this problem with any version of XMBC (believe me if I did it would be resolve pretty quickly as it would be a show stopper for me!) Therefore I suspect that it may be a setting or configuration issue.
Can you send me a copy of your settings? What have you got the RDP settings set to in general settings?

What old version works (compared to I presume the latest version) (and out of interest, why would you need to keep downloading it - XMBC does not automatically update itself?!)
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply