2.19.1 failing after hibernation

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
atompkins
New User
Posts: 2
Joined: Tue Apr 07, 2020 3:28 pm

2.19.1 failing after hibernation

Post by atompkins »

XMBC Version: 2.19.1
Windows Version: Windows 10 1909
Mouse Information (brand/model): Logitech MX Ergo
Relevant Computer Information (CPU, RAM etc): Core i7-8650U, 16GB RAM, Surface Pro 6 with dock
Did the problem occur after an upgrade of XMBC? (If so, from what version?): 2.19
Did the problem occur after a Windows update/upgrade? (If so, from what version?): No
How long have you used XMBC?: 3-4 years
What language and keyboard layout do you use in Windows?: English UK

Clear description of the problem - try and include as much information as possible, including what button and mappings you are having problems with (if applicable).:

XMBC doesn't return from hibernation properly. The systray icon has a red x as if it was disabled. I can right click on it to get the context menu once. no matter what i select nothing happens. i have to end task and restart every time.

is there a way to roll back to previous version?

User avatar
phil
Site Admin
Posts: 6401
Joined: Sun Apr 06, 2003 11:12 pm

Re: 2.19.1 failing after hibernation

Post by phil »

Yes you can roll back just by running the installer for the previous version. I know about this and I'm working on it (have already fixed it - awaiting test results to be sure the fix is working better than the one in 2.19.1 - it was broken in 2.19 too but behaved slightly differently).
If you need links to previous versions, let me know - or if you want to test the fix, also let me know :)
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

atompkins
New User
Posts: 2
Joined: Tue Apr 07, 2020 3:28 pm

Re: 2.19.1 failing after hibernation

Post by atompkins »

wow thanks for quick response :) yes i am happy to test.

User avatar
phil
Site Admin
Posts: 6401
Joined: Sun Apr 06, 2003 11:12 pm

Re: 2.19.1 failing after hibernation

Post by phil »

PM sent! As for the quick response, it's not like we have anything else to do right now hahaha.. :?
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

struddles73
New User
Posts: 2
Joined: Wed Apr 15, 2020 4:39 pm

Re: 2.19.1 failing after hibernation

Post by struddles73 »

Hello, would you be able to share the link to download 2.19? I'm having this issue as well and would like to revert back to the previous version for now while you are still working on the fix. :)

User avatar
phil
Site Admin
Posts: 6401
Joined: Sun Apr 06, 2003 11:12 pm

Re: 2.19.1 failing after hibernation

Post by phil »

But 2.19 suffers this problem too! And as far as I know its worse in 2.19! If you are seeing this problem, please send me a copy of your XMBC log file!
The more examples I get, the better I can be sure I have found the exact problem!

Thanks
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

struddles73
New User
Posts: 2
Joined: Wed Apr 15, 2020 4:39 pm

Re: 2.19.1 failing after hibernation

Post by struddles73 »

Hi Phil,

Thank you for your response! I just sent you an email with my XMBC log file attached. Please let me know if there's anything else I can do to help. :)

Thank you!

Post Reply