Profiles request

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
User avatar
Kukurykus
Fanatic
Posts: 384
Joined: Sat Jul 02, 2016 1:15 pm

Profiles request

Post by Kukurykus »

When I export / import single application / profile, so save / load it on / from drive, XMBC remembers last location the operation was done. I mean when I close (exit) XMBC and open (launch) it again I am happily taken back to last visited location. That's very convinient, as I keep my single application profiles in dedicated folder.

The problem is with 'Save Profile' / 'Load Profile' buttons. To use them for whole XMBC profile I'm always taken to XMBC folder (ctrl lmb on trey icon), not to that where I made saving / loading of profile. Please make it remembers last visited (used) location also in this case.
HAMA Roma, Rapoo 3920P
Windows 10 x64, Intel i5-4670K @ 3.40GHz, 8GB,
Intel(R) HD Graphics 4600, Intel SSD 179 GB HDD

User avatar
phil
Site Admin
Posts: 6401
Joined: Sun Apr 06, 2003 11:12 pm

Re: Profiles request

Post by phil »

Added to the list :)
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
Kukurykus
Fanatic
Posts: 384
Joined: Sat Jul 02, 2016 1:15 pm

Re: Profiles request

Post by Kukurykus »

Bug Alert:

When Saving Profile the new file is created, for ex. Marko.xmbcp. Then each time I open XMBC, the loaded and displayed profile is: Marko (instead of default). So in other words, XMBC in first instance looks for last used custom profile to load it instead of XMBCSettings.xml

Is that problem? I don't know yet, but what is wrong for sure is, when making changes to settings and applying them, the changes are applied only to current profile (Marko.xmbcp). XMBCSettings.xml is not updated at same time!

So in scenario someone looses / deletes his current profile, all changes beeing made for long time will be lost as well, as XMBCSettings.xml is not up-to-date anymore from time of creating custom profile.


What is really bad, if Marko.xmbcp will be deleted intentionally, XMBC starts with XMBCSettings.xml and displays Default profile (that's good, however they are old), because when any change to settings or application is made and then applied, it is not stored in XMBCSettings.xml, but for some reason Marko.xmbcp is recreated!

This way XMBCSettings.xml becomes useless from first time of making new custom profile.


What is very, very bad, when exiting XMBC, uninstalling it, restarting computer, and installing it again (reseting) settings, XMBC still searches for Marko.xmbcp profile!

XMouseButtonControl.log
************************************************************************************************************************************
05-04-2020 19:36:21.810> X-Mouse Button Control v2.19.1 (x64) Startup. Commandline '/installed /notportable', 05-04-2020 19:36:21.814> Running in high integrity mode (0x00003000)
05-04-2020 19:36:21.815> Unable to find the user defined profile 'C:\Users\Userek\AppData\Roaming\Highresolution Enterprises\XMouseButtonControl\Marko.xmbcp' (Error code 2: unable to find specific file. )

So XMBCSettings.xml is created this time indeed, but any change made to apps / settings, then applied does not rewrite it, but creates Marko.xmbcp!


I solved it by deleting (regedit):
Komputer\HKEY_CURRENT_USER\Software\Highresolution Enterprises\XMouseButtonControl

where in settingsFile key (even after reinstallation) there's still:
C:\Users\User\AppData\Roaming\Highresolution Enterprises\XMouseButtonControl\Marko.xmbcp

Surely reinstallation is not needed when I know that key has to be removed. But main problem presists:
XMBCSettings.xml should be updated when changes are applied to currentnly used profile (Marko.xmbcp)

Additionally after deleting Marko.xmbcp and opening XMBC, and then making any changes to apply, Marko.xmbcp shouldn't be recreated, but only XMBCSettings.xml updated!


Regarding problem I mentioned at beginning, XMBC can be opened with Marko.xmbcp (if it was closed with, and it still exists), but between Profile: Marko static text and About button there should be also button: 'Unload Profile'.
Last edited by Kukurykus on Sun Apr 05, 2020 7:29 pm, edited 1 time in total.
HAMA Roma, Rapoo 3920P
Windows 10 x64, Intel i5-4670K @ 3.40GHz, 8GB,
Intel(R) HD Graphics 4600, Intel SSD 179 GB HDD

User avatar
phil
Site Admin
Posts: 6401
Joined: Sun Apr 06, 2003 11:12 pm

Re: Profiles request

Post by phil »

I completely disagree with your last post.

If you load a different profile, you are editing updating THAT profile and not the default one - if it were to update the base settings, that would be 100% nightmare for me as I have many many profiles from various users for testing/proving fixes etc. I *want* them to be COMPLETELY separate from MY settings. Updating the default settings with other's profiles would be a nightmare.

It is currently working as I intend it to and I see little reason to change it. Most people do not need to load/save alternate profiles but if they do, I really don't see how updating the base/default settings would be of more good than harm!

You can load the default settings file too with the load profile button - if you load XMBCSettings.xml it will clear that registry key automatically - no need to go editing the registry. This also works in portable mode where the registry is NOT used (it uses a file instead to maintain the point of portable - no system changes).
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
Kukurykus
Fanatic
Posts: 384
Joined: Sat Jul 02, 2016 1:15 pm

Re: Profiles request

Post by Kukurykus »

I see now when loading / saving profile there is in dropdown menu other extension to choose what I was not aware. This way I can either with custom profile rewrite default profile (xml), or reload that default profile instead of .xmbcp file that deletes registry value indeed.

The little bug still exists, when removing custom profile, then opening XMBC it shouldn't recreate it after applied changes, but rewrite default xml profile as that was loaded opening XMBC? Same for reinstallation.
HAMA Roma, Rapoo 3920P
Windows 10 x64, Intel i5-4670K @ 3.40GHz, 8GB,
Intel(R) HD Graphics 4600, Intel SSD 179 GB HDD

User avatar
phil
Site Admin
Posts: 6401
Joined: Sun Apr 06, 2003 11:12 pm

Re: Profiles request

Post by phil »

Yes, if the profile is not there, it shouldnt create it - agree!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply