Page 1 of 1

Unique Issue With Tekla Structures - SOLVED!

Posted: Fri Sep 06, 2019 10:46 am
by fredz19
XMBC Version: 2.18.8
Windows Version: Windows 10 Pro build 1809
Mouse Information (brand/model): Logitech G700s
Relevant Computer Information (CPU, RAM etc): I9-9900K 3.60 GHz, 32.0 GB Ram
Did the problem occur after an upgrade of XMBC? (If so, from what version?): Not sure? I've tried older versions and still have the issue.
Did the problem occur after a Windows update/upgrade? (If so, from what version?): Kind of? It wasn't an issue on an older computer, upgraded, and now it's an issue. Both computers were Windows 10 Pro, but maybe different builds? Switch occurred some time last year in the fall.
How long have you used XMBC?: Almost a decade... at least 8 years I'd say. Big fan, have donated a few times, intend to donate more!! Love this software!! Hope to see it keep getting love/updates.
What language and keyboard layout do you use in Windows?: English, Qwerty.

Clear description of the problem - try and include as much information as possible, including what button and mappings you are having problems with (if applicable).: The issue is a unique one... It's X-Mouse causing an issue in another program (Tekla Structures V21.0). When my mouse cursor scrolls over the top of another window/program that does NOT have a profile within X-Mouse causes important dialog information to disappear from my Tekla Structures window.

I have a link to a video to demonstrate the issue, but as a new user to this forum I cannot provide a link. To anyone that would like one, perhaps I could message you a link?

Re: Unique Issue

Posted: Fri Sep 06, 2019 10:49 am
by fredz19
Sorry should have included this, to clarify, this is not an issue with X-Mouse disabled/closed. If I create a profile for the window, it's also not an issue... however this is a very inconvenient work-around as it's cluttering up my X-Mouse profiles FAST.

Re: Unique Issue

Posted: Fri Sep 06, 2019 3:00 pm
by phil
Sounds really weird... I have manually upgraded you to a "normal" forum user so you should now be able to post links and images etc.
I cant yet imagine what the problem would be - hopefully a video will make things clearer.

Re: Unique Issue

Posted: Fri Sep 06, 2019 3:43 pm
by fredz19
Here is a link to the video

Notice how when I hover my mouse over "LMTOOLS" window, aspects of the Beam Properties dialog vanish.

Re: Unique Issue

Posted: Fri Sep 06, 2019 7:04 pm
by phil
Ok officially weird! No idea what could cause that. Can you pm me a copy of your profile?

I’m out tonight but may get some time over the W/end to have a look. Although I suspect I’m not gonna be able to reproduce as I doubt that software is ‘available’ to me which will make it rather tricky I suspect!

Re: Unique Issue

Posted: Sat Sep 07, 2019 10:27 am
by phil
When you say "mouse cursor scrolls over" do you mean moves over or do you mean when you actually scroll the mouse wheel when the cursor is over the other window? The video does not make that clear because I cant see what you are doing with the mouse at the time :).

If you mean "scroll the wheel over another window" then have you tried disabling the (global) general setting "make scroll wheel scroll window under cursor"? Did it make any difference? Also, try turning off "Activate window when scrolling" if its on.


Re: Unique Issue

Posted: Thu Sep 12, 2019 2:59 pm
by fredz19

I sent you the profile as you requested.

This is when I "Mouse Over" no scrolling involved, sorry for the poor wording.

By default I run with those suggested settings turned off.

Thanks for looking into this for me, I sure appreciate it!

Re: Unique Issue

Posted: Thu Sep 12, 2019 5:45 pm
by fredz19
WOW Sometimes just talking it out and discussing issues with another person reveals a solution!

I went into my default profile to poke around and see the settings... I then turned off "Force Scroll Lines/Pages(If application does not respond to setting)" shown in the attached snapshot. Problem solved for now? It doesn't seem to be an issue any more.... Hopefully I can clean up my application profile list now!!!

Thanks Phil!