Mouse Up action results in slow, stepped scrolling

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
jwicker
New User
Posts: 3
Joined: Wed Jul 31, 2019 4:40 pm

Mouse Up action results in slow, stepped scrolling

Post by jwicker » Wed Jul 31, 2019 4:57 pm

XMBC Version: 2.18.7
Windows Version: Windows 10 x64
Mouse Information (brand/model): Logitech M705
Computer Information: Lenovo T470
Did the problem occur after an upgrade of XMBC?: Yes
Did the problem occur after a Windows update/upgrade?: No
How long have you used XMBC?: 1 yr
What language and keyboard layout do you use in Windows?: English QWERTY US

Clear description of the problem: Mouse Up action when used with Side buttons of Logitech M705 causes juddering slow chunky feeling scrolling. It was smooth previous to the update (I believe the update caused the issue). No Logitech software or drivers installed that I know of. Have tried updating/ removing drivers and restarting etc.

User avatar
phil
Site Admin
Posts: 5923
Joined: Sun Apr 06, 2003 11:12 pm

Re: Mouse Up action results in slow, stepped scrolling

Post by phil » Wed Jul 31, 2019 5:02 pm

Hi,

What version did you update from - as perhaps the first thing to try is to roll back to an older version (I can provide links). The latest version has been there for several months now so I cant easily work out if your talking about a minor update 2.18.x-2.18.7 or a bigger update 2.17.x - 2.18.7???

I'm trying to understand exactly what you are referring to - when you say "mouse up action" - do you mean moving the mouse in an upward direction - are you talking about "Change movement to scroll", or do you mean that the button up action is slow (what is the button remapped to), or something else altogether?

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

jwicker
New User
Posts: 3
Joined: Wed Jul 31, 2019 4:40 pm

Re: Mouse Up action results in slow, stepped scrolling

Post by jwicker » Wed Jul 31, 2019 5:07 pm

Ah, sorry.

I take the updates as they come. It could be coincidental but I believe when I updated to 2.18.7 from whatever version was exactly previous (2.18.6 ?), the problem began.

By "mouse up action" I mean I have mapped buttons 4 and 5 to Mouse Up and Mouse Down, respectively. Only 1 layer in use.

They do scroll when pressed, but in a time-delayed sort of 'chunky' fashion.

When I originally installed XMBC, the scrolling via those buttons was as smooth as the wheel (e.g. much faster and smoother).

I reinstalled today and made sure to remove previous configurations, and restarted.

Thanks for your speedy response and help.

User avatar
phil
Site Admin
Posts: 5923
Joined: Sun Apr 06, 2003 11:12 pm

Re: Mouse Up action results in slow, stepped scrolling

Post by phil » Wed Jul 31, 2019 5:11 pm

Ah OK now I get it - "Mouse Wheel Up"/"Mouse Wheel Down" (perhaps there are too many options with similar names/functionality :)).

I'll try and have a look at home tonight to see if I have the same problem.
In the meantime, could you:
a) Try "Scroll Window Up"/"Scroll Window Down" as they do actually work slightly differently (and see if its better or worse or no different).
b) Try 2.18.6 to confirm if indeed it changed between 6 and 7 (which I doubt as there were very few changes)

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

jwicker
New User
Posts: 3
Joined: Wed Jul 31, 2019 4:40 pm

Re: Mouse Up action results in slow, stepped scrolling

Post by jwicker » Wed Jul 31, 2019 5:21 pm

Just to update -

No changes observed when trying 2.18.6.

Scroll Window Up and down did not have any different effect. No difference from what I could tell.


Again, thank you for your help. I use the side buttons to scroll huge bouts of code every day and I'm just getting around to asking for help since the issue started.

User avatar
phil
Site Admin
Posts: 5923
Joined: Sun Apr 06, 2003 11:12 pm

Re: Mouse Up action results in slow, stepped scrolling

Post by phil » Wed Jul 31, 2019 9:23 pm

OK I wonder if its worth going back to 2.17 - the closer I can get to where it changed (if it changed and is not something else impacting it) the easier it will be to narrow down and fix. If your scrolling code, Im sure you understand :)

If you want to try:
2.17: https://www.highrez.co.uk/scripts/downl ... on=2170000
2.18: https://www.highrez.co.uk/scripts/downl ... on=2180000
2.18.5: https://www.highrez.co.uk/scripts/downl ... on=2180500

In the meantime I'll try it out here and see how it performs...
PS: What application are you using when scrolling (does it make any difference or is it slow globally)

Regards,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
phil
Site Admin
Posts: 5923
Joined: Sun Apr 06, 2003 11:12 pm

Re: Mouse Up action results in slow, stepped scrolling

Post by phil » Wed Jul 31, 2019 9:41 pm

I just tried here (Windows 10, XMBC 2.18.7 in both Firefox and Visual studio 2015 the scroll appears to be nice and fast and not laggy when on the 4th and 5th buttons.

To rule out any other XMBC settings, could you share your profile with me (save it and PM me a copy of the XML file). Then I can check that here. If still I get no lag its going to get a bit tricky - and perhaps we will need to go down the debug log route and perhaps there is something else at play.

Regards,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply