Multi Double Click

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
unikey68
New User
Posts: 1
Joined: Tue May 07, 2019 3:16 am

Multi Double Click

Post by unikey68 » Thu Jun 20, 2019 8:38 am

XMBC Version: 2.18.6
Windows Version: Windows 7
Mouse Information (brand/model): Steelseries Rival 95
Computer Information:
Did the problem occur after an upgrade of XMBC?: No
Did the problem occur after a Windows update/upgrade?: No
How long have you used XMBC?: 6 months
What language and keyboard layout do you use in Windows?: US standard

Clear description of the problem:

I have a macro section like this:
{ASET:515,380}{LMB}{LMB}{WAITMS:100}{ASET:515,410}{WAITMS:100}{LMB}{LMB}
This has 4 LMB all (2 double click). It is fine but it won't work if I leave {WAITMS: 100}.
The macro segment only accepts the last 2 LMBs (1 double click).
Is there a way to not use {WAITMS: 100} but it still runs?
I mean there's a command to clear the mouse buffer for example.
Thanks for read.

User avatar
phil
Site Admin
Posts: 5923
Joined: Sun Apr 06, 2003 11:12 pm

Re: Multi Double Click

Post by phil » Thu Jun 20, 2019 8:54 pm

I guess you need the wait in there because otherwise Windows things its a quadruple click not just two double clicks.
No its not possible to "clear" the mouse buffer - not from XMBC anyway. You may be able to reduce the delay - that will depend on your double click time in Windows settings.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply