Using the scroll wheel to mute the sound

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
djr63
New User
Posts: 4
Joined: Tue Mar 26, 2019 9:43 pm

Using the scroll wheel to mute the sound

Post by djr63 » Tue Mar 26, 2019 10:15 pm

XMBC Version: 2.18.5
Windows Version: Windows 7 home
Mouse Information (brand/model): Gearhead Optical
Computer Information: Old like it's owner
Did the problem occur after an upgrade of XMBC?: no
Did the problem occur after a Windows update/upgrade?: no
How long have you used XMBC?: a year maybe
What language and keyboard layout do you use in Windows?: Standard English

Clear description of the problem: I downloaded this program because the scroll wheel stopped working as a mute button on my mouse and I didn't want to get a new mouse. Your program worked GREAT! And then all of a sudden something got changed. (I think my sneaky granddaughter was a little extra sneaky and changed something.) Everything still works except that before the settings got changed...when I pushed the scroll button the computer would be muted and I could use the scroll wheel and control the volume without moving the cursor from wherever it was when I pushed it.

NOW when I push the scroll button...the computer mutes as it should...but in order to change the volume I have to have the cursor hovering over the little volume display that pops up (also a feature of this program that I LOVE!) or it just scrolls the windows under it.

I've changed the 3 settings I think I should several times to different configurations of "disable scroll window under cursor" "Make scroll wheel scroll window under cursor" and "Activate window when scrolling"...but I just can't find the correct set of them to get it to work. It's like one of those puzzles in a Harry Potter or Adventure of the Lost Ark movies where things have to be in the correct order to gain access to the room. UGH! :? :lol: :?

Could you PLEASE explain which option to check and or un-check to get it so when I push the scroll wheel it mutes (or unmutes) and I can scroll the wheel and change the volume without having to hover over the volume display? It's a little thing...but for an old lady like me, it's a big thing.

Thanks guys :-)

User avatar
phil
Site Admin
Posts: 5876
Joined: Sun Apr 06, 2003 11:12 pm

Re: Using the scroll wheel to mute the sound

Post by phil » Tue Mar 26, 2019 10:30 pm

Hi, its possible that a change in XMBC caused this to stop working. I will have to have a look.

First of all, is the middle button (scroll wheel button) still muting the audio or not? If it is, and the volume HUD/slider is shown then the issue will be with the scrolling redirection or interception. If you have "Scroll window under cursor" turned ON then I would expect the behavior you are reporting (because the scroll messages get sent to the window under the cursor, not the active window (i.e. the volume slider window). If thats turned off then the scroll messages should go the the "active" foreground window (ie the volume slider window). In that case, I will have to check that the volume slider window is responding as it should to scroll messages.

There were an awful lot of changes in XMBC 2.18 (that I released late December) so maybe something in 2.18 has changed (intentionally or unintentionally [I will need to figure out when I find it!])
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

djr63
New User
Posts: 4
Joined: Tue Mar 26, 2019 9:43 pm

Re: Using the scroll wheel to mute the sound

Post by djr63 » Wed Mar 27, 2019 1:45 am

Hello Phil,

Thanks for the quick reply :-)

Yes, the middle (wheel) is working for muting and unmuting as expected, no problem there. It's just the scrolling the wheel to make the volume increase or decrease that refuses to work unless the cursor is over the little display. I can't make the volume display be the 'active window' no matter what I do. And it WAS like that before.

As far as the "Scroll window under cursor" you talked about, I don't have that as an option anywhere that I can find. I'm hoping you meant "DISABLE scroll window under cursor"? Because that's what I have.

When I click the 'settings' button on the bottom left (global settings) I have 2 options...
"Make scroll wheel scroll window under cursor" and also right under that I have "Activate window when scrolling".

Then on the Options tab (top right where the Layer1/Layer2 etc tabs are located) I have

"Disable scroll window under cursor." currently UN-checked

Also, when I UNcheck the "Make scroll wheel scroll window under cursor" in the global options...the other setting on the options tab gets greyed out so I can't change it until I go back and check the other one. I don't know if that is what it's supposed to do or not but that's what happens.

I have checked and unchecked all of them and tried many combinations of the 3 and no matter WHAT combination I choose...the cursor HAS to be over the volume slider display for me to be able to change the volume one way or the other with the wheel.

Even when it is active (when I click on the volume display and I'm scrolling the volume up or down) if I move the cursor away it stops, and the window that's under it becomes the active one and moves up and down.

Thanks for your help...I hope I explained everything ok and didn't confuse you (too much) :D

User avatar
phil
Site Admin
Posts: 5876
Joined: Sun Apr 06, 2003 11:12 pm

Re: Using the scroll wheel to mute the sound

Post by phil » Wed Mar 27, 2019 1:56 am

djr63 wrote:
Wed Mar 27, 2019 1:45 am
As far as the "Scroll window under cursor" you talked about, I don't have that as an option anywhere that I can find. I'm hoping you meant "DISABLE scroll window under cursor"? Because that's what I have.
Yes thats what I mean. You tick it to disable this functionality and therefore DON'T scroll the window under the cursor, but only the active window (well thats the plan anyway!)
djr63 wrote:
Wed Mar 27, 2019 1:45 am
When I click the 'settings' button on the bottom left (global settings) I have 2 options...
"Make scroll wheel scroll window under cursor" and also right under that I have "Activate window when scrolling".
Activate window when scrolling brings the window under the cursor (that you scroll) into the foreground. This is irrelevant to this problem as far as I can tell - leave it unchecked.
djr63 wrote:
Wed Mar 27, 2019 1:45 am
Then on the Options tab (top right where the Layer1/Layer2 etc tabs are located) I have

"Disable scroll window under cursor." currently UN-checked

Also, when I UNcheck the "Make scroll wheel scroll window under cursor" in the global options...the other setting on the options tab gets greyed out so I can't change it until I go back and check the other one. I don't know if that is what it's supposed to do or not but that's what happens.
Yes thats intended. The per-profile "disable" option is not available if you disable it globally - as its always disabled (globally).
djr63 wrote:
Wed Mar 27, 2019 1:45 am
I have checked and unchecked all of them and tried many combinations of the 3 and no matter WHAT combination I choose...the cursor HAS to be over the volume slider display for me to be able to change the volume one way or the other with the wheel.

Even when it is active (when I click on the volume display and I'm scrolling the volume up or down) if I move the cursor away it stops, and the window that's under it becomes the active one and moves up and down.
If you have "activate on scroll" ticked then I would expect that. If not then the active window should not change. I can only think that the volume HUD/slider window is running differently from normal windows (because really its an always on top, notification window and not a "normal" window. It is quite possible that I changed the way it works in 2.18 - I need to take some time and review the change history. If it was changed intentionally (at someone else's request (I cant remember but its been over a year since I started working on 2.18), then I will need to make that intention optional I guess. If it was changed unintentionally, I need to revert said change (i.e. its a bug that needs fixing).
djr63 wrote:
Wed Mar 27, 2019 1:45 am
Thanks for your help...I hope I explained everything ok and didn't confuse you (too much) :D
I got it - no confusion... I'll try and loo into it this week or at the weekend (more likely as I don't get much time during the working week) and will get back to you when I find anything.

Regards,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

djr63
New User
Posts: 4
Joined: Tue Mar 26, 2019 9:43 pm

Re: Using the scroll wheel to mute the sound

Post by djr63 » Wed Mar 27, 2019 4:17 am

Take your time sir...I'll check back in a week or so.
Thank you so much :D

User avatar
phil
Site Admin
Posts: 5876
Joined: Sun Apr 06, 2003 11:12 pm

Re: Using the scroll wheel to mute the sound

Post by phil » Sun Mar 31, 2019 2:08 pm

Hi Djr63,

I'm struggling a little to reproduce this. Can you please send me a copy of your XMBC profile (use the "Save profile" button on the main window and send em the result - you can PM or attach it here, or you can email me - phil [@] highrez [dot] co.uk

Right now, i have tested 2.18.5 on Windows 7, and when the volume HUD window is visible, the wheel scroll works to change the volume, no matter where the pointer is (so long as "make scroll wheel scroll window under cursor" is UNTICKED - if its ticked then the window under the pointer scrolls, as I would expect).

So for me it appears to be working as I would expect... I hope your profile may cause the same problem for me, in which case, I can see what is different and suggest a setting change - or find the bug if there is one!

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

djr63
New User
Posts: 4
Joined: Tue Mar 26, 2019 9:43 pm

Re: Using the scroll wheel to mute the sound

Post by djr63 » Tue Apr 16, 2019 2:52 pm

Just stopped by to say a big THANK YOU PHIL!!!
:D :D :D :D :D :D :D

My volume control now works the way it did before!

You're the best...big companies should have such great customer service :-)

:cheers: to you!

Debbie

guptaandrew
New User
Posts: 2
Joined: Sun Jun 16, 2019 5:24 pm

Re: Using the scroll wheel to mute the sound

Post by guptaandrew » Sun Jun 16, 2019 5:45 pm

now i get it why i was having such problem thanks for the post

Post Reply