In the Russian keyboard does not work

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
User avatar
nolimit59
New User
Posts: 2
Joined: Thu Feb 14, 2019 11:07 am

In the Russian keyboard does not work

Post by nolimit59 » Thu Feb 14, 2019 11:44 am

XMBC Version: 2.18.2
Windows Version: Windows 10 Home Single Languare 10.0.17134.523 64-bit
Mouse Information (brand/model): Garnizon GM-730G
Computer Information: Notebook Dell G3 15" 3579
Did the problem occur after an upgrade of XMBC?:
Did the problem occur after a Windows update/upgrade?:
How long have you used XMBC?:
What language and keyboard layout do you use in Windows?: Russia + English

Clear description of the problem:

Hello !

When you turn on the Russian keyboard layout, the assigned buttons 4 and 5 stop working.

nolimit59

User avatar
Killy
Dedicated
Posts: 42
Joined: Mon Nov 27, 2017 1:26 pm

Re: In the Russian keyboard does not work

Post by Killy » Fri Feb 15, 2019 11:41 am

You haven't described what actions you assigned to buttons 4 and 5, and what software you're trying to use them in.
Layout-dependent hotkeys issue is usually specific to "receiving side", so it might not work in some applications while work in all others. This happens when character code is checked instead of key code.
So it is most likely not XMouse issue.

-------

So far I can see that, when simulated keys are used:
- Latin letters are sent as key codes (will be typed in currently active layout, react to active modifier keys)
- non-Latin letters are sent as characters (will be typed as is, independent of current layout or modifier keys)

User avatar
nolimit59
New User
Posts: 2
Joined: Thu Feb 14, 2019 11:07 am

Re: In the Russian keyboard does not work

Post by nolimit59 » Fri Feb 15, 2019 7:55 pm

Key 4 and 5 - copy/paste
Key 4 : {CTRL}C
Key 5 : {CTRL}V
When you click the mouse button
When you turn on the Russian keyboard layout, assigned buttons 4 and 5 stop working if the Punto Switcher program is running.
When you turn off the program, Punto Switcher works fine.
:angel:
He cured himself.
Added in the settings of the program Punto Switcher in the exception clause: XMouseButtonControl.exe - and everything began to work as it should!
This is a Punto Switcher bug, incompatibility.

Post Reply