[Issues/REQ] Mouse Sense & Sim-key issues, No Scroll-lock key & Two REQs

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
Flugan
New User
Posts: 4
Joined: Sun Feb 10, 2019 12:54 am

[Issues/REQ] Mouse Sense & Sim-key issues, No Scroll-lock key & Two REQs

Post by Flugan » Sun Feb 10, 2019 2:17 am

XMBC Version: 2.18.2
Windows Version: W10 Pro
Mouse Information (brand/model): Logi G603/MX518
Computer Information: 980Ti, Ryz 2600@4.2Ghz
How long have you used XMBC?: Years.
What language and keyboard layout do you use in Windows?: Swe/Swe

Clear description of the problem:

1. My mouse sensitivity gets messed up by XMBC, doesnt matter if its on 4, 5 or 6. Would it be possible for you to add a check box which Globally disables ALL mouse sensitivity settings in XMBC? It doesnt use the Windows set-settings for some reason, but feels like it adds to it. So 6/10 in Windows + 6/10 = 12/10(Max). 200DPI can move all over 1440p in 2-3cm moves.

2. Would it be possible for the Dev/Admin to add a "command" in Simulated keys clearing ALL currently active simulated key presses? I use the following sim-key
AutoFire + Aiming in during hold wrote:{OR}{LMBD}{OD}{ACTIVATE}{PRESS}{OD}L{RELEASE}{OU}L{OU}{LMBU}
And the issue I've got is that I use "Shift" as a modifier-key to change to a neutral layer(For when I need to scope/use sniper rifles), ingame the shift button is also used to sprint. So sometimes when I need to Shoot followed by running({LMB}->Shift+W) the "Aiming In" is glitched and carries on Scoping. And since I have to use "Reset sticky buttons when the layer change"(On key/button pressed doesnt work since I need to be able to do both) to reset, I guess the sim-key command is bugged since I might be pressing Shift to run before I've released {LMB}. (For some reason "reset on button" is activated when when I use a Sim-key which is repeating a mouse button as well as a physical click).

3. A smart addition to "Sim-keys" which I would be appreciating the hell out of would be if you added a button/Hot-key in the client which adds {} to your current textfield-position. A fast mockup of what I mean: https://i.imgur.com/O3haXtQ.jpg (For some reason I cant link to pictures nor use the ['img']-tag they recommended in the FAQ). An extended feature would be if you could choose which button to add by right clicking it -> Drop-down menu with alternatives.

4. I haven't got Scroll lock at all on my keyboard (Wooting One), is there any way of "Setting F12 as Scroll Lock"?

User avatar
phil
Site Admin
Posts: 5888
Joined: Sun Apr 06, 2003 11:12 pm

Re: [Issues/REQ] Mouse Sense & Sim-key issues, No Scroll-lock key & Two REQs

Post by phil » Mon Feb 11, 2019 8:52 pm

Hi,

1. Yes I can probably add an option to completely disable all speed changes (but I would also like to try and reproduce the problem and understand why it is doing this - I presume this is new in 2.18.x?).

2. Urrr... trying to get my head around this one.. Sim keys run in a separate thread so there may be some timing/synchronization issues there but that's going to be tricky to diagnose. I wonder though, if the "Reset on any other button" should only apply to physical buttons and not simulated buttons (probably makes sense). I'm also not entirely sure how a "reset tag" would work. Care to explain that in more detail... Lets call it {reset} for now... Where would you put it in your sequence and how would it actually work?

3. Yes, a good idea. NOTE: I edited your post so the link works - new users need 4 or 5 posts before img/url links can be inserted (to combat spam bots).
4. An even better idea - may be able to do this but it will be <significantly> more work so may do 3 first and add 4 to a slower todo list!

NOTE: Just to be realistic, all the items on this list will certainly not be implemented in any 2.18 releases (they are limited to simple bug fixes only right now). In my mind right now, these are targets for 2.19 beta/test/release cycle (bar item 4 which may get pushed further out due to complexity)
Having said that I am concerned about item 1 and that may need to be either in a 2.18 bug patch or an early beta of 2.19. That really depends on if anyone else has the problem (I struggle to believe it could be affecting only one user - but no one else has said anything <yet>!)

Regards,
Phil.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply