Strange problem with Firefox

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
ghostwheel
New User
Posts: 1
Joined: Thu Nov 29, 2018 10:50 pm

Strange problem with Firefox

Post by ghostwheel » Thu Jan 31, 2019 3:35 am

XMBC Version: 2.18.2 portable
Windows Version: 10
Mouse Information (brand/model): Logitech G700s
Computer Information: Surface Book 2
Did the problem occur after an upgrade of XMBC or Windows?: no
How long have you used XMBC?: 3 month
What language and keyboard layout do you use in Windows?: Eng

Clear description of the problem:
This isn't directly a problem with XMBC. I have a logitech mouse and the touchpad on my laptop. Sadly XMBC can't switch behavior depending on the mouse. I use XMBC to reverse scrollwheel direction on my mouse. So my not perfect solution is to run XMBC whenever using the mouse, and exit when not. All works well when starting XMBC, but when quitting Firefox has a strange behavior. When I quit XMBC the touchpad scroll works very slowly. I have to exit firefox and then restart, and then it works ok again.

BTW: I know that XMBC doesn't know where the mouse movement comes from. But would it be possible to make a conditional layer switch that depends on whether a device is connected or maybe if a program is running? (I just noticed that scroll wheel invert is not layer dependent...)

User avatar
phil
Site Admin
Posts: 5959
Joined: Sun Apr 06, 2003 11:12 pm

Re: Strange problem with Firefox

Post by phil » Thu Jan 31, 2019 4:39 pm

None of the items on the scrolling (and options) tab are layer dependent. Only the stuff on the layer tab is layer dependent.

I don't know about disabling/enabling XMBC/Layers if a device is connected. In theory it must be possible but in practice Ive no idea how to do that - but I'm sure windows must broadcast some sort of "device" connect notification. Something to investigate.

I wonder if the scroll issue is because XMBC has changed the lines per scroll and exiting is resetting it (or breaking it). Will need to investigate
For now, rather than exiting XMBC, why not just setup a global hotkey to enable/disable XMBC?

I'm on holiday right now and will be out of the country for a week or so from tomorrow so I can do no more than reply at this point :).

Thanks
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

BradleyBarraza
New User
Posts: 1
Joined: Thu Mar 07, 2019 10:20 am

Re: Strange problem with Firefox

Post by BradleyBarraza » Thu Mar 07, 2019 10:38 am

If the script generates a file (blob) that contains a very long file name and encourages the user to download it every millisecond, this will lead to flooding on the IPC (Inter-Process Communication) channel between the main and child Firefox processes that will make the browser at least slown down.

User avatar
Dolmatov
Dedicated
Posts: 49
Joined: Tue Sep 19, 2017 9:19 pm

Re: Strange problem with Firefox

Post by Dolmatov » Thu Mar 07, 2019 6:42 pm

Try create profile for firefox and change scroll method for this profile.

Post Reply