Page 1 of 1

scrolling didn't work but then it did?

Posted: Mon Dec 31, 2018 3:16 pm
by MrCrackerplays
XMBC Version: X-Mouse Button Control v2.18 (x64)
Windows Version: Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
Mouse Information (brand/model): trust gxt 152
Computer Information: amd phenom II X4 945, 16gb ddr3, asrock 970 pro3, nvidia geforce gtx 970 msi
Did the problem occur after an upgrade of XMBC or Windows?:after upgrading xmbc but it didn't happen immediately right after updating
How long have you used XMBC?: according to the current log october 3918 (lol not sure why it doesn't say 2018) but that's because I reset my pc in october, I have been using it since april 2016
What language and keyboard layout do you use in Windows?: us international

Clear description of the problem: tldr; scrolling didn't scroll until I enabled an option but it stayed fixed even after disabling the option again
longer explanation: last night I was trying to prevent the scroll window under mouse thing if I have skyrim special edition open but it wasn't working so I tried updating xmbc (it was v2.17 before) which still didn't work so I gave up on trying, but when I started my pc again today nothing wanted to scroll like even if I was in the window itself it didn't scroll.
when I opened xmbc I saw the scroll buttons light up when I scrolled and I tested another mouse so I know it wasn't the mouse malfunctioning. restarting the computer and ending the xmbc process from task manager didn't work either. then I selected the "Force Scroll Pages/Line (If application does not respond to setting)" option and suddenly scrolling worked again and when I disabled the option again scrolling still worked.

so currently I don't have any problem with scrolling anymore but I thought I'd just report it just in case since it just seemed weird

Re: scrolling didn't work but then it did?

Posted: Wed Jan 02, 2019 3:19 pm
by phil
Thanks for the info, it does indeed sound weird but I have a feeling I may have seen this myself, and it just, inexplicably started working - which is not good but at least its working now. if anyone else has the problem hopefully they will see this post and perhaps add to it to provide more information. As always when I release a new version, the potential of more/new bugs is always there (although many have been testing 2.18 through various stages for over 6 months, some things slip through).

Keep an eye on if and if it happens again, it might be wroth turning on debug logging temporarily, that way you can send me the log and it may give up some more useful information as to what is causing the problem.